summaryrefslogtreecommitdiff
path: root/media-libs/cal3d
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/cal3d
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/cal3d')
-rw-r--r--media-libs/cal3d/Manifest1
-rw-r--r--media-libs/cal3d/cal3d-0.11.0-r1.ebuild57
-rw-r--r--media-libs/cal3d/files/cal3d-0.11.0-gcc43.patch10
-rw-r--r--media-libs/cal3d/files/cal3d-0.11.0-tests.patch11
-rw-r--r--media-libs/cal3d/files/cal3d-0.11.0-verbose.patch11
-rw-r--r--media-libs/cal3d/metadata.xml11
6 files changed, 101 insertions, 0 deletions
diff --git a/media-libs/cal3d/Manifest b/media-libs/cal3d/Manifest
new file mode 100644
index 00000000000..fd59d35f595
--- /dev/null
+++ b/media-libs/cal3d/Manifest
@@ -0,0 +1 @@
+DIST cal3d-0.11.0.tar.gz 568532 SHA256 fc4a6fe311004987377ec80b804a04aab44c32085fd974d275aa9d0b14144b06 SHA512 4dc4b36b8f18760bfe6f8c80cbd941c14e2ebe596d0cd514fdb1ae4175bf2706e125665272d67ff21d33bb4b34e7be22bad9c00d488c1da21f442550bf3f204f WHIRLPOOL cf6f1343556a97fe743482d6f34d147c7a68e77daf5f1ca7b4958da4b3cdd3e1c807b4eaaff7c26428e5e999733fc20c82b25ddc7dc56ae6ca58a92b61645457
diff --git a/media-libs/cal3d/cal3d-0.11.0-r1.ebuild b/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
new file mode 100644
index 00000000000..c8e8198cd26
--- /dev/null
+++ b/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Cal3D is a skeletal based character animation library"
+HOMEPAGE="http://home.gna.org/cal3d"
+SRC_URI="http://download.gna.org/cal3d/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86 ~x86-fbsd"
+IUSE="16bit-indices debug doc"
+
+DEPEND="doc? (
+ app-doc/doxygen
+ app-text/docbook-sgml-utils
+ )"
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-tests.patch \
+ "${FILESDIR}"/${P}-verbose.patch
+ sed -i \
+ -e "s:db2html:docbook2html:g" \
+ configure.in \
+ docs/Makefile.am \
+ || die "sed for doc failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable 16bit-indices)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ cd docs
+ emake doc-api
+ emake doc-guide
+ mkdir -p html/{guide,api}
+ mv *.{html,gif} html/guide/
+ mv api/html/* html/api/
+ fi
+}
+
+src_install() {
+ default
+ use doc && dohtml -r docs/html/api docs/html/guide
+}
diff --git a/media-libs/cal3d/files/cal3d-0.11.0-gcc43.patch b/media-libs/cal3d/files/cal3d-0.11.0-gcc43.patch
new file mode 100644
index 00000000000..80d73b27474
--- /dev/null
+++ b/media-libs/cal3d/files/cal3d-0.11.0-gcc43.patch
@@ -0,0 +1,10 @@
+--- src/cal3d/platform.h.old 2008-04-27 23:08:41.000000000 +0200
++++ src/cal3d/platform.h 2008-04-27 23:08:56.000000000 +0200
+@@ -77,6 +77,7 @@
+ // standard includes
+ #include <stdlib.h>
+ #include <math.h>
++#include <string.h>
+
+ // debug includes
+ #include <assert.h>
diff --git a/media-libs/cal3d/files/cal3d-0.11.0-tests.patch b/media-libs/cal3d/files/cal3d-0.11.0-tests.patch
new file mode 100644
index 00000000000..3a6754f4015
--- /dev/null
+++ b/media-libs/cal3d/files/cal3d-0.11.0-tests.patch
@@ -0,0 +1,11 @@
+--- tests/Makefile.am.old 2014-10-27 12:14:44.534607920 +0100
++++ tests/Makefile.am 2014-10-27 12:16:00.825891248 +0100
+@@ -14,7 +14,7 @@
+ EXTRA_DIST = \
+ $(wildcard cal3d_converter/base.??f)
+
+-TESTS_ENVIRONMENT = sh ./run
++LOG_COMPILER = sh ./run
+ TESTS = converter/skeleton converter/mesh converter/material converter/animation
+
+ .PHONY: ${TESTS}
diff --git a/media-libs/cal3d/files/cal3d-0.11.0-verbose.patch b/media-libs/cal3d/files/cal3d-0.11.0-verbose.patch
new file mode 100644
index 00000000000..a6dfbd677bf
--- /dev/null
+++ b/media-libs/cal3d/files/cal3d-0.11.0-verbose.patch
@@ -0,0 +1,11 @@
+--- tests/run.in.old 2012-06-29 13:27:55.413765822 +0200
++++ tests/run.in 2012-06-29 13:29:02.092084095 +0200
+@@ -43,7 +43,7 @@
+ exit 1
+ ;;
+ esac
+- $VERBOSE cal3d_converter ${srcdir}/cal3d_converter/base.x$ext
++ : cal3d_converter ${srcdir}/cal3d_converter/base.x$ext
+ ../src/cal3d_converter ${srcdir}/cal3d_converter/base.x$ext base.c$ext
+ ../src/cal3d_converter base.c$ext 01.x$ext
+ ../src/cal3d_converter 01.x$ext 01.c$ext
diff --git a/media-libs/cal3d/metadata.xml b/media-libs/cal3d/metadata.xml
new file mode 100644
index 00000000000..644e9bf3eaf
--- /dev/null
+++ b/media-libs/cal3d/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tupone@gentoo.org</email>
+ <name>Alfredo Tupone</name>
+ </maintainer>
+ <use>
+ <flag name="16bit-indices">Enables use of 16bit indices</flag>
+ </use>
+</pkgmetadata>