summaryrefslogtreecommitdiff
path: root/media-libs/fdk-aac
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-08-13 00:47:42 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-08-13 00:47:42 +0300
commit41aa5b030150c2b26db936dd21bd389581c26825 (patch)
tree41334f9e295c6314022b2ee404ba066f7ef13e01 /media-libs/fdk-aac
parentdb7625cc3c8155279a9cc2e2a7fcd0b77c4ca662 (diff)
downloadgentoo-41aa5b030150c2b26db936dd21bd389581c26825.tar.gz
gentoo-41aa5b030150c2b26db936dd21bd389581c26825.tar.xz
media-libs/fdk-aac: fix bug 483040
Rename aac-enc to avoid file collisions with other packages. Package-Manager: portage-2.3.0 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'media-libs/fdk-aac')
-rw-r--r--media-libs/fdk-aac/fdk-aac-0.1.2.ebuild11
-rw-r--r--media-libs/fdk-aac/fdk-aac-0.1.3.ebuild11
-rw-r--r--media-libs/fdk-aac/fdk-aac-0.1.4.ebuild11
3 files changed, 30 insertions, 3 deletions
diff --git a/media-libs/fdk-aac/fdk-aac-0.1.2.ebuild b/media-libs/fdk-aac/fdk-aac-0.1.2.ebuild
index b5cb38ba51b..c9fb62e6c14 100644
--- a/media-libs/fdk-aac/fdk-aac-0.1.2.ebuild
+++ b/media-libs/fdk-aac/fdk-aac-0.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -39,3 +39,12 @@ src_configure() {
)
autotools-multilib_src_configure
}
+
+src_install() {
+ autotools-multilib_src_install
+ use examples && mv "${ED}/usr/bin/aac-enc" "${ED}/usr/bin/fdk-aac-enc"
+}
+
+pkg_postinst() {
+ use examples && einfo "aac-enc was renamed to fdk-aac-enc to prevent file collision with other packages"
+}
diff --git a/media-libs/fdk-aac/fdk-aac-0.1.3.ebuild b/media-libs/fdk-aac/fdk-aac-0.1.3.ebuild
index 364207767e5..2a013f721bf 100644
--- a/media-libs/fdk-aac/fdk-aac-0.1.3.ebuild
+++ b/media-libs/fdk-aac/fdk-aac-0.1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -39,3 +39,12 @@ src_configure() {
)
autotools-multilib_src_configure
}
+
+src_install() {
+ autotools-multilib_src_install
+ use examples && mv "${ED}/usr/bin/aac-enc" "${ED}/usr/bin/fdk-aac-enc"
+}
+
+pkg_postinst() {
+ use examples && einfo "aac-enc was renamed to fdk-aac-enc to prevent file collision with other packages"
+}
diff --git a/media-libs/fdk-aac/fdk-aac-0.1.4.ebuild b/media-libs/fdk-aac/fdk-aac-0.1.4.ebuild
index f7da48059d2..3923033057d 100644
--- a/media-libs/fdk-aac/fdk-aac-0.1.4.ebuild
+++ b/media-libs/fdk-aac/fdk-aac-0.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -40,3 +40,12 @@ src_configure() {
)
autotools-multilib_src_configure
}
+
+src_install() {
+ autotools-multilib_src_install
+ use examples && mv "${ED}/usr/bin/aac-enc" "${ED}/usr/bin/fdk-aac-enc"
+}
+
+pkg_postinst() {
+ use examples && einfo "aac-enc was renamed to fdk-aac-enc to prevent file collision with other packages"
+}