summaryrefslogtreecommitdiff
path: root/media-libs/fmod
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/fmod
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/fmod')
-rw-r--r--media-libs/fmod/Manifest5
-rw-r--r--media-libs/fmod/fmod-3.75.ebuild34
-rw-r--r--media-libs/fmod/fmod-4.38.00.ebuild58
-rw-r--r--media-libs/fmod/fmod-4.38.02.ebuild58
-rw-r--r--media-libs/fmod/metadata.xml5
5 files changed, 160 insertions, 0 deletions
diff --git a/media-libs/fmod/Manifest b/media-libs/fmod/Manifest
new file mode 100644
index 00000000000..34f6cea7add
--- /dev/null
+++ b/media-libs/fmod/Manifest
@@ -0,0 +1,5 @@
+DIST fmodapi375linux.tar.gz 929710 SHA256 7ad978a44368ea41fcfd257da18466cc7df7cab2c3fbc16514943a4bb6dc875a
+DIST fmodapi43800linux.tar.gz 21990250 SHA256 1edf6a4a7782e093cd509b340c7e05ac9b50b37a9d56b792990232a13aa0ec56
+DIST fmodapi43800linux64.tar.gz 22276575 SHA256 9981cb1e146e4dc93d469dce061e15ef82fa1c94c425bdab683232bfa6a2160e
+DIST fmodapi43802linux.tar.gz 21992247 SHA256 9ef7eb3e277a53a69ea31206223fd27f01e236869568f83bfac97dbd9982a4fd
+DIST fmodapi43802linux64.tar.gz 22282269 SHA256 55e52603d2d53cd43467e086ea292928d66c741956c98266fd312a7936f1ba42
diff --git a/media-libs/fmod/fmod-3.75.ebuild b/media-libs/fmod/fmod-3.75.ebuild
new file mode 100644
index 00000000000..72872cd313a
--- /dev/null
+++ b/media-libs/fmod/fmod-3.75.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_P="fmodapi${PV/.}linux"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="music and sound effects library, and a sound processing system"
+HOMEPAGE="http://www.fmod.org/"
+SRC_URI="http://www.fmod.org/files/${MY_P}.tar.gz"
+
+LICENSE="BSD fmod-3.75" # BSD is for OggVorbis from README.txt
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+RESTRICT="strip"
+
+src_install() {
+ dolib api/libfmod-${PV}.so
+ dosym /usr/lib/libfmod-${PV}.so /usr/lib/libfmod.so
+
+ insinto /usr/include
+ doins api/inc/*
+
+ insinto /usr/share/${PN}/media
+ doins media/* || die "doins failed"
+ cp -r samples "${D}/usr/share/${PN}/" || die "cp failed"
+
+ dohtml -r documentation/*
+ dodoc README.TXT documentation/Revision.txt
+}
diff --git a/media-libs/fmod/fmod-4.38.00.ebuild b/media-libs/fmod/fmod-4.38.00.ebuild
new file mode 100644
index 00000000000..d36dad7272f
--- /dev/null
+++ b/media-libs/fmod/fmod-4.38.00.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator
+
+MY_P=fmodapi$(delete_all_version_separators)linux
+
+DESCRIPTION="music and sound effects library, and a sound processing system"
+HOMEPAGE="http://www.fmod.org"
+SRC_URI="x86? ( http://www.fmod.org/index.php/release/version/${MY_P}.tar.gz )
+ amd64? ( http://www.fmod.org/index.php/release/version/${MY_P}64.tar.gz )"
+
+LICENSE="BSD BSD-2 fmod"
+SLOT="1"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+RESTRICT="strip test"
+
+QA_FLAGS_IGNORED="opt/fmodex/tools/fsbanklib/.*"
+
+QA_TEXTRELS="opt/fmodex/fmoddesignerapi/api/lib/*
+opt/fmodex/api/lib/*"
+
+src_compile() { :; }
+src_install() {
+ dodir /opt/fmodex
+
+ local fbits=""
+ use amd64 && fbits="64"
+
+ local fsource="${WORKDIR}/${MY_P}${fbits}"
+
+ cd "${fsource}"/api/lib
+
+ cp -f libfmodex${fbits}-${PV}.so libfmodex.so.${PV} || die
+ ln -sf libfmodex.so.${PV} libfmodex.so || die
+ ln -sf libfmodex.so.${PV} libfmodex.so.4 || die
+
+ cp -f libfmodexL${fbits}-${PV}.so libfmodexL.so.${PV} || die
+ ln -sf libfmodexL.so.${PV} libfmodexL.so || die
+ ln -sf libfmodexL.so.${PV} libfmodexL.so.4 || die
+
+ cp -dpR "${fsource}"/* "${D}"/opt/fmodex || die
+
+ dosym /opt/fmodex/api/inc /usr/include/fmodex || die
+
+ use examples || rm -rf "${D}"/opt/fmodex/{,fmoddesignerapi}/examples
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins "${fsource}"/documentation/*.pdf
+ dodoc "${fsource}"/{documentation/*.txt,fmoddesignerapi/*.TXT}
+ rm -rf "${D}"/opt/fmodex/{documentation,fmoddesignerapi/*.TXT}
+
+ echo LDPATH="/opt/fmodex/api/lib" > "${T}"/65fmodex
+ doenvd "${T}"/65fmodex
+}
diff --git a/media-libs/fmod/fmod-4.38.02.ebuild b/media-libs/fmod/fmod-4.38.02.ebuild
new file mode 100644
index 00000000000..1c84c8d6084
--- /dev/null
+++ b/media-libs/fmod/fmod-4.38.02.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator
+
+MY_P=fmodapi$(delete_all_version_separators)linux
+
+DESCRIPTION="music and sound effects library, and a sound processing system"
+HOMEPAGE="http://www.fmod.org"
+SRC_URI="x86? ( http://www.fmod.org/index.php/release/version/${MY_P}.tar.gz )
+ amd64? ( http://www.fmod.org/index.php/release/version/${MY_P}64.tar.gz )"
+
+LICENSE="BSD BSD-2 fmod"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RESTRICT="strip test"
+
+QA_FLAGS_IGNORED="opt/fmodex/tools/fsbanklib/.*"
+
+QA_TEXTRELS="opt/fmodex/fmoddesignerapi/api/lib/*
+opt/fmodex/api/lib/*"
+
+src_compile() { :; }
+src_install() {
+ dodir /opt/fmodex
+
+ local fbits=""
+ use amd64 && fbits="64"
+
+ local fsource="${WORKDIR}/${MY_P}${fbits}"
+
+ cd "${fsource}"/api/lib
+
+ cp -f libfmodex${fbits}-${PV}.so libfmodex.so.${PV} || die
+ ln -sf libfmodex.so.${PV} libfmodex.so || die
+ ln -sf libfmodex.so.${PV} libfmodex.so.4 || die
+
+ cp -f libfmodexL${fbits}-${PV}.so libfmodexL.so.${PV} || die
+ ln -sf libfmodexL.so.${PV} libfmodexL.so || die
+ ln -sf libfmodexL.so.${PV} libfmodexL.so.4 || die
+
+ cp -dpR "${fsource}"/* "${D}"/opt/fmodex || die
+
+ dosym /opt/fmodex/api/inc /usr/include/fmodex || die
+
+ use examples || rm -rf "${D}"/opt/fmodex/{,fmoddesignerapi}/examples
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins "${fsource}"/documentation/*.pdf
+ dodoc "${fsource}"/{documentation/*.txt,fmoddesignerapi/*.TXT}
+ rm -rf "${D}"/opt/fmodex/{documentation,fmoddesignerapi/*.TXT}
+
+ echo LDPATH="/opt/fmodex/api/lib" > "${T}"/65fmodex
+ doenvd "${T}"/65fmodex
+}
diff --git a/media-libs/fmod/metadata.xml b/media-libs/fmod/metadata.xml
new file mode 100644
index 00000000000..e1774e3d9ad
--- /dev/null
+++ b/media-libs/fmod/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>