summaryrefslogtreecommitdiff
path: root/media-libs/gst-rtsp-server
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-09 10:05:08 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-09 12:08:18 +0200
commita6d58272259df8ba0ec17fdc92c0fcc3e7dae896 (patch)
treef4b87917a164fb61a95c74af3021407d42714a64 /media-libs/gst-rtsp-server
parenta6a9e33ab297850c6e143cda48b56f471e39a65e (diff)
downloadgentoo-a6d58272259df8ba0ec17fdc92c0fcc3e7dae896.tar.gz
gentoo-a6d58272259df8ba0ec17fdc92c0fcc3e7dae896.tar.xz
media-libs/gst-rtsp-server: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs/gst-rtsp-server')
-rw-r--r--media-libs/gst-rtsp-server/Manifest1
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.8.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-libs/gst-rtsp-server/Manifest b/media-libs/gst-rtsp-server/Manifest
index 9d01928e589..fe3d9d4b1fd 100644
--- a/media-libs/gst-rtsp-server/Manifest
+++ b/media-libs/gst-rtsp-server/Manifest
@@ -1,2 +1,3 @@
DIST gst-rtsp-0.10.8.tar.bz2 567670 SHA256 9915887cf8515bda87462c69738646afb715b597613edc7340477ccab63a6617 SHA512 c5020cffa9334b7d9c6b9dbe6f32bd4580eeee1c67689269d232e954ef9d96d8b988e3fb19da89701eae26419df0bf6de5796f7780cfbedda4c07154b1c1ebd7 WHIRLPOOL 6bd260edaef5ab003ef7176d84c46d5a94d365af51226108af9ab845d6e5910d90c721d5fd87e7fe93b141a82e5114b4c674a1d2500ef57302bf845c87f5463c
DIST gst-rtsp-server-1.6.2.tar.xz 560824 SHA256 0f51f9879556c0950203c766b09a1b62f1f25b17f9a7d516e01b13ecf93c8858 SHA512 853a26cde765f029c1d357092684a2c0b187c213e0877567b17f45727e179e110fd55484134bfee0dfd32b5af8fa8443c5cafac0aa6d445166fe3d12aa331354 WHIRLPOOL fba57cdb95926312f2e9d3db495ecffdd46962c758aafb606d18c900007561e8da7233da2939100ba7fd03d4d4c4605c72511a2cc26408e09aefd83f2d59e6ae
+DIST gst-rtsp-server-1.8.2.tar.xz 599944 SHA256 7d414cd4302ae253821dcb22d483fadc9d21cf96b5fd4c0a33fd41960f8e0459 SHA512 9573b7f440ac9885a7ca168b5e249994cc8534233058e6297d05c7e933388cf7e6ecd23acbf0793853557498e357c61877915cbc05c2e0a2796668bfaa0fb738 WHIRLPOOL c59548399e0025cb7d68d5769f6154472838af387259f9685d1242769f545b27ed160a65532f741d7b49e2f5e52ff0e9097dbf1cd31d7cecc6e54810bef37bf4
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.8.2.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.8.2.ebuild
new file mode 100644
index 00000000000..bedc2e771ca
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.8.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gstreamer
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="https://people.freedesktop.org/~wtay/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs test"
+
+# FIXME: check should depend on USE=test but check is losy
+# configure says good and bad are required by macros forces them to be optional
+# they are only used in unittests anyway.
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/check-0.9.2
+ >=dev-util/gtk-doc-am-1.12
+ virtual/pkgconfig
+ test? (
+ >=media-libs/gst-plugins-bad-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ )
+"
+
+# Due to gstreamer src_configure
+QA_CONFIGURE_OPTIONS="--enable-nls"
+
+multilib_src_configure() {
+ # debug: only adds -g to CFLAGS
+ # docbook: nothing behind that switch
+ # libcgroup is automagic and only used in examples
+ gstreamer_multilib_src_configure \
+ --disable-examples \
+ --disable-docbook \
+ --disable-gtk-doc \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ LIBCGROUP_LIBS= \
+ LIBCGROUP_FLAGS=
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi ; then
+ ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
+ fi
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+ # Handle broken upstream modifications to defaults of gtk-doc
+ emake install -C docs/libs DESTDIR="${D}"
+ prune_libtool_files
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}