summaryrefslogtreecommitdiff
path: root/media-libs/libbs2b
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libbs2b
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libbs2b')
-rw-r--r--media-libs/libbs2b/Manifest1
-rw-r--r--media-libs/libbs2b/files/3.1.0-format-security.patch11
-rw-r--r--media-libs/libbs2b/libbs2b-3.1.0-r1.ebuild23
-rw-r--r--media-libs/libbs2b/libbs2b-3.1.0-r2.ebuild27
-rw-r--r--media-libs/libbs2b/metadata.xml12
5 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/libbs2b/Manifest b/media-libs/libbs2b/Manifest
new file mode 100644
index 00000000000..199a852d103
--- /dev/null
+++ b/media-libs/libbs2b/Manifest
@@ -0,0 +1 @@
+DIST libbs2b-3.1.0.tar.bz2 606283 SHA256 4799974becdeeedf0db00115bc63f60ea3fe4b25f1dfdb6903505839a720e46f SHA512 50cf477ff9ce6adf26fa8a696831c3a4f219c80a21ec4c93be8ec3f67f077447c17abbd9588a9de5eeb3ddacac1564a7138807468fc80e853bc78f193b4afbc4 WHIRLPOOL c8703324bf54656af8533a5ce71234ca158f819498258426c5df2da87c4c4ebb0987217e1fecf39d5f510d9a96a6b6a7da0fa0c3db9c259b573448d35ba58374
diff --git a/media-libs/libbs2b/files/3.1.0-format-security.patch b/media-libs/libbs2b/files/3.1.0-format-security.patch
new file mode 100644
index 00000000000..1b9f9f97479
--- /dev/null
+++ b/media-libs/libbs2b/files/3.1.0-format-security.patch
@@ -0,0 +1,11 @@
+--- src/bs2bconvert.c.orig 2015-03-06 12:24:00.168451618 +0000
++++ src/bs2bconvert.c 2015-03-06 12:22:20.504446655 +0000
+@@ -153,7 +153,7 @@
+ if( ( infile = sf_open( infilename, SFM_READ, &sfinfo ) ) == NULL )
+ {
+ printf( "Not able to open input file %s.\n", infilename );
+- printf( sf_strerror( NULL ) );
++ printf( "%s", sf_strerror( NULL ) );
+ return 1;
+ }
+
diff --git a/media-libs/libbs2b/libbs2b-3.1.0-r1.ebuild b/media-libs/libbs2b/libbs2b-3.1.0-r1.ebuild
new file mode 100644
index 00000000000..56059f38fd3
--- /dev/null
+++ b/media-libs/libbs2b/libbs2b-3.1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-minimal
+
+DESCRIPTION="Bauer stereophonic-to-binaural DSP library"
+HOMEPAGE="http://bs2b.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bs2b/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/libsndfile-1.0.25-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# for default_src_configure to work
+ECONF_SOURCE="${S}"
diff --git a/media-libs/libbs2b/libbs2b-3.1.0-r2.ebuild b/media-libs/libbs2b/libbs2b-3.1.0-r2.ebuild
new file mode 100644
index 00000000000..38ab0d53bf5
--- /dev/null
+++ b/media-libs/libbs2b/libbs2b-3.1.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Bauer stereophonic-to-binaural DSP library"
+HOMEPAGE="http://bs2b.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bs2b/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/libsndfile-1.0.25-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# for default_src_configure to work
+ECONF_SOURCE="${S}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-format-security.patch"
+}
diff --git a/media-libs/libbs2b/metadata.xml b/media-libs/libbs2b/metadata.xml
new file mode 100644
index 00000000000..9ecb53a9d80
--- /dev/null
+++ b/media-libs/libbs2b/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">bs2b</remote-id>
+ </upstream>
+</pkgmetadata>