summaryrefslogtreecommitdiff
path: root/media-libs/libcdr
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-16 23:07:04 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-16 23:07:28 +0100
commitfd74bb1df142f5e3e33d33a8f0c95ca14fd58dc7 (patch)
tree9b7e77a72cfaf146624d7d201b68ba890134a7eb /media-libs/libcdr
parent75067f0b069743046827c0cd6cdd07138840b32b (diff)
downloadgentoo-fd74bb1df142f5e3e33d33a8f0c95ca14fd58dc7.tar.gz
gentoo-fd74bb1df142f5e3e33d33a8f0c95ca14fd58dc7.tar.xz
media-libs/libcdr: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-libs/libcdr')
-rw-r--r--media-libs/libcdr/Manifest1
-rw-r--r--media-libs/libcdr/libcdr-0.1.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/libcdr/Manifest b/media-libs/libcdr/Manifest
index ff1bb4f1f9d..cc1bdc98d76 100644
--- a/media-libs/libcdr/Manifest
+++ b/media-libs/libcdr/Manifest
@@ -2,3 +2,4 @@ DIST libcdr-0.0.14.tar.xz 570728 SHA256 720b693ba5e777f099f41ecd40418a16674ab29d
DIST libcdr-0.0.16.tar.xz 569644 SHA256 4c8a6586920f7b040ce51fa375eb87507291e0de4f568469db25f52915bc1135 SHA512 59b65b95806bce3c97c1a0762bb80ce0845e444a23b7b4683c74d6c0c9155664e7a7e558d787f6cfa69460f657e4d7416ae8e8947e426f04e369b42fc5da4838 WHIRLPOOL a0021dc4b8640fc2c192ead7b34a9c98536dcfcc2d13b65028768cb61a0ed96a163e8189a1b16751a62bdb7853d210fdfd9d3343870140eb6fe9cd95011c24af
DIST libcdr-0.1.0.tar.xz 562240 SHA256 a9bd1faca049cf1e2285b27da213a499434591919227beb209b191ad1bb240e8 SHA512 823c98a7185d5dd31bac240d007056f36fb290085efa3392d75f4ed26a4703ffeb2b9be0d9a19417473fb44c4e3abad7242773f5455431040bcfffc8aa51d18e WHIRLPOOL a1dfe38eec531eb10c01416aa7b83ec70c9736cba24aa6d2e4cf3f7f0bf0e6260f38d746663537b97c2875af9f9c87fa755d695effdb58a87cf2f3ee9f24eeb5
DIST libcdr-0.1.1.tar.xz 564668 SHA256 d0a6e0667e5a37fe059bcb81d5077fc2abffc7e7bac86fe302fbcf927d58df1f SHA512 a655b5390022fb5049d2f75fe836a693033943060d820942d59eb0a34548363ff183e0f32d22ec277d1f8b5c7ab89ab1fba933f17ef1239d14d053bd6a5cf624 WHIRLPOOL f7d5b6b1655f86ac3b843957e476ab17f2ef234bb5073678d182760cd6a370d24c98b14570474221d9f5ef9b24ffc76a5f4f82d596f466a7324dac95a04b9d77
+DIST libcdr-0.1.2.tar.xz 602024 SHA256 6bdb20bcdec5ad1a115d0a3aada7d4b2758e9d22801d72b4ecc2e55fb3d5d42c SHA512 c5c08444fa28be13b60ba1aa515a47606de80b079cbabb0276f54064820fecb2a6ee50a8b33a6cc1b2f5f46323d3de7f00822aadec5c3058a14adebf5255da91 WHIRLPOOL bd3137e234bfa37e82f121b431bb47c5fe5844d3ccf3d73b1aa5660ee732a2705fca0280777111f22bac4056f2f82be7df1e93eb6668dc7c4062727635d89b10
diff --git a/media-libs/libcdr/libcdr-0.1.2.ebuild b/media-libs/libcdr/libcdr-0.1.2.ebuild
new file mode 100644
index 00000000000..dd033dac872
--- /dev/null
+++ b/media-libs/libcdr/libcdr-0.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="Library parsing the Corel cdr documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ media-libs/lcms:2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ base_src_prepare
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}