summaryrefslogtreecommitdiff
path: root/media-libs/libdc1394/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libdc1394/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libdc1394/files')
-rw-r--r--media-libs/libdc1394/files/libdc1394-2.2.1-includes.patch29
-rw-r--r--media-libs/libdc1394/files/libdc1394-2.2.1-pthread.patch13
-rw-r--r--media-libs/libdc1394/files/libdc1394-usbinit.patch39
-rw-r--r--media-libs/libdc1394/files/libdc1394-videodev.h.patch53
4 files changed, 134 insertions, 0 deletions
diff --git a/media-libs/libdc1394/files/libdc1394-2.2.1-includes.patch b/media-libs/libdc1394/files/libdc1394-2.2.1-includes.patch
new file mode 100644
index 00000000000..db703e9c371
--- /dev/null
+++ b/media-libs/libdc1394/files/libdc1394-2.2.1-includes.patch
@@ -0,0 +1,29 @@
+Fix out of source builds.
+https://bugs.gentoo.org/show_bug.cgi?id=488716
+
+Index: libdc1394-2.2.1/dc1394/juju/Makefile.am
+===================================================================
+--- libdc1394-2.2.1.orig/dc1394/juju/Makefile.am
++++ libdc1394-2.2.1/dc1394/juju/Makefile.am
+@@ -7,7 +7,7 @@ noinst_LTLIBRARIES = libdc1394-juju.la
+ pkgjujuinclude_HEADERS =
+ endif
+
+-AM_CFLAGS = -I$(top_srcdir)/dc1394
++AM_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/dc1394
+ libdc1394_juju_la_SOURCES = \
+ control.c \
+ capture.c \
+Index: libdc1394-2.2.1/dc1394/usb/Makefile.am
+===================================================================
+--- libdc1394-2.2.1.orig/dc1394/usb/Makefile.am
++++ libdc1394-2.2.1/dc1394/usb/Makefile.am
+@@ -7,7 +7,7 @@ noinst_LTLIBRARIES = libdc1394-usb.la
+ pkgusbinclude_HEADERS =
+ endif
+
+-AM_CFLAGS = -I$(top_srcdir)/dc1394 $(LIBUSB_CFLAGS)
++AM_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/dc1394 $(LIBUSB_CFLAGS)
+ libdc1394_usb_la_LIBADD = $(LIBUSB_LIBS)
+ libdc1394_usb_la_SOURCES = \
+ control.c \
diff --git a/media-libs/libdc1394/files/libdc1394-2.2.1-pthread.patch b/media-libs/libdc1394/files/libdc1394-2.2.1-pthread.patch
new file mode 100644
index 00000000000..6ea7651e146
--- /dev/null
+++ b/media-libs/libdc1394/files/libdc1394-2.2.1-pthread.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/514008
+
+--- dc1394/usb/Makefile.am
++++ dc1394/usb/Makefile.am
+@@ -8,7 +8,7 @@
+ endif
+
+ AM_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/dc1394 $(LIBUSB_CFLAGS)
+-libdc1394_usb_la_LIBADD = $(LIBUSB_LIBS)
++libdc1394_usb_la_LIBADD = $(LIBUSB_LIBS) -lpthread
+ libdc1394_usb_la_SOURCES = \
+ control.c \
+ usb.h \
diff --git a/media-libs/libdc1394/files/libdc1394-usbinit.patch b/media-libs/libdc1394/files/libdc1394-usbinit.patch
new file mode 100644
index 00000000000..e94d25355ad
--- /dev/null
+++ b/media-libs/libdc1394/files/libdc1394-usbinit.patch
@@ -0,0 +1,39 @@
+diff --git a/libdc1394/dc1394/control.c b/libdc1394/dc1394/control.c
+index c62e0e2..f250f6a 100644
+--- a/libdc1394/dc1394/control.c
++++ b/libdc1394/dc1394/control.c
+@@ -1955,7 +1955,7 @@ dc1394_new (void)
+ windows_init (d);
+ #endif
+ #ifdef HAVE_LIBUSB
+- usb_init (d);
++ dc1394_usb_init (d);
+ #endif
+
+ int i;
+diff --git a/libdc1394/dc1394/internal.h b/libdc1394/dc1394/internal.h
+index b4d295a..c59e5d3 100644
+--- a/libdc1394/dc1394/internal.h
++++ b/libdc1394/dc1394/internal.h
+@@ -74,7 +74,7 @@ void juju_init(dc1394_t *d);
+ void linux_init(dc1394_t *d);
+ void macosx_init(dc1394_t *d);
+ void windows_init(dc1394_t *d);
+-void usb_init(dc1394_t *d);
++void dc1394_usb_init(dc1394_t *d);
+
+ void register_platform (dc1394_t * d, const platform_dispatch_t * dispatch,
+ const char * name);
+diff --git a/libdc1394/dc1394/usb/control.c b/libdc1394/dc1394/usb/control.c
+index 6509452..19a21a6 100644
+--- a/libdc1394/dc1394/usb/control.c
++++ b/libdc1394/dc1394/usb/control.c
+@@ -378,7 +378,7 @@ usb_dispatch = {
+ };
+
+ void
+-usb_init(dc1394_t * d)
++dc1394_usb_init(dc1394_t * d)
+ {
+ register_platform (d, &usb_dispatch, "usb");
+ }
diff --git a/media-libs/libdc1394/files/libdc1394-videodev.h.patch b/media-libs/libdc1394/files/libdc1394-videodev.h.patch
new file mode 100644
index 00000000000..dba42c46f0b
--- /dev/null
+++ b/media-libs/libdc1394/files/libdc1394-videodev.h.patch
@@ -0,0 +1,53 @@
+From 2ee7e7f98dd6225b40d5cd570c240504be7bc86a Mon Sep 17 00:00:00 2001
+From: David Moore <david.moore@gmail.com>
+Date: Sun, 27 Mar 2011 22:48:15 -0700
+Subject: [PATCH 1/1] Conditionally compile dc1394_vloopback only when linux/videodev.h exists
+
+---
+ libdc1394/ChangeLog | 3 +++
+ libdc1394/configure.in | 3 +++
+ libdc1394/examples/Makefile.am | 2 ++
+ 3 files changed, 8 insertions(+), 0 deletions(-)
+
+diff --git a/libdc1394/ChangeLog b/libdc1394/ChangeLog
+index e1355de..536ccae 100644
+--- a/libdc1394/ChangeLog
++++ b/libdc1394/ChangeLog
+@@ -1,3 +1,6 @@
++2011-03-27 David Moore <david.moore@gmail.com>
++ * Conditionally compile dc1394_vloopback only when linux/video.h exists
++
+ 2011-01-02 David Moore <david.moore@gmail.com>
+ * dc1394/conversions.h: Fix typo in DC1394_STEREO_METHOD_MIN
+ * Update NEWS, README, AUTHORS and version for release 2.1.3.
+diff --git a/libdc1394/configure.in b/libdc1394/configure.in
+index 69babab..bdddc9b 100644
+--- a/libdc1394/configure.in
++++ b/libdc1394/configure.in
+@@ -75,6 +75,9 @@ AM_CONDITIONAL(HAVE_WINDOWS, test x$have_windows = xtrue)
+ AM_CONDITIONAL(HAVE_LIBRAW1394, test x$libraw1394 = xtrue)
+ AM_CONDITIONAL(HAVE_LIBUSB, test "x$LIBUSB_LIBS" != "x")
+
++AC_CHECK_HEADER([linux/videodev.h], [have_videodev=true])
++AM_CONDITIONAL(HAVE_VIDEODEV, test x$have_videodev = xtrue)
++
+ AC_ARG_ENABLE([examples], [AS_HELP_STRING([--disable-examples], [don't build example programs])], [build_examples=$enableval], [build_examples=true])
+
+ AM_CONDITIONAL(MAKE_EXAMPLES, test x$build_examples = xtrue)
+diff --git a/libdc1394/examples/Makefile.am b/libdc1394/examples/Makefile.am
+index fcebf18..035612e 100644
+--- a/libdc1394/examples/Makefile.am
++++ b/libdc1394/examples/Makefile.am
+@@ -8,7 +8,9 @@ A = grab_gray_image grab_partial_image grab_color_image \
+ B = dc1394_reset_bus
+
+ if HAVE_LINUX
++if HAVE_VIDEODEV
+ B += dc1394_vloopback
++endif
+ if HAVE_XV
+ A += dc1394_multiview
+ endif
+--
+1.7.0.1
+