summaryrefslogtreecommitdiff
path: root/media-libs/libgltf
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libgltf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libgltf')
-rw-r--r--media-libs/libgltf/Manifest2
-rw-r--r--media-libs/libgltf/libgltf-0.0.1.ebuild51
-rw-r--r--media-libs/libgltf/libgltf-0.0.2.ebuild51
-rw-r--r--media-libs/libgltf/libgltf-9999.ebuild51
-rw-r--r--media-libs/libgltf/metadata.xml5
5 files changed, 160 insertions, 0 deletions
diff --git a/media-libs/libgltf/Manifest b/media-libs/libgltf/Manifest
new file mode 100644
index 00000000000..aa8ba7851df
--- /dev/null
+++ b/media-libs/libgltf/Manifest
@@ -0,0 +1,2 @@
+DIST libgltf-0.0.1.tar.bz2 348202 SHA256 2569bd6521a6afc53484746035478f1f8a8f002baa6c3d7ea83764e4db576345 SHA512 7009b9f9fcf4033bf4a884bbc017a740390418552495f2f2c940bdac43ecebb9899f6f4b3b18f28f6fca2f352992c61aeecccf3087ceb272891a8710e678268e WHIRLPOOL a89f7531705cbabb460b6890fbc99007a8cbde1d775a77531d467b5ab9e10d4867358c11ad7c35e2064f6236d906a7bfce569e23ac1b6f74b9e448444e053af6
+DIST libgltf-0.0.2.tar.bz2 538040 SHA256 d1cc7297ed1921aa969e26413b4c4e18afc882ce4d2f5a2aa2a2905706f7206b SHA512 74ca5e5e0f38ee5a67e870b49f4adf6c9710dc696afb776149618c05d15e3527d605143230f7ceacd199b609bcbb683cfc72d8e4ef22ba5b9ca777c8a2b53dcf WHIRLPOOL fbac1dc41cab63d4f322893d1b55d513fe8eefad5d625db703134dc429b3b87b5b6d36c481810d6e819c8f8213846b700d318421ac7858347c5ddf1cd875a246
diff --git a/media-libs/libgltf/libgltf-0.0.1.ebuild b/media-libs/libgltf/libgltf-0.0.1.ebuild
new file mode 100644
index 00000000000..93dde2e6e4c
--- /dev/null
+++ b/media-libs/libgltf/libgltf-0.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://gerrit.libreoffice.org/libgltf.git"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="C++ Library for rendering OpenGL models stored in glTF format"
+HOMEPAGE="http://www.libreoffice.org"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+RDEPEND="virtual/opengl"
+
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ media-libs/glew
+ media-libs/glm
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+
+# testsuite not in tarball
+# only in git; unsure
+RESTRICT="test"
+
+src_prepare() {
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-werror \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libgltf/libgltf-0.0.2.ebuild b/media-libs/libgltf/libgltf-0.0.2.ebuild
new file mode 100644
index 00000000000..2b4c8618f72
--- /dev/null
+++ b/media-libs/libgltf/libgltf-0.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://gerrit.libreoffice.org/libgltf.git"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="C++ Library for rendering OpenGL models stored in glTF format"
+HOMEPAGE="http://www.libreoffice.org"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="amd64 x86"
+IUSE="debug test"
+
+RDEPEND="virtual/opengl"
+
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ media-libs/glew
+ media-libs/glm
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+
+# testsuite not in tarball
+# only in git; unsure
+RESTRICT="test"
+
+src_prepare() {
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-werror \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libgltf/libgltf-9999.ebuild b/media-libs/libgltf/libgltf-9999.ebuild
new file mode 100644
index 00000000000..93dde2e6e4c
--- /dev/null
+++ b/media-libs/libgltf/libgltf-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://gerrit.libreoffice.org/libgltf.git"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="C++ Library for rendering OpenGL models stored in glTF format"
+HOMEPAGE="http://www.libreoffice.org"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+RDEPEND="virtual/opengl"
+
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ media-libs/glew
+ media-libs/glm
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+
+# testsuite not in tarball
+# only in git; unsure
+RESTRICT="test"
+
+src_prepare() {
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-werror \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libgltf/metadata.xml b/media-libs/libgltf/metadata.xml
new file mode 100644
index 00000000000..5d46203011d
--- /dev/null
+++ b/media-libs/libgltf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+</pkgmetadata>