summaryrefslogtreecommitdiff
path: root/media-libs/liblastfm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/liblastfm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/liblastfm')
-rw-r--r--media-libs/liblastfm/Manifest2
-rw-r--r--media-libs/liblastfm/liblastfm-1.0.8.ebuild50
-rw-r--r--media-libs/liblastfm/liblastfm-1.0.9.ebuild85
-rw-r--r--media-libs/liblastfm/metadata.xml11
4 files changed, 148 insertions, 0 deletions
diff --git a/media-libs/liblastfm/Manifest b/media-libs/liblastfm/Manifest
new file mode 100644
index 00000000000..5e99ee04bf6
--- /dev/null
+++ b/media-libs/liblastfm/Manifest
@@ -0,0 +1,2 @@
+DIST liblastfm-1.0.8.tar.gz 119186 SHA256 e36f4f83428ede7021187fe6042db5a1919a579b071a75420364ef7115434607 SHA512 afeea48e4b859a0ce126889258b1f8b9a33224595c8b1d3f791559f854c0f895a0eb6dc5e6295bd5f0fe44d2a706b4b2602d5810d446d588db721f9c2b22af29 WHIRLPOOL b4ec8ed1d3f392a38d82c6a10d100032a62d35e316ad6a5f00b3f7b2e61d81030104ce4eafe8010329b91a81daeca68b89c78996d3ee8d3e586e9df3be74d2b4
+DIST liblastfm-1.0.9.tar.gz 119320 SHA256 5276b5fe00932479ce6fe370ba3213f3ab842d70a7d55e4bead6e26738425f7b SHA512 9d2bcf71b26d8a95920a07649c97b3faa071c49a8269268bb08fab01537392774873233d03cada09d3ce3fe2c45b0affdb74cd27c41f69342b973896effe1018 WHIRLPOOL 491b50ec174d0a344221f12da9c783cfe56fffa99bfe3b84d835a70a510a3157dfecc62f2fff086cd570fb7281ecefe2b05c6982336f27ca6c1db6ccc4bd55dc
diff --git a/media-libs/liblastfm/liblastfm-1.0.8.ebuild b/media-libs/liblastfm/liblastfm-1.0.8.ebuild
new file mode 100644
index 00000000000..066de33a4e6
--- /dev/null
+++ b/media-libs/liblastfm/liblastfm-1.0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+QT_MINIMAL="4.8.0"
+inherit cmake-utils
+
+DESCRIPTION="A Qt C++ library for the Last.fm webservices"
+HOMEPAGE="https://github.com/lastfm/liblastfm"
+SRC_URI="https://github.com/lastfm/liblastfm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="fingerprint test"
+
+COMMON_DEPEND="
+ >=dev-qt/qtcore-${QT_MINIMAL}:4
+ >=dev-qt/qtdbus-${QT_MINIMAL}:4
+ fingerprint? (
+ media-libs/libsamplerate
+ sci-libs/fftw:3.0
+ >=dev-qt/qtsql-${QT_MINIMAL}:4
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-qt/qttest-${QT_MINIMAL}:4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/lastfmlib-0.4.0
+"
+
+# 1 of 2 is failing, last checked version 1.0.7
+RESTRICT="test"
+
+src_configure() {
+ # demos not working
+ # qt5 support broken
+ local mycmakeargs=(
+ -DBUILD_DEMOS=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Core=ON
+ -DBUILD_WITH_QT4=ON
+ $(cmake-utils_use_build fingerprint)
+ $(cmake-utils_use_build test TESTS)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/media-libs/liblastfm/liblastfm-1.0.9.ebuild b/media-libs/liblastfm/liblastfm-1.0.9.ebuild
new file mode 100644
index 00000000000..d01b0fd340c
--- /dev/null
+++ b/media-libs/liblastfm/liblastfm-1.0.9.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multibuild
+
+DESCRIPTION="Collection of libraries to integrate Last.fm services"
+HOMEPAGE="https://github.com/lastfm/liblastfm"
+SRC_URI="https://github.com/lastfm/liblastfm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0/0"
+IUSE="fingerprint test +qt4 qt5"
+
+REQUIRED_USE="|| ( qt4 qt5 )"
+
+COMMON_DEPEND="
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ )
+ fingerprint? (
+ media-libs/libsamplerate
+ sci-libs/fftw:3.0
+ qt4? ( dev-qt/qtsql:4 )
+ qt5? ( dev-qt/qtsql:5 )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ test? (
+ qt4? ( dev-qt/qttest:4 )
+ qt5? ( dev-qt/qttest:5 )
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/lastfmlib-0.4.0
+"
+
+# 1 of 2 (UrlBuilderTest) is failing, last checked version 1.0.9
+RESTRICT="test"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt4) $(usev qt5) )
+}
+
+src_configure() {
+ myconfigure() {
+ # demos not working
+ local mycmakeargs=(
+ -DBUILD_DEMOS=OFF
+ $(cmake-utils_use_build fingerprint)
+ $(cmake-utils_use_build test TESTS)
+ )
+ if [[ ${MULTIBUILD_VARIANT} = qt4 ]]; then
+ mycmakeargs+=(-DBUILD_WITH_QT4=ON)
+ fi
+ if [[ ${MULTIBUILD_VARIANT} = qt5 ]]; then
+ mycmakeargs+=(-DBUILD_WITH_OT4=OFF)
+ fi
+ cmake-utils_src_configure
+ }
+
+ multibuild_foreach_variant myconfigure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake-utils_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake-utils_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant cmake-utils_src_install
+}
diff --git a/media-libs/liblastfm/metadata.xml b/media-libs/liblastfm/metadata.xml
new file mode 100644
index 00000000000..b0a55507f56
--- /dev/null
+++ b/media-libs/liblastfm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="fingerprint">Build the lastfm-fingerprint library</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">lastfm/liblastfm</remote-id>
+ </upstream>
+</pkgmetadata>