summaryrefslogtreecommitdiff
path: root/media-libs/liblo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/liblo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/liblo')
-rw-r--r--media-libs/liblo/Manifest3
-rw-r--r--media-libs/liblo/files/liblo-0.27-no-threads.patch15
-rw-r--r--media-libs/liblo/liblo-0.26.ebuild35
-rw-r--r--media-libs/liblo/liblo-0.27.ebuild43
-rw-r--r--media-libs/liblo/liblo-0.28.ebuild41
-rw-r--r--media-libs/liblo/metadata.xml9
6 files changed, 146 insertions, 0 deletions
diff --git a/media-libs/liblo/Manifest b/media-libs/liblo/Manifest
new file mode 100644
index 00000000000..e84b7bb0b14
--- /dev/null
+++ b/media-libs/liblo/Manifest
@@ -0,0 +1,3 @@
+DIST liblo-0.26.tar.gz 519750 SHA256 a636fb09f8178ad0d5303e94fec37b182d3062a0e3daee85eed2a39ab6232258 SHA512 5bc720be216b796587ee020cc32bdea760c65ee063a1248a44bb7c800c1a91b5e5a1321b55c61fd3b219aecb0d8cfb4d6bf53a6440d46fd59e8697c63e542215 WHIRLPOOL 4fcfa3dbfe8bbb8887eb18a17c3d3e3d532b9386dd83bbe9fd0d1c075fbf556b7abca626f415b60d69e92df49d7dafc2874d43e83f14bec8990b609ca4f5fe3e
+DIST liblo-0.27.tar.gz 533684 SHA256 67b48e1e63fddea60bb4a0f0c25fba32ea42d2a55877752aa342c478b59374b6 SHA512 079f12d349d7fb58d4f7393d2ad72ca6844570524992c56ce87b23531620c2387ac6ba5316f92684b3fae72c7a5abe03e49fcbd97196efdb35d11a2422b065bc WHIRLPOOL efce8f9fca4828338778e120a795cc998cf8dee9bb17477891907d77cf3a5e9c203bca7f0ef201810a0e148e4fabe7086d1093d781d05e31cfa52c863dc476dd
+DIST liblo-0.28.tar.gz 591659 SHA256 da94a9b67b93625354dd89ff7fe31e5297fc9400b6eaf7378c82ee1caf7db909 SHA512 05818218d2d6a7042714b8fa905e7242fb9707795ad53ea27b2a1af3661f0822d25585ce17d286aa269c534ef24e19e377e041bf7fe194c8e47c0046fefcb85f WHIRLPOOL 5de1592d2fe8aee191115ed5b094dd8bb0ca5ec442c94e785c2bc74bef93f3df0dd8804c8aa2a1c3b1a1ce70729fa87c73cd4b09f3535300548999687b9a1ab5
diff --git a/media-libs/liblo/files/liblo-0.27-no-threads.patch b/media-libs/liblo/files/liblo-0.27-no-threads.patch
new file mode 100644
index 00000000000..5e3ebe8e43a
--- /dev/null
+++ b/media-libs/liblo/files/liblo-0.27-no-threads.patch
@@ -0,0 +1,15 @@
+--- liblo-0.27/examples/Makefile.am
++++ liblo-0.27/examples/Makefile.am
+@@ -3,10 +3,9 @@
+ # Example server depends on server threads, so skip it if threads are
+ # disabled.
+
+-noinst_PROGRAMS = example_client nonblocking_server_example \
+- example_tcp_echo_server
++noinst_PROGRAMS = example_client nonblocking_server_example
+ if ENABLE_THREADS
+-noinst_PROGRAMS += example_server
++noinst_PROGRAMS += example_server example_tcp_echo_server
+ endif
+
+ AM_CFLAGS = -Wall -I@top_srcdir@
diff --git a/media-libs/liblo/liblo-0.26.ebuild b/media-libs/liblo/liblo-0.26.ebuild
new file mode 100644
index 00000000000..cc73d72e967
--- /dev/null
+++ b/media-libs/liblo/liblo-0.26.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
+HOMEPAGE="http://plugin.org.uk/liblo"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~ppc-macos"
+IUSE="doc ipv6 static-libs"
+
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_configure() {
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/liblo/liblo-0.27.ebuild b/media-libs/liblo/liblo-0.27.ebuild
new file mode 100644
index 00000000000..7853e82eb08
--- /dev/null
+++ b/media-libs/liblo/liblo-0.27.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
+HOMEPAGE="http://plugin.org.uk/liblo"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="doc ipv6 static-libs"
+
+RESTRICT="test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-threads.patch
+
+ # don't build examples by default
+ sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ # switching threads on/off breaks ABI, bugs #473282, #473286 and #473356
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable ipv6) \
+ --enable-threads
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/liblo/liblo-0.28.ebuild b/media-libs/liblo/liblo-0.28.ebuild
new file mode 100644
index 00000000000..4fcb9d244fa
--- /dev/null
+++ b/media-libs/liblo/liblo-0.28.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
+HOMEPAGE="http://plugin.org.uk/liblo"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="doc ipv6 static-libs"
+
+RESTRICT="test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # don't build examples by default
+ sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ # switching threads on/off breaks ABI, bugs #473282, #473286 and #473356
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable ipv6) \
+ --enable-threads
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/liblo/metadata.xml b/media-libs/liblo/metadata.xml
new file mode 100644
index 00000000000..2d400e11954
--- /dev/null
+++ b/media-libs/liblo/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription>liblo is an implementation of the Open Sound Control protocol for POSIX systems, started by Steve Harris.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">liblo</remote-id>
+ </upstream>
+</pkgmetadata>