summaryrefslogtreecommitdiff
path: root/media-libs/libnjb
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libnjb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libnjb')
-rw-r--r--media-libs/libnjb/Manifest2
-rw-r--r--media-libs/libnjb/files/libnjb.rules35
-rw-r--r--media-libs/libnjb/libnjb-2.2.6.ebuild42
-rw-r--r--media-libs/libnjb/libnjb-2.2.7.ebuild44
-rw-r--r--media-libs/libnjb/metadata.xml8
5 files changed, 131 insertions, 0 deletions
diff --git a/media-libs/libnjb/Manifest b/media-libs/libnjb/Manifest
new file mode 100644
index 00000000000..163d3ac9f81
--- /dev/null
+++ b/media-libs/libnjb/Manifest
@@ -0,0 +1,2 @@
+DIST libnjb-2.2.6.tar.gz 504329 SHA256 c6eabf1fd3d32af6d3707574e1891919b25c3af35cadfc093456c00bccf3826e
+DIST libnjb-2.2.7.tar.gz 497862 SHA256 ccbcfc870bdc10ad7a144f81a340b61bad74a6f00f77cf08db5866332668d2b6
diff --git a/media-libs/libnjb/files/libnjb.rules b/media-libs/libnjb/files/libnjb.rules
new file mode 100644
index 00000000000..2ad3227d7b2
--- /dev/null
+++ b/media-libs/libnjb/files/libnjb.rules
@@ -0,0 +1,35 @@
+SUBSYSTEM!="usb_device", GOTO="libnjb_rules_end"
+ACTION!="add", GOTO="libnjb_rules_end"
+
+# Creative Nomad Jukebox
+ATTRS{idVendor}=="0471", ATTRS{idProduct}=="0222", GROUP="plugdev", MODE="0660"
+# Creative Nomad Jukebox 2
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="4100", GROUP="plugdev", MODE="0660"
+# Creative Nomad Jukebox 3
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="4101", GROUP="plugdev", MODE="0660"
+# Creative Nomad Jukebox Zen
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="4108", GROUP="plugdev", MODE="0660"
+# Creative Nomad Jukebox Zen USB 2.0
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="410b", GROUP="plugdev", MODE="0660"
+# Creative Nomad Jukebox Zen NX
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="4109", GROUP="plugdev", MODE="0660"
+# Creative Nomad Jukebox Zen Xtra
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="4110", GROUP="plugdev", MODE="0660"
+# Dell Digital Jukebox
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="4111", GROUP="plugdev", MODE="0660"
+# Creative Nomad Jukebox Zen Touch
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="411b", GROUP="plugdev", MODE="0660"
+# Creative Zen (Zen Micro variant)
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="411d", GROUP="plugdev", MODE="0660"
+# Creative Nomad Jukebox Zen Micro
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="411e", GROUP="plugdev", MODE="0660"
+# Second Generation Dell Digital Jukebox
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="4126", GROUP="plugdev", MODE="0660"
+# Dell Pocket DJ
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="4127", GROUP="plugdev", MODE="0660"
+# Creative Zen Sleek
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="4136", GROUP="plugdev", MODE="0660"
+# Third Generation Dell Digital Jukebox
+ATTRS{idVendor}=="041e", ATTRS{idProduct}=="412f", GROUP="plugdev", MODE="0660"
+
+LABEL="libnjb_rules_end"
diff --git a/media-libs/libnjb/libnjb-2.2.6.ebuild b/media-libs/libnjb/libnjb-2.2.6.ebuild
new file mode 100644
index 00000000000..47d76b9949f
--- /dev/null
+++ b/media-libs/libnjb/libnjb-2.2.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit libtool multilib udev
+
+DESCRIPTION="a C library and API for communicating with the Creative Nomad JukeBox digital audio player"
+HOMEPAGE="http://libnjb.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:SUBDIRS = src sample doc:SUBDIRS = src doc:' \
+ Makefile.in || die
+
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog* FAQ HACKING README
+
+ udev_newrules "${FILESDIR}"/${PN}.rules 80-${PN}.rules
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
diff --git a/media-libs/libnjb/libnjb-2.2.7.ebuild b/media-libs/libnjb/libnjb-2.2.7.ebuild
new file mode 100644
index 00000000000..27441704c86
--- /dev/null
+++ b/media-libs/libnjb/libnjb-2.2.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit libtool multilib udev
+
+DESCRIPTION="a C library and API for communicating with the Creative Nomad JukeBox digital audio player"
+HOMEPAGE="http://libnjb.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc static-libs"
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS ChangeLog* FAQ HACKING README"
+
+src_prepare() {
+ sed -i \
+ -e 's:SUBDIRS = src sample doc:SUBDIRS = src doc:' \
+ Makefile.in || die
+
+ elibtoolize
+}
+
+src_configure() {
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ udev_newrules "${FILESDIR}"/${PN}.rules 80-${PN}.rules
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/media-libs/libnjb/metadata.xml b/media-libs/libnjb/metadata.xml
new file mode 100644
index 00000000000..6a6641a7fe2
--- /dev/null
+++ b/media-libs/libnjb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">libnjb</remote-id>
+ </upstream>
+</pkgmetadata>