summaryrefslogtreecommitdiff
path: root/media-libs/libopenraw
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libopenraw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libopenraw')
-rw-r--r--media-libs/libopenraw/Manifest1
-rw-r--r--media-libs/libopenraw/files/libopenraw-0.0.9-jpeg-9a.patch23
-rw-r--r--media-libs/libopenraw/libopenraw-0.0.9.ebuild56
-rw-r--r--media-libs/libopenraw/metadata.xml8
4 files changed, 88 insertions, 0 deletions
diff --git a/media-libs/libopenraw/Manifest b/media-libs/libopenraw/Manifest
new file mode 100644
index 00000000000..3acd570a30f
--- /dev/null
+++ b/media-libs/libopenraw/Manifest
@@ -0,0 +1 @@
+DIST libopenraw-0.0.9.tar.bz2 478687 SHA256 49fd1adf0a0228c7a17a79bf98d8d03664195feae1e50f4ddd1b20162626e18f SHA512 88d475d27719212686a0a5a08da04d6879fd456ec8f7531f401217df97f4f3d4c52dc8c4fb1c6ca88c12d6a67ecd516b151c5e9dceba9cbfcd13150fe81d6db5 WHIRLPOOL 52d407b1d443fe7c38c59274b3267feb4dffeca9114a39cad925c346ae21d1378cbceba4ce1973657073f8890bf50a18c476ba3451d806fe7f50824bb935c559
diff --git a/media-libs/libopenraw/files/libopenraw-0.0.9-jpeg-9a.patch b/media-libs/libopenraw/files/libopenraw-0.0.9-jpeg-9a.patch
new file mode 100644
index 00000000000..bfb99fab974
--- /dev/null
+++ b/media-libs/libopenraw/files/libopenraw-0.0.9-jpeg-9a.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/520888
+http://sourceforge.net/p/fink/package-submissions/4336/
+
+--- lib/jfifcontainer.cpp
++++ lib/jfifcontainer.cpp
+@@ -145,7 +145,7 @@
+ {
+ int ret = 0;
+ if (::setjmp(m_jpegjmp) == 0) {
+- ret = JPEG::jpeg_read_header(&m_cinfo, TRUE);
++ ret = JPEG::jpeg_read_header(&m_cinfo, JPEG::TRUE);
+ //Trace(DEBUG1) << "jpeg_read_header " << ret << "\n";
+
+ JPEG::jpeg_calc_output_dimensions(&m_cinfo);
+@@ -181,7 +181,7 @@
+ src->pub.next_input_byte = NULL;
+ src->pub.bytes_in_buffer = 0;
+ }
+- return TRUE;
++ return JPEG::TRUE;
+ }
+
+
diff --git a/media-libs/libopenraw/libopenraw-0.0.9.ebuild b/media-libs/libopenraw/libopenraw-0.0.9.ebuild
new file mode 100644
index 00000000000..de1481577bc
--- /dev/null
+++ b/media-libs/libopenraw/libopenraw-0.0.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils
+
+DESCRIPTION="A decoding library for RAW image formats"
+HOMEPAGE="http://libopenraw.freedesktop.org/wiki/"
+SRC_URI="http://${PN}.freedesktop.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="gtk static-libs test"
+
+RDEPEND="virtual/jpeg:0
+ dev-libs/libxml2
+ gtk? (
+ >=dev-libs/glib-2
+ >=x11-libs/gdk-pixbuf-2.24.0:2
+ )"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.35
+ virtual/pkgconfig
+ test? ( net-misc/curl )"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ has_version '>=media-libs/jpeg-9a:0' && epatch "${FILESDIR}"/${P}-jpeg-9a.patch
+}
+
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}"/usr \
+ $(use_enable static-libs static) \
+ $(use_enable gtk gnome)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_preinst() {
+ gnome2_gdk_pixbuf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gdk_pixbuf_update
+}
+
+pkg_postinst() {
+ gnome2_gdk_pixbuf_update
+}
diff --git a/media-libs/libopenraw/metadata.xml b/media-libs/libopenraw/metadata.xml
new file mode 100644
index 00000000000..8c868061b73
--- /dev/null
+++ b/media-libs/libopenraw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>freedesktop</herd>
+<maintainer>
+<email>freedesktop-bugs@gentoo.org</email>
+</maintainer>
+</pkgmetadata>