summaryrefslogtreecommitdiff
path: root/media-libs/libpgf
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libpgf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libpgf')
-rw-r--r--media-libs/libpgf/Manifest2
-rw-r--r--media-libs/libpgf/libpgf-6.11.32.ebuild39
-rw-r--r--media-libs/libpgf/libpgf-6.12.27.ebuild37
-rw-r--r--media-libs/libpgf/metadata.xml5
4 files changed, 83 insertions, 0 deletions
diff --git a/media-libs/libpgf/Manifest b/media-libs/libpgf/Manifest
new file mode 100644
index 00000000000..996e84ce184
--- /dev/null
+++ b/media-libs/libpgf/Manifest
@@ -0,0 +1,2 @@
+DIST libpgf-6.11.32.tar.bz2 83174 SHA256 b722ef0f60c95aed195a2abc65d066fd815e926936875c912904607f2608fc05 SHA512 2e2a181d01821e8888b0edfd697f0ef8dddc9b4d07b8245dfac22c2c5f1b6f1768ab0de47fce3cb039b788a0c8b115f7e8c45f8ecf9d3f5eeb9c38241134490e WHIRLPOOL 004e63f2beea6ead3ec1b28fb1adf6043e3baba55400201a63cbda842364ecd53796d2e2e30add1eff44d6d62f98b5dffafc66ad4260dee2aa6fdcf86c262008
+DIST libpgf-6.12.27.tar.bz2 1235651 SHA256 d6be17025c99390093f23570cf3759edc0f26faf2a968c796a3849c339046670 SHA512 ad06b34d61219a61d06b87e05a26e8639cd7a93211943217832969c03c4dbc81fbbb287fa2d628b7e087b96e78665a3cbc78920c8ff5828dfb2a7748e04fe42a WHIRLPOOL a552665a4e5f3598c08afd61125892b1fc542508ee9d4f8517883b9398a916fbb928ac67e474459f55a55afea3ca67c9eeaaa9afed09e35815d54aa724b0ef56
diff --git a/media-libs/libpgf/libpgf-6.11.32.ebuild b/media-libs/libpgf/libpgf-6.11.32.ebuild
new file mode 100644
index 00000000000..43530dcc553
--- /dev/null
+++ b/media-libs/libpgf/libpgf-6.11.32.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="Library to load, handle and manipulate images in the PGF format"
+HOMEPAGE="http://www.libpgf.org/"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ if ! use doc; then
+ sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libpgf/libpgf-6.12.27.ebuild b/media-libs/libpgf/libpgf-6.12.27.ebuild
new file mode 100644
index 00000000000..ec4650d1893
--- /dev/null
+++ b/media-libs/libpgf/libpgf-6.12.27.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="Library to load, handle and manipulate images in the PGF format"
+HOMEPAGE="http://www.libpgf.org/"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ app-arch/unzip"
+
+src_prepare() {
+ if ! use doc; then
+ sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libpgf/metadata.xml b/media-libs/libpgf/metadata.xml
new file mode 100644
index 00000000000..9be90a25897
--- /dev/null
+++ b/media-libs/libpgf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+</pkgmetadata>