summaryrefslogtreecommitdiff
path: root/media-libs/libprojectm-qt
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libprojectm-qt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libprojectm-qt')
-rw-r--r--media-libs/libprojectm-qt/Manifest1
-rw-r--r--media-libs/libprojectm-qt/files/libprojectm-qt-2.1.0-multilib.patch14
-rw-r--r--media-libs/libprojectm-qt/libprojectm-qt-2.1.0-r1.ebuild29
-rw-r--r--media-libs/libprojectm-qt/metadata.xml8
4 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/libprojectm-qt/Manifest b/media-libs/libprojectm-qt/Manifest
new file mode 100644
index 00000000000..455b2574a17
--- /dev/null
+++ b/media-libs/libprojectm-qt/Manifest
@@ -0,0 +1 @@
+DIST projectM-qt-2.1.0-Source.tar.gz 100928 SHA256 1dbc281f8f96d50380781259fb61a6f3b6b53fc5c07a6866acf89a9d220214b3 SHA512 fe3f88941da763086a20dbb8a32d25081361a39cb98a87467b06a98c87e3d3c05db555b357974c376ee1d0af01efcec4b1522405d8bd5b7c9860ccecdfb4a887 WHIRLPOOL 7d99f0702ca740ccd04c8da08e071e510f2302336efb894fbfbf6d19f0880bee25ad8dbba714828b342382508eba60d24625c241c9bac7c481fef85bcb34ccd8
diff --git a/media-libs/libprojectm-qt/files/libprojectm-qt-2.1.0-multilib.patch b/media-libs/libprojectm-qt/files/libprojectm-qt-2.1.0-multilib.patch
new file mode 100644
index 00000000000..99c5b25068c
--- /dev/null
+++ b/media-libs/libprojectm-qt/files/libprojectm-qt-2.1.0-multilib.patch
@@ -0,0 +1,14 @@
+diff --git a/src/projectM-qt/CMakeLists.txt b/src/projectM-qt/CMakeLists.txt
+index 750d1ed..ed14840 100644
+--- a/src/projectM-qt/CMakeLists.txt
++++ b/src/projectM-qt/CMakeLists.txt
+@@ -131,6 +131,6 @@ include_directories(${PROJECTM_INCLUDE} ${QT_INCLUDE_DIR} ${QT_QTGUI_INCLUDE_DIR
+ target_link_libraries(projectM-qt projectM GLEW GL ${QT_QTGUI_LIBRARIES} ${QT_QTOPENGL_LIBRARIES} ${QT_QTXML_LIBRARIES} ${QT_LIBRARIES})
+
+ install(FILES qprojectm_mainwindow.hpp DESTINATION include/libprojectM-qt)
+-install(TARGETS projectM-qt DESTINATION lib)
+-install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libprojectM-qt.pc" DESTINATION lib/pkgconfig)
++install(TARGETS projectM-qt DESTINATION lib${LIB_SUFFIX})
++install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libprojectM-qt.pc" DESTINATION lib${LIB_SUFFIX}/pkgconfig)
+ install(FILES "images/icons/prjm16-transparent.svg" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/pixmaps)
+
diff --git a/media-libs/libprojectm-qt/libprojectm-qt-2.1.0-r1.ebuild b/media-libs/libprojectm-qt/libprojectm-qt-2.1.0-r1.ebuild
new file mode 100644
index 00000000000..663c5d9802f
--- /dev/null
+++ b/media-libs/libprojectm-qt/libprojectm-qt-2.1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+MY_P=${P/m/M}-Source ; MY_P=${MY_P/lib}
+
+DESCRIPTION="A graphical music visualization plugin similar to milkdrop"
+HOMEPAGE="http://projectm.sourceforge.net"
+SRC_URI="mirror://sourceforge/projectm/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND=">=media-libs/libprojectm-2.1.0
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-multilib.patch" )
diff --git a/media-libs/libprojectm-qt/metadata.xml b/media-libs/libprojectm-qt/metadata.xml
new file mode 100644
index 00000000000..2ace5da1910
--- /dev/null
+++ b/media-libs/libprojectm-qt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">projectm</remote-id>
+ </upstream>
+</pkgmetadata>