summaryrefslogtreecommitdiff
path: root/media-libs/libshout
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libshout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libshout')
-rw-r--r--media-libs/libshout/Manifest1
-rw-r--r--media-libs/libshout/files/libshout-2.3.1-underlinking.patch13
-rw-r--r--media-libs/libshout/libshout-2.3.1-r1.ebuild42
-rw-r--r--media-libs/libshout/libshout-2.3.1.ebuild36
-rw-r--r--media-libs/libshout/metadata.xml5
5 files changed, 97 insertions, 0 deletions
diff --git a/media-libs/libshout/Manifest b/media-libs/libshout/Manifest
new file mode 100644
index 00000000000..e80f9bde7aa
--- /dev/null
+++ b/media-libs/libshout/Manifest
@@ -0,0 +1 @@
+DIST libshout-2.3.1.tar.gz 464229 SHA256 cf3c5f6b4a5e3fcfbe09fb7024aa88ad4099a9945f7cb037ec06bcee7a23926e SHA512 19c1421e654310ddbc25f343d205d921b7c3f1c9c97f028207deaf1a46150b7f6c8069d52b7a3c9ed72dda276b52237cf1208292fbfa09aa7d09f85072c46a7b WHIRLPOOL 7060612fc19735030d8da4ef340eb51ef6d3cbb44502a64ba68f87cc4031918e304bd1f317dfe5796937ef0eeed2dad13abaa622bdca774d65e23f5ae2a061fa
diff --git a/media-libs/libshout/files/libshout-2.3.1-underlinking.patch b/media-libs/libshout/files/libshout-2.3.1-underlinking.patch
new file mode 100644
index 00000000000..e9bb73678ae
--- /dev/null
+++ b/media-libs/libshout/files/libshout-2.3.1-underlinking.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/499458
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -26,7 +26,7 @@
+ AM_CFLAGS = @XIPH_CFLAGS@
+
+ libshout_la_LIBADD = net/libicenet.la timing/libicetiming.la avl/libiceavl.la\
+- httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS) $(SPEEX_LIBS)
++ httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(OGG_LIBS) $(VORBIS_LIBS) $(THEORA_LIBS) $(SPEEX_LIBS)
+
+ INCLUDES = -I$(top_builddir)/include
+
diff --git a/media-libs/libshout/libshout-2.3.1-r1.ebuild b/media-libs/libshout/libshout-2.3.1-r1.ebuild
new file mode 100644
index 00000000000..8faf502dfc1
--- /dev/null
+++ b/media-libs/libshout/libshout-2.3.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="library for connecting and sending data to icecast servers"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="speex static-libs theora"
+
+RDEPEND=">=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
+ >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
+ speex? ( >=media-libs/speex-1.2_rc1-r1[${MULTILIB_USEDEP}] )
+ theora? ( >=media-libs/libtheora-1.1.1[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r6
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable theora) \
+ $(use_enable speex)
+}
+
+multilib_src_install_all() {
+ dodoc README examples/example.c
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ prune_libtool_files
+}
diff --git a/media-libs/libshout/libshout-2.3.1.ebuild b/media-libs/libshout/libshout-2.3.1.ebuild
new file mode 100644
index 00000000000..71b078836a6
--- /dev/null
+++ b/media-libs/libshout/libshout-2.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="library for connecting and sending data to icecast servers"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="speex static-libs theora"
+
+RDEPEND="media-libs/libogg
+ media-libs/libvorbis
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable theora) \
+ $(use_enable speex)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README examples/example.c
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ prune_libtool_files
+}
diff --git a/media-libs/libshout/metadata.xml b/media-libs/libshout/metadata.xml
new file mode 100644
index 00000000000..e1774e3d9ad
--- /dev/null
+++ b/media-libs/libshout/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>