summaryrefslogtreecommitdiff
path: root/media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-08-30 13:00:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-08-30 13:00:00 +0200
commit02947e97a7b9c2a35d82405e3b3e8a6b7ad9489c (patch)
tree1a5a4739b48902156bd186dd0431886ac6e53a95 /media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild
parentb252629653a11bdca61279c5de260d66e6ff8fbd (diff)
downloadgentoo-02947e97a7b9c2a35d82405e3b3e8a6b7ad9489c.tar.gz
gentoo-02947e97a7b9c2a35d82405e3b3e8a6b7ad9489c.tar.xz
media-libs/libsidplayfp: bump to 1.8.1
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild')
-rw-r--r--media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild b/media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild
new file mode 100644
index 00000000000..99dd164426d
--- /dev/null
+++ b/media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator
+
+DESCRIPTION="A library for the sidplay2 fork with resid-fp"
+HOMEPAGE="http://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="mirror://sourceforge/sidplay-residfp/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="cpu_flags_x86_mmx static-libs"
+
+DOCS=( AUTHORS NEWS README TODO )
+
+src_prepare() {
+ # fix automagic. warning: modifying .ac triggers maintainer mode.
+ sed -i -e 's:doxygen:dIsAbLe&:' configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_mmx mmx)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}