summaryrefslogtreecommitdiff
path: root/media-libs/libxspf
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libxspf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libxspf')
-rw-r--r--media-libs/libxspf/Manifest1
-rw-r--r--media-libs/libxspf/files/libxspf-1.2.0-gcc44.patch22
-rw-r--r--media-libs/libxspf/files/libxspf-1.2.0-gcc47.patch12
-rw-r--r--media-libs/libxspf/libxspf-1.2.0.ebuild49
-rw-r--r--media-libs/libxspf/metadata.xml12
5 files changed, 96 insertions, 0 deletions
diff --git a/media-libs/libxspf/Manifest b/media-libs/libxspf/Manifest
new file mode 100644
index 00000000000..293bd079bab
--- /dev/null
+++ b/media-libs/libxspf/Manifest
@@ -0,0 +1 @@
+DIST libxspf-1.2.0.tar.bz2 372483 SHA256 ba9e93a0066469b074b4022b480004651ad3aa5b4313187fd407d833f79b43a5 SHA512 56667b6df89e30517e2e388e2e3b1c083b19d98d69b4ee328d2784bba57a8d50c6b6ae1876cf17e6f9eb1ff872680c8f33b84b826d1290b890ac173c76bea491 WHIRLPOOL 4a518c505d2d685989923fa995547152e1d48ea903834a2a8c8fca938a79973850c2c589e9ad47f680f7f257b3d4b2bea12202f334a96fc8c04b68186a235684
diff --git a/media-libs/libxspf/files/libxspf-1.2.0-gcc44.patch b/media-libs/libxspf/files/libxspf-1.2.0-gcc44.patch
new file mode 100644
index 00000000000..fa16b589df3
--- /dev/null
+++ b/media-libs/libxspf/files/libxspf-1.2.0-gcc44.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/261604
+
+--- test/OfficialSuite.cpp
++++ test/OfficialSuite.cpp
+@@ -21,6 +21,7 @@
+ * Sebastian Pipping, sping@xiph.org
+ */
+
++#include <cstdio>
+ #include "OfficialSuite.h"
+ #include <xspf/XspfReaderCallback.h>
+ using namespace Xspf;
+--- test/ProjectOpus/ProjectOpusSuite.cpp
++++ test/ProjectOpus/ProjectOpusSuite.cpp
+@@ -21,6 +21,7 @@
+ * Sebastian Pipping, sping@xiph.org
+ */
+
++#include <cstdio>
+ #include "ProjectOpusSuite.h"
+ #include <xspf/XspfReader.h>
+ #include <xspf/XspfTrack.h>
diff --git a/media-libs/libxspf/files/libxspf-1.2.0-gcc47.patch b/media-libs/libxspf/files/libxspf-1.2.0-gcc47.patch
new file mode 100644
index 00000000000..b408416e7ef
--- /dev/null
+++ b/media-libs/libxspf/files/libxspf-1.2.0-gcc47.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/421745
+
+--- examples/read/read.cpp
++++ examples/read/read.cpp
+@@ -43,6 +43,7 @@
+ #include <cstdio>
+ #include <cstdlib> // MAX_PATH
+ #include <climits> // PATH_MAX
++#include <unistd.h> // getcwd
+
+
+ #if defined(__WIN32__) || defined(WIN32)
diff --git a/media-libs/libxspf/libxspf-1.2.0.ebuild b/media-libs/libxspf/libxspf-1.2.0.ebuild
new file mode 100644
index 00000000000..edee2c183d0
--- /dev/null
+++ b/media-libs/libxspf/libxspf-1.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Playlist handling library"
+HOMEPAGE="http://libspiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libspiff/${P}.tar.bz2"
+
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/expat-2
+ >=dev-libs/uriparser-0.7.5"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.5.8
+ media-gfx/graphviz
+ dev-qt/qthelp:4
+ )
+ test? ( >=dev-util/cpptest-1.1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ export XDG_CONFIG_HOME="${T}" #398881#c2
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable static-libs static) \
+ $(use_enable test) \
+ $(use_enable doc)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/libxspf/metadata.xml b/media-libs/libxspf/metadata.xml
new file mode 100644
index 00000000000..57004d18bdd
--- /dev/null
+++ b/media-libs/libxspf/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription lang="en">
+ libxspf brings XSPF playlist reading and writing support to your C++
+ application. XSPF is an open XML format for sharing playlists.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">libspiff</remote-id>
+ </upstream>
+</pkgmetadata>