summaryrefslogtreecommitdiff
path: root/media-libs/mutagen
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/mutagen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/mutagen')
-rw-r--r--media-libs/mutagen/Manifest3
-rw-r--r--media-libs/mutagen/metadata.xml8
-rw-r--r--media-libs/mutagen/mutagen-1.22.ebuild43
-rw-r--r--media-libs/mutagen/mutagen-1.27.ebuild43
-rw-r--r--media-libs/mutagen/mutagen-1.29.ebuild43
5 files changed, 140 insertions, 0 deletions
diff --git a/media-libs/mutagen/Manifest b/media-libs/mutagen/Manifest
new file mode 100644
index 00000000000..bbee9d2d0f7
--- /dev/null
+++ b/media-libs/mutagen/Manifest
@@ -0,0 +1,3 @@
+DIST mutagen-1.22.tar.gz 813763 SHA256 ddf2907bcaf4827b044a3d70b2fb3c1b58954497d86133f16715fc6c407d494e SHA512 875d61fdb89de6e620dc397a23a83da2d8bdbf111cceb469a6089225c9d7aa91fe03c98258c522ae781e6bbc3d7b72aa66de571c7d99d72419a72697c9b389cc WHIRLPOOL ea3b771c11143194ac395ffe896d2be5410896e614293c14e2a8a9515c5316a8872da5d600a7fa72a710c2263f845dda6e7cd85a7478eeeaa25ec8179ba23c5f
+DIST mutagen-1.27.tar.gz 875720 SHA256 cc884fe1e20fe220be7ce7c3b269f4cadc69a8310150a3a41162fba1ca9c88bd SHA512 ae15fb3f5d77025a60e25a2ed25e23f7d21160d4e63c49fe7d01508440ff1f6b673cf34d8f4facc834824825ad6f4d3ed9830133db5aba339ac1eae46f7f50d5 WHIRLPOOL ecd44cc7fde15f87a2a31be84b428a49e97d67ce26c700382b4e2ba7cdb995223ea6dfda101dd7039d4c7ce23a2314d7e523b9849f19189a6ed7bcdb18bbd52e
+DIST mutagen-1.29.tar.gz 879767 SHA256 dbad61c8db882f849f25183448f21e440f5eceaf614dd8c2c5ae9392f33f599f SHA512 cd04bc79f1de1ad5ce0cd52e08d21918815d9d797370891431781fa99cb854eb98d20ed11a562afde71d4ea78c0468e831a3ed0eae67bbb30e629300753ff44e WHIRLPOOL bc9b539be281753c46bd363e3d88c429f5c254c3f8d276fa124db00098fd51831f64b585bf7f20a3a349cd27c532fa3ad3024f04f0f54ed40b23ab1eb64c2fa1
diff --git a/media-libs/mutagen/metadata.xml b/media-libs/mutagen/metadata.xml
new file mode 100644
index 00000000000..a54ea4d207c
--- /dev/null
+++ b/media-libs/mutagen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="google-code">mutagen</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/mutagen/mutagen-1.22.ebuild b/media-libs/mutagen/mutagen-1.22.ebuild
new file mode 100644
index 00000000000..8a84a742acf
--- /dev/null
+++ b/media-libs/mutagen/mutagen-1.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Mutagen is an audio metadata tag reader and writer implemented in pure Python"
+HOMEPAGE="http://code.google.com/p/mutagen http://pypi.python.org/pypi/mutagen"
+SRC_URI="https://bitbucket.org/lazka/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test" # Missing support for >=dev-python/eyeD3-0.7 API
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+src_test() {
+ # tests/test_flac.py uses temp files with a constant path.
+ # If we had multiple python implementations, we would hit a race.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS README TODO )
+ use doc && local HTML_DOCS=( docs/_build/. )
+ distutils-r1_python_install_all
+}
diff --git a/media-libs/mutagen/mutagen-1.27.ebuild b/media-libs/mutagen/mutagen-1.27.ebuild
new file mode 100644
index 00000000000..386935cc9a9
--- /dev/null
+++ b/media-libs/mutagen/mutagen-1.27.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mutagen is an audio metadata tag reader and writer implemented in pure Python"
+HOMEPAGE="http://code.google.com/p/mutagen http://pypi.python.org/pypi/mutagen"
+SRC_URI="https://bitbucket.org/lazka/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 ppc ~ppc64 sparc x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# TODO: Missing support for >=dev-python/eyeD3-0.7 API
+# test? ( >=dev-python/eyeD3-0.7 )
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+src_test() {
+ # tests/test_flac.py uses temp files with a constant path.
+ # If we had multiple python implementations, we would hit a race.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS README.rst )
+ use doc && local HTML_DOCS=( docs/_build/. )
+ distutils-r1_python_install_all
+}
diff --git a/media-libs/mutagen/mutagen-1.29.ebuild b/media-libs/mutagen/mutagen-1.29.ebuild
new file mode 100644
index 00000000000..5c5ca70f965
--- /dev/null
+++ b/media-libs/mutagen/mutagen-1.29.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mutagen is an audio metadata tag reader and writer implemented in pure Python"
+HOMEPAGE="http://code.google.com/p/mutagen http://pypi.python.org/pypi/mutagen"
+SRC_URI="https://bitbucket.org/lazka/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# TODO: Missing support for >=dev-python/eyeD3-0.7 API
+# test? ( >=dev-python/eyeD3-0.7 )
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+src_test() {
+ # tests/test_flac.py uses temp files with a constant path.
+ # If we had multiple python implementations, we would hit a race.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS README.rst )
+ use doc && local HTML_DOCS=( docs/_build/. )
+ distutils-r1_python_install_all
+}