summaryrefslogtreecommitdiff
path: root/media-libs/opencolorio/opencolorio-1.0.9.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/opencolorio/opencolorio-1.0.9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/opencolorio/opencolorio-1.0.9.ebuild')
-rw-r--r--media-libs/opencolorio/opencolorio-1.0.9.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/media-libs/opencolorio/opencolorio-1.0.9.ebuild b/media-libs/opencolorio/opencolorio-1.0.9.ebuild
new file mode 100644
index 00000000000..9f96600ee9b
--- /dev/null
+++ b/media-libs/opencolorio/opencolorio-1.0.9.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Compatibility with Python 3 is declared by upstream, but it is broken in fact, check on bump
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1 vcs-snapshot
+
+DESCRIPTION="A color management framework for visual effects and animation"
+HOMEPAGE="http://opencolorio.org/"
+SRC_URI="https://github.com/imageworks/OpenColorIO/archive/v${PV}.tar.gz \
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc opengl pdf python cpu_flags_x86_sse2 test"
+
+RDEPEND="opengl? (
+ media-libs/lcms:2
+ >=media-libs/openimageio-1.1.0
+ media-libs/glew
+ media-libs/freeglut
+ virtual/opengl
+ )
+ python? ( ${PYTHON_DEPS} )
+ =dev-cpp/yaml-cpp-0.3*
+ dev-libs/tinyxml
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ pdf? ( dev-python/sphinx[latex,${PYTHON_USEDEP}] )
+ !pdf? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ )
+ "
+
+# Documentation building requires Python bindings building
+REQUIRED_USE="doc? ( python )"
+
+# Restricting tests, bugs #439790 and #447908
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.8-documentation-gen.patch"
+ "${FILESDIR}/${P}-remove-external-doc-utilities.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ use python && python_fix_shebang .
+}
+
+src_configure() {
+ # Missing features:
+ # - Truelight and Nuke are not in portage for now, so their support are disabled
+ # - Java bindings was not tested, so disabled
+ # Notes:
+ # - OpenImageIO is required for building ociodisplay and ocioconvert (USE opengl)
+ # - OpenGL, GLUT and GLEW is required for building ociodisplay (USE opengl)
+ local mycmakeargs=(
+ -DOCIO_BUILD_JNIGLUE=OFF
+ -DOCIO_BUILD_NUKE=OFF
+ -DOCIO_BUILD_SHARED=ON
+ -DOCIO_BUILD_STATIC=OFF
+ -DOCIO_STATIC_JNIGLUE=OFF
+ -DOCIO_BUILD_TRUELIGHT=OFF
+ -DUSE_EXTERNAL_LCMS=ON
+ -DUSE_EXTERNAL_TINYXML=ON
+ -DUSE_EXTERNAL_YAML=ON
+ $(cmake-utils_use doc OCIO_BUILD_DOCS)
+ $(cmake-utils_use opengl OCIO_BUILD_APPS)
+ $(cmake-utils_use pdf OCIO_BUILD_PDF_DOCS)
+ $(cmake-utils_use python OCIO_BUILD_PYGLUE)
+ $(cmake-utils_use cpu_flags_x86_sse2 OCIO_USE_SSE)
+ $(cmake-utils_use test OCIO_BUILD_TESTS)
+ )
+ cmake-utils_src_configure
+}