summaryrefslogtreecommitdiff
path: root/media-libs/raul
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/raul
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/raul')
-rw-r--r--media-libs/raul/Manifest1
-rw-r--r--media-libs/raul/files/ldconfig2.patch12
-rw-r--r--media-libs/raul/files/raul-0.8.0-gcc47.patch45
-rw-r--r--media-libs/raul/metadata.xml9
-rw-r--r--media-libs/raul/raul-0.8.0-r1.ebuild50
-rw-r--r--media-libs/raul/raul-0.8.0.ebuild51
6 files changed, 168 insertions, 0 deletions
diff --git a/media-libs/raul/Manifest b/media-libs/raul/Manifest
new file mode 100644
index 00000000000..d93bd4627f6
--- /dev/null
+++ b/media-libs/raul/Manifest
@@ -0,0 +1 @@
+DIST raul-0.8.0.tar.bz2 155450 SHA256 0b35cd7bb6fb0b1ca0340be07678a2561888572c96cf4e4da4d8f4c03a20ba26 SHA512 7ad48c551945aad104309448bcdb86a4a2ca07c44af53b37492e7cddce6a093529f1e1e75c4b27cb8e292ec46424969cdea270883d44b2f1badc48df8943a0a1 WHIRLPOOL b63cf7eef4de032ef26f2f2bef46543cd2d3b691e8bbdc4dd105feaae02c589525382b9155f4e9faa1c10ae7ae89baf0fe3878c57a1a10b969740804b67cef4a
diff --git a/media-libs/raul/files/ldconfig2.patch b/media-libs/raul/files/ldconfig2.patch
new file mode 100644
index 00000000000..7676ae0781f
--- /dev/null
+++ b/media-libs/raul/files/ldconfig2.patch
@@ -0,0 +1,12 @@
+Index: raul-0.8.0/wscript
+===================================================================
+--- raul-0.8.0.orig/wscript
++++ raul-0.8.0/wscript
+@@ -153,7 +153,5 @@ def build(bld):
+ # Documentation
+ autowaf.build_dox(bld, 'RAUL', RAUL_VERSION, top, out)
+
+- bld.add_post_fun(autowaf.run_ldconfig)
+-
+ def test(ctx):
+ autowaf.run_tests(ctx, APPNAME, tests.split())
diff --git a/media-libs/raul/files/raul-0.8.0-gcc47.patch b/media-libs/raul/files/raul-0.8.0-gcc47.patch
new file mode 100644
index 00000000000..c9cb2d08093
--- /dev/null
+++ b/media-libs/raul/files/raul-0.8.0-gcc47.patch
@@ -0,0 +1,45 @@
+https://bugs.gentoo.org/show_bug.cgi?id=425274
+Build with gcc 4.7
+
+Index: raul-0.8.0/raul/PathTable.hpp
+===================================================================
+--- raul-0.8.0.orig/raul/PathTable.hpp
++++ raul-0.8.0/raul/PathTable.hpp
+@@ -37,13 +37,13 @@ public:
+ typename Table<Path, T>::iterator find_descendants_end(
+ typename Table<Path, T>::iterator parent)
+ {
+- return find_range_end(parent, &Path::descendant_comparator);
++ return this->find_range_end(parent, &Path::descendant_comparator);
+ }
+
+ typename Table<Path, T>::const_iterator find_descendants_end(
+ typename Table<Path, T>::const_iterator parent) const
+ {
+- return find_range_end(parent, &Path::descendant_comparator);
++ return this->find_range_end(parent, &Path::descendant_comparator);
+ }
+ };
+
+Index: raul-0.8.0/raul/TableImpl.hpp
+===================================================================
+--- raul-0.8.0.orig/raul/TableImpl.hpp
++++ raul-0.8.0/raul/TableImpl.hpp
+@@ -249,7 +249,7 @@ Table<K, T>::cram(const Table<K,T>& rang
+ assert(is_sorted());
+ #endif
+
+- return make_pair(iterator(*this, insert_index), true);
++ return std::make_pair(iterator(*this, insert_index), true);
+ }
+
+
+@@ -339,7 +339,7 @@ Table<K, T>::operator[](const K& key)
+ if (i != end()) {
+ return i->second;
+ } else {
+- std::pair<iterator,bool> ret = insert(make_pair(key, T()));
++ std::pair<iterator,bool> ret = insert(std::make_pair(key, T()));
+ return ret.first->second;
+ }
+ }
diff --git a/media-libs/raul/metadata.xml b/media-libs/raul/metadata.xml
new file mode 100644
index 00000000000..44aedffdc31
--- /dev/null
+++ b/media-libs/raul/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+<longdescription lang="en">
+ Raul (Realtime Audio Utility Library) is a C++ utility library primarily
+ aimed at audio/musical applications.
+</longdescription>
+</pkgmetadata>
diff --git a/media-libs/raul/raul-0.8.0-r1.ebuild b/media-libs/raul/raul-0.8.0-r1.ebuild
new file mode 100644
index 00000000000..7a9d48cb21b
--- /dev/null
+++ b/media-libs/raul/raul-0.8.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit waf-utils python-any-r1 eutils
+
+DESCRIPTION="C++ utility library primarily aimed at audio/musical applications"
+HOMEPAGE="http://wiki.drobilla.net/Raul"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test"
+
+RDEPEND="dev-libs/boost
+ >=dev-libs/glib-2.14.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+RAUL_TESTS="atomic_test atom_test list_test midi_ringbuffer_test path_test quantize_test queue_test ringbuffer_test smf_test table_test thread_test time_test"
+DOCS=( AUTHORS README ChangeLog )
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig2.patch"
+ epatch "${FILESDIR}/${P}-gcc47.patch"
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use debug && echo "--debug") \
+ $(use doc && echo "--docs") \
+ $(use test && echo "--test")
+}
+
+src_test() {
+ cd "${S}/build/test" || die
+ for i in ${RAUL_TESTS} ; do
+ einfo "Running test ${i}"
+ LD_LIBRARY_PATH=.. ./${i} || die
+ done
+}
diff --git a/media-libs/raul/raul-0.8.0.ebuild b/media-libs/raul/raul-0.8.0.ebuild
new file mode 100644
index 00000000000..6cefe880422
--- /dev/null
+++ b/media-libs/raul/raul-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit waf-utils python eutils
+
+DESCRIPTION="C++ utility library primarily aimed at audio/musical applications"
+HOMEPAGE="http://wiki.drobilla.net/Raul"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug doc test"
+
+RDEPEND="dev-libs/boost
+ >=dev-libs/glib-2.14.0"
+DEPEND="${RDEPEND}
+ =dev-lang/python-2*
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+RAUL_TESTS="atomic_test atom_test list_test midi_ringbuffer_test path_test quantize_test queue_test ringbuffer_test smf_test table_test thread_test time_test"
+DOCS=( AUTHORS README ChangeLog )
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig2.patch"
+ epatch "${FILESDIR}/${P}-gcc47.patch"
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use debug && echo "--debug") \
+ $(use doc && echo "--docs") \
+ $(use test && echo "--test")
+}
+
+src_test() {
+ cd "${S}/build/test" || die
+ for i in ${RAUL_TESTS} ; do
+ einfo "Running test ${i}"
+ LD_LIBRARY_PATH=.. ./${i} || die
+ done
+}