summaryrefslogtreecommitdiff
path: root/media-libs/rubberband
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/rubberband
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/rubberband')
-rw-r--r--media-libs/rubberband/Manifest2
-rw-r--r--media-libs/rubberband/metadata.xml5
-rw-r--r--media-libs/rubberband/rubberband-1.7.0.ebuild44
-rw-r--r--media-libs/rubberband/rubberband-1.8.1.ebuild44
4 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/rubberband/Manifest b/media-libs/rubberband/Manifest
new file mode 100644
index 00000000000..3d5623a2dce
--- /dev/null
+++ b/media-libs/rubberband/Manifest
@@ -0,0 +1,2 @@
+DIST rubberband-1.7.0.tar.bz2 129328 SHA256 8037fe0e435a756f74b524b47943a8db0a4915c8437a8a4f88cb681ed577f682 SHA512 47d45ff6355e8f31f3ef0c0c5f14f27cc952f98597271b6b35b5047293b8dfa5e6576dc2e3ede102c0209507c77d666cf7c049fc65da18f09de84ea90fb2f87d WHIRLPOOL b32abc93a558bfb44bad76e3beb0d3f78bdface1141e0265e3d2720e6667236ee5f2120f3984818f927a0788d1fa6ed0c5dc15dbc3a154ec22b2c4027f054ed4
+DIST rubberband-1.8.1.tar.bz2 177501 SHA256 ff0c63b0b5ce41f937a8a3bc560f27918c5fe0b90c6bc1cb70829b86ada82b75 SHA512 9721eaa36b80574f90b8ae5cfae388159a239e4257b8c85b9e55e7cf0dbbb9a996b857213a6a172a4ada5ff712e6936a16adbe08396e2ab1df3fd8d5a02a3620 WHIRLPOOL 14906711c8599b06ac8d772fd8c83fe8625f7235aafe67ccf505bdbcd43b8a28609f885b2243b22adfee8b1dad0815458253f1c07b728afd1c399e2ddf525dc4
diff --git a/media-libs/rubberband/metadata.xml b/media-libs/rubberband/metadata.xml
new file mode 100644
index 00000000000..0dc3775f83d
--- /dev/null
+++ b/media-libs/rubberband/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+</pkgmetadata>
diff --git a/media-libs/rubberband/rubberband-1.7.0.ebuild b/media-libs/rubberband/rubberband-1.7.0.ebuild
new file mode 100644
index 00000000000..7d6afc625d2
--- /dev/null
+++ b/media-libs/rubberband/rubberband-1.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit multilib
+
+DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
+HOMEPAGE="http://www.breakfastquay.com/rubberband/"
+SRC_URI="http://code.breakfastquay.com/attachments/download/23/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/vamp-plugin-sdk
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ media-libs/ladspa-sdk
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if ! use static-libs ; then
+ sed -i -e '/^all:/s/$(STATIC_TARGET)//' \
+ -e '/^\tcp $(STATIC_TARGET)/d' \
+ Makefile.in || die
+ fi
+}
+
+src_install() {
+ emake INSTALL_BINDIR="${D}/usr/bin" \
+ INSTALL_INCDIR="${D}/usr/include/rubberband" \
+ INSTALL_LIBDIR="${D}/usr/$(get_libdir)" \
+ INSTALL_VAMPDIR="${D}/usr/$(get_libdir)/vamp" \
+ INSTALL_LADSPADIR="${D}/usr/$(get_libdir)/ladspa" \
+ INSTALL_LRDFDIR="${D}/usr/share/ladspa/rdf" \
+ INSTALL_PKGDIR="${D}/usr/$(get_libdir)/pkgconfig" \
+ install
+
+ dodoc CHANGELOG README.txt
+}
diff --git a/media-libs/rubberband/rubberband-1.8.1.ebuild b/media-libs/rubberband/rubberband-1.8.1.ebuild
new file mode 100644
index 00000000000..910bdcb9a72
--- /dev/null
+++ b/media-libs/rubberband/rubberband-1.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib
+
+DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
+HOMEPAGE="http://www.breakfastquay.com/rubberband/"
+SRC_URI="http://code.breakfastquay.com/attachments/download/34/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/vamp-plugin-sdk
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ media-libs/ladspa-sdk
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if ! use static-libs ; then
+ sed -e '/^all:/s/$(STATIC_TARGET)//' \
+ -e '/^\tcp $(STATIC_TARGET)/d' \
+ -i Makefile.in || die
+ fi
+}
+
+src_install() {
+ emake INSTALL_BINDIR="${D}/usr/bin" \
+ INSTALL_INCDIR="${D}/usr/include/rubberband" \
+ INSTALL_LIBDIR="${D}/usr/$(get_libdir)" \
+ INSTALL_VAMPDIR="${D}/usr/$(get_libdir)/vamp" \
+ INSTALL_LADSPADIR="${D}/usr/$(get_libdir)/ladspa" \
+ INSTALL_LRDFDIR="${D}/usr/share/ladspa/rdf" \
+ INSTALL_PKGDIR="${D}/usr/$(get_libdir)/pkgconfig" \
+ install
+
+ dodoc CHANGELOG README.txt
+}