summaryrefslogtreecommitdiff
path: root/media-libs/speex/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/speex/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/speex/files')
-rw-r--r--media-libs/speex/files/speex-1.2_rc1-configure.patch31
-rw-r--r--media-libs/speex/files/speex-1.2_rc1-r1-configure.patch40
2 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/speex/files/speex-1.2_rc1-configure.patch b/media-libs/speex/files/speex-1.2_rc1-configure.patch
new file mode 100644
index 00000000000..cd780daf261
--- /dev/null
+++ b/media-libs/speex/files/speex-1.2_rc1-configure.patch
@@ -0,0 +1,31 @@
+diff -ur speex-1.2rc1.orig/configure.ac speex-1.2rc1/configure.ac
+--- speex-1.2rc1.orig/configure.ac 2008-07-30 22:49:17.000000000 -0400
++++ speex-1.2rc1/configure.ac 2008-07-30 22:50:33.000000000 -0400
+@@ -112,9 +112,6 @@
+
+ AC_CHECK_HEADERS(sys/soundcard.h sys/audioio.h)
+
+-XIPH_PATH_OGG([src="src"], [src=""])
+-AC_SUBST(src)
+-
+ AC_CHECK_LIB(m, sin)
+
+ # Check for getopt_long; if not found, use included source.
+@@ -139,10 +136,16 @@
+ AC_DEFINE([ENABLE_VALGRIND], , [Enable valgrind extra checks])
+ fi])
+
++AC_ARG_ENABLE(ogg, [ --enable-ogg Enable OGG support], [if test "$enableval" = yes; then
++ XIPH_PATH_OGG([src="src"], [src=""])
++ AC_SUBST(src)
++fi
++])
++
+ AC_ARG_ENABLE(sse, [ --enable-sse Enable SSE support], [
+ if test "x$enableval" != xno; then
+ has_sse=yes
+-CFLAGS="$CFLAGS -O3 -msse"
++CFLAGS="$CFLAGS -msse"
+ else
+ has_sse=no
+ fi
diff --git a/media-libs/speex/files/speex-1.2_rc1-r1-configure.patch b/media-libs/speex/files/speex-1.2_rc1-r1-configure.patch
new file mode 100644
index 00000000000..a6c9166a925
--- /dev/null
+++ b/media-libs/speex/files/speex-1.2_rc1-r1-configure.patch
@@ -0,0 +1,40 @@
+diff -urN speex-1.2rc1.orig/configure.ac speex-1.2rc1/configure.ac
+--- speex-1.2rc1.orig/configure.ac 2008-07-21 03:17:08.000000000 +0100
++++ speex-1.2rc1/configure.ac 2011-03-15 00:23:21.263751871 +0000
+@@ -112,9 +112,6 @@
+
+ AC_CHECK_HEADERS(sys/soundcard.h sys/audioio.h)
+
+-XIPH_PATH_OGG([src="src"], [src=""])
+-AC_SUBST(src)
+-
+ AC_CHECK_LIB(m, sin)
+
+ # Check for getopt_long; if not found, use included source.
+@@ -139,10 +136,16 @@
+ AC_DEFINE([ENABLE_VALGRIND], , [Enable valgrind extra checks])
+ fi])
+
++AC_ARG_ENABLE(ogg, [ --enable-ogg Enable OGG support], [if test "$enableval" = yes; then
++ XIPH_PATH_OGG([src="src"], [src=""])
++ AC_SUBST(src)
++fi
++])
++
+ AC_ARG_ENABLE(sse, [ --enable-sse Enable SSE support], [
+ if test "x$enableval" != xno; then
+ has_sse=yes
+-CFLAGS="$CFLAGS -O3 -msse"
++CFLAGS="$CFLAGS -msse"
+ else
+ has_sse=no
+ fi
+@@ -217,7 +220,7 @@
+ ],
+ [gpl-fftw3], [
+ AC_DEFINE([USE_GPL_FFTW3], [], [Use FFTW3 for FFT])
+- PKG_CHECK_MODULES(FFT, fftw3f)
++ PKG_CHECK_MODULES([FFT], [fftw3f])
+ ],
+ [proprietary-intel-mkl], [
+ AC_DEFINE([USE_INTEL_MKL], [], [Use Intel Math Kernel Library for FFT])