summaryrefslogtreecommitdiff
path: root/media-libs/x265/x265-2.2.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-07 12:35:50 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-07 12:35:58 +0100
commit1a09e44eac27b76085eafe0db8f52ed46c98ee41 (patch)
tree35a5bd89086c50164678707869efe28438289e74 /media-libs/x265/x265-2.2.ebuild
parent5d1ea5aa923543f6611ef38f1f7033610220a3ff (diff)
downloadgentoo-1a09e44eac27b76085eafe0db8f52ed46c98ee41.tar.gz
gentoo-1a09e44eac27b76085eafe0db8f52ed46c98ee41.tar.xz
media-libs/x265: Fixes for arm.
Add patch to properly detect ARM. Do not force CFLAGS for ARM, esp. -march=native which breaks when cross compiling. Add neon useflag. Disable neon on main10 & main12 profiles as those do not build, bug #589674. Add patch to define proper symbols when disabling neon. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/x265/x265-2.2.ebuild')
-rw-r--r--media-libs/x265/x265-2.2.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/media-libs/x265/x265-2.2.ebuild b/media-libs/x265/x265-2.2.ebuild
index 0608b09bf27..ac326ae1385 100644
--- a/media-libs/x265/x265-2.2.ebuild
+++ b/media-libs/x265/x265-2.2.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/102"
-IUSE="+10bit +12bit numa pic test"
+IUSE="+10bit +12bit neon numa pic test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
@@ -30,6 +30,8 @@ DEPEND="${RDEPEND}
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )"
+PATCHES=( "${FILESDIR}/arm.patch" "${FILESDIR}/neon.patch" )
+
src_unpack() {
if [[ ${PV} = 9999* ]]; then
mercurial_src_unpack
@@ -79,6 +81,10 @@ x265_variant_src_configure() {
if [[ ${ABI} = x86 ]] ; then
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
+ if [[ ${ABI} = arm ]] ; then
+ # 589674
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
;;
"main10")
mycmakeargs+=(
@@ -90,6 +96,10 @@ x265_variant_src_configure() {
if [[ ${ABI} = x86 ]] ; then
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
+ if [[ ${ABI} = arm ]] ; then
+ # 589674
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
;;
"main")
if (( "${#MULTIBUILD_VARIANTS[@]}" > 1 )) ; then
@@ -134,6 +144,8 @@ multilib_src_configure() {
elif [[ ${ABI} = x32 ]] ; then
# bug #510890
myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ elif [[ ${ABI} = arm ]] ; then
+ mycmakeargs+=( -DENABLE_ASSEMBLY=$(usex neon ON OFF) )
fi
local MULTIBUILD_VARIANTS=( $(x265_get_variants) )