summaryrefslogtreecommitdiff
path: root/media-libs/x265
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 16:28:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 16:28:32 +0200
commitf384ec79e1ed374c864fc5d91f148c6754303ff8 (patch)
tree353ab75f1a54a3e536237a2fafa9f653e10a39e2 /media-libs/x265
parent27e6d872ed6865e3e1d6878e914844708cac2939 (diff)
downloadgentoo-f384ec79e1ed374c864fc5d91f148c6754303ff8.tar.gz
gentoo-f384ec79e1ed374c864fc5d91f148c6754303ff8.tar.xz
media-libs/x265: Make src_test more robust.
Build system builds "tests" only when asm optimizations are enabled, which may be disabled by other means (x32 or pic). Run tests only when it decided to build them. Package-Manager: portage-2.2.23
Diffstat (limited to 'media-libs/x265')
-rw-r--r--media-libs/x265/x265-1.8.ebuild10
-rw-r--r--media-libs/x265/x265-9999.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/media-libs/x265/x265-1.8.ebuild b/media-libs/x265/x265-1.8.ebuild
index d5b67b240d1..1505f631304 100644
--- a/media-libs/x265/x265-1.8.ebuild
+++ b/media-libs/x265/x265-1.8.ebuild
@@ -76,11 +76,11 @@ src_configure() {
}
multilib_src_test() {
- if has ${MULTILIB_ABI_FLAG} abi_x86_32 abi_x86_64 ; then
- cd "${BUILD_DIR}/test" || die
- for i in TestBench ; do
- ./${i} || die
- done
+ if [ -x "${BUILD_DIR}/test/TestBench" ] ; then
+ "${BUILD_DIR}/test/TestBench" || die
+ else
+ einfo "Unit tests check only assembly, and you do not seem to have any."
+ einfo "Skipping tests."
fi
}
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 1298033d279..0d77b713795 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -72,11 +72,11 @@ src_configure() {
}
multilib_src_test() {
- if has ${MULTILIB_ABI_FLAG} abi_x86_32 abi_x86_64 ; then
- cd "${BUILD_DIR}/test" || die
- for i in TestBench ; do
- ./${i} || die
- done
+ if [ -x "${BUILD_DIR}/test/TestBench" ] ; then
+ "${BUILD_DIR}/test/TestBench" || die
+ else
+ einfo "Unit tests check only assembly, and you do not seem to have any."
+ einfo "Skipping tests."
fi
}