summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
authori.Dark_Templar <darktemplar@dark-templar-archives.net>2017-04-02 15:46:27 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-15 17:11:18 +0200
commit0d0592550d27c8d666bc9e8abf22c84f49ec9386 (patch)
tree7831bccd4c226268c9ed9e3ef2483011730be655 /media-libs
parent38e89666dc45cf150e8c60072ec7337fab379e9e (diff)
downloadgentoo-0d0592550d27c8d666bc9e8abf22c84f49ec9386.tar.gz
gentoo-0d0592550d27c8d666bc9e8abf22c84f49ec9386.tar.xz
media-libs/lcms: Fix USE=static-libs
Closes: https://github.com/gentoo/gentoo/pull/4344
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lcms/lcms-2.8-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/lcms/lcms-2.8-r2.ebuild b/media-libs/lcms/lcms-2.8-r2.ebuild
new file mode 100644
index 00000000000..bca90ecc304
--- /dev/null
+++ b/media-libs/lcms/lcms-2.8-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="modules"
+inherit eutils multilib-minimal
+
+DESCRIPTION="A lightweight, speed optimized color management engine"
+HOMEPAGE="http://www.littlecms.com/"
+SRC_URI="mirror://sourceforge/${PN}/lcms2-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc jpeg static-libs +threads test tiff zlib"
+
+RDEPEND="jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-4.0.3-r6:0=[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r10
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/lcms2-${PV}
+
+PATCHES=(
+ "${FILESDIR}/${P}-CVE-2016-10165.patch"
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_with jpeg)
+ $(use_enable static-libs static)
+ $(use_with tiff)
+ $(use_with zlib)
+ $(use_with threads)
+ )
+ ECONF_SOURCE="${S}" \
+ econf ${myeconfargs[@]}
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -delete || die
+
+ if use doc; then
+ docinto pdf
+ dodoc doc/*.pdf
+ fi
+}