summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-09 12:57:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-09 12:58:15 +0200
commit58bc9a25a3dff62dc97c7a1ed41902cdb05e9581 (patch)
tree07ab92750b61fec75219f73863d81bee676579e2 /media-libs
parentcaf8553c232319890e0d5200febd3e32ddcad236 (diff)
downloadgentoo-58bc9a25a3dff62dc97c7a1ed41902cdb05e9581.tar.gz
gentoo-58bc9a25a3dff62dc97c7a1ed41902cdb05e9581.tar.xz
media-libs/harfbuzz: Bump to version 1.2.6
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-1.2.6.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 3c5b96788a0..e50daf74001 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -2,3 +2,4 @@ DIST harfbuzz-0.9.41.tar.bz2 1188176 SHA256 d81aa53d0c02b437beeaac159d7fc16394d6
DIST harfbuzz-1.1.3.tar.bz2 1294579 SHA256 d93d7cb7979c32672e902fdfa884599e63f07f2fa5b06c66147d20c516d4b8f7 SHA512 e418a1543ec2a1e58e5d8d0ba9a40e8675eda13c94c664ff83ed6303c724f078cf1744883b454c46ec40157db8dc05e7f2cf5e52200601bb1e13827d8dfbaccf WHIRLPOOL 9d18d985df77ff841b1a87d25f17eb472517e109a051f2ed213b44ec91de3a499853cf7d93e23f5ac4c199ec65f2dd02300e05097cb4983565ebb9227c8d3810
DIST harfbuzz-1.2.4.tar.bz2 1320609 SHA256 449dbdf12a8f94aedbdefaac831d8b1bf45e7decaa9192eaa4f74104ef9de491 SHA512 fd721f172b329cb39ae053da77fc4ef9675d9578bf1043647dcdc06d6dd92f43cf39a75a780899364b82363f8271269c6eae71169f5c160c726d65fe3fafd16e WHIRLPOOL 0b751f988eb88bf958a7a7ab7783b9c83952f1b2324434630f43e12e7618afebd045b1499bd5605ebf35ce4f4ed15c12761a2a84a3412248bbd17476e6885b95
DIST harfbuzz-1.2.5.tar.bz2 1334740 SHA256 cfca0b6ba42c36a1f7b03fffb926dc4d137be2aa2a2ad8930259072e43a347d5 SHA512 a94b032895490215fdace430f04db02caf79c4ab705edea26844f31a79f4e213558550be216a14fd406cb2aecfab1ae8e1503f7f90b4a38ad498b78554495eb9 WHIRLPOOL 84a41974547eedd8f0306a70092fc06f9d643fcc89eaf2d04fba74f1e0005c36328b44a574723fde2287109813feb314fbbe74d0e8587850751fb0b8458e3d1f
+DIST harfbuzz-1.2.6.tar.bz2 1336078 SHA256 7537bacccb3524df0cd2a4d5bc7e168bcc10e8171e0324f3cd522583868192c1 SHA512 00963674f41d12fb231c59813693f7b665924a1b57d9410a7a00de533aa6c5693b3852fbf03b8ed07183fb2e648b9250d949df59830e38c6adc0360ae8580edc WHIRLPOOL ae575709ff48c7c4b06417ecdd2712c5e8ce4c6ed789a64fdf50e884ce35258e5d3d35138ee81a232e852694bba96e4f4455827a74aec97d1143979a638cf5ef
diff --git a/media-libs/harfbuzz/harfbuzz-1.2.6.ebuild b/media-libs/harfbuzz/harfbuzz-1.2.6.ebuild
new file mode 100644
index 00000000000..e643e411133
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-1.2.6.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils libtool multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/HarfBuzz"
+[[ ${PV} == 9999 ]] || SRC_URI="http://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+
+IUSE="+cairo fontconfig +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+[[ ${PV} = 9999 ]] && DEPEND="${DEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # failing test, https://bugs.freedesktop.org/show_bug.cgi?id=89190
+ sed -e 's#tests/arabic-fallback-shaping.tests##' -i test/shaping/Makefile.in || die "sed failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ econf \
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with cairo) \
+ $(use_with fontconfig) \
+ $(use_with glib) \
+ $(use_with introspection gobject) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(multilib_native_use_enable introspection) \
+ $(use_with truetype freetype)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}