summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 16:33:12 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 18:25:26 +0200
commitc0a167195e7b278f91ff97382f6bae684530ff9b (patch)
treec0613a854497c4e0939152f5ed7fd34c27c907fd /media-libs
parent6c74f596ad227d999170330731b621aebe138358 (diff)
downloadgentoo-c0a167195e7b278f91ff97382f6bae684530ff9b.tar.gz
gentoo-c0a167195e7b278f91ff97382f6bae684530ff9b.tar.xz
media-libs/clutter: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/clutter/Manifest1
-rw-r--r--media-libs/clutter/clutter-1.26.0.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/media-libs/clutter/Manifest b/media-libs/clutter/Manifest
index 3760709f39c..7e3b66c038b 100644
--- a/media-libs/clutter/Manifest
+++ b/media-libs/clutter/Manifest
@@ -1 +1,2 @@
DIST clutter-1.24.2.tar.xz 5344604 SHA256 9631c98cb4bcbfec15e1bbe9eaa6eef0f127201552fce40d7d28f2133803cd63 SHA512 fab0b0d9e2c7fba9b056a94753a18aab4bd947dcce387548133c070fa6d1dc739bdb95fe7a9e0c0bad98067215346e0c35b8e5729c573dcc090e536b2b367a34 WHIRLPOOL 8b74cb6332a68f440e6371b88500e40ac61566c4df9a17c108863c2f8e2ee9f2d0dd8bf53a2996e8479a31de2247a111195acd2507dbd9866d5a2af0a63ccd0c
+DIST clutter-1.26.0.tar.xz 5378576 SHA256 67514e7824b3feb4723164084b36d6ce1ae41cb3a9897e9f1a56c8334993ce06 SHA512 86284152dd07bde1513e4a005cb4596ea5bb1ff88cc009e12bb6f550e01a5c9252e2d84dbebb6778458ba5352f1aaba30233576a9aba3d821c38f2fcb30a9a4d WHIRLPOOL acfdd3a7ceff43fddd605211bc0dda4a0055ef648c88eff6ae5133b58027df2c914c9f2a767b64ede209024361340440dc4f48748cbbdd32d1097d6c6ccc0805
diff --git a/media-libs/clutter/clutter-1.26.0.ebuild b/media-libs/clutter/clutter-1.26.0.ebuild
new file mode 100644
index 00000000000..9aae380c99e
--- /dev/null
+++ b/media-libs/clutter/clutter-1.26.0.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+HOMEPAGE="https://wiki.gnome.org/Projects/Clutter"
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+LICENSE="LGPL-2.1+ FDL-1.1+"
+SLOT="1.0"
+
+IUSE="aqua debug doc egl gtk +introspection test wayland X"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ wayland? ( egl )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# NOTE: glx flavour uses libdrm + >=mesa-7.3
+# >=libX11-1.3.1 needed for X Generic Event support
+# do not depend on tslib, it does not build and is disabled by default upstream
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/atk-2.5.3[introspection?]
+ >=dev-libs/json-glib-0.12[introspection?]
+ >=media-libs/cogl-1.21.2:1.0=[introspection?,pango,wayland?]
+ >=x11-libs/cairo-1.14:=[aqua?,glib]
+ >=x11-libs/pango-1.30[introspection?]
+
+ virtual/opengl
+ x11-libs/libdrm:=
+
+ egl? (
+ >=dev-libs/libinput-0.19.0
+ media-libs/cogl[gles2,kms]
+ >=virtual/libgudev-136
+ x11-libs/libxkbcommon
+ )
+ gtk? ( >=x11-libs/gtk+-3.3.18:3[aqua?] )
+ introspection? ( >=dev-libs/gobject-introspection-1.39:= )
+ X? (
+ media-libs/fontconfig
+ >=x11-libs/libX11-1.3.1
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-proto/inputproto
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXcomposite-0.4 )
+ wayland? (
+ dev-libs/wayland
+ x11-libs/gdk-pixbuf:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ >=dev-util/gtk-doc-1.20
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ dev-libs/libxslt )
+ test? ( x11-libs/gdk-pixbuf )
+"
+
+src_prepare() {
+ # We only need conformance tests, the rest are useless for us
+ sed -e 's/^\(SUBDIRS =\).*/\1 accessibility conform/g' \
+ -i tests/Makefile.am || die "am tests sed failed"
+ sed -e 's/^\(SUBDIRS =\)[^\]*/\1 accessibility conform/g' \
+ -i tests/Makefile.in || die "in tests sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
+ # (GLX error blabla)
+ # XXX: coverage disabled for now
+ # XXX: What about cex100/win32 backends?
+ gnome2_src_configure \
+ --disable-maintainer-flags \
+ --disable-mir-backend \
+ --disable-gcov \
+ --disable-cex100-backend \
+ --disable-win32-backend \
+ --disable-tslib-input \
+ $(use_enable aqua quartz-backend) \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(use_enable doc docs) \
+ $(use_enable egl egl-backend) \
+ $(use_enable egl evdev-input) \
+ $(use_enable gtk gdk-backend) \
+ $(use_enable introspection) \
+ $(use_enable test gdk-pixbuf) \
+ $(use_enable wayland wayland-backend) \
+ $(use_enable wayland wayland-compositor) \
+ $(use_enable X xinput) \
+ $(use_enable X x11-backend)
+}
+
+src_test() {
+ virtx emake check -C tests/conform
+}