summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2014-06-07 13:48:10 +0200
committerBertrand Jacquin <bertrand@jacquin.bzh>2015-10-09 22:50:24 +0100
commitd7673d38a8d5e8cf7c66f2166506b055f3231ca5 (patch)
treee8a0d327beb04b31f325f060f93795f3540ca89d /media-libs
parent790137d7c407dc40e515b8fcb7cc6be0d7614a69 (diff)
downloadgentoo-d7673d38a8d5e8cf7c66f2166506b055f3231ca5.tar.gz
gentoo-d7673d38a8d5e8cf7c66f2166506b055f3231ca5.tar.xz
media-libs/gavl: Add patch for x32, bug #472288
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gavl/files/1.4.0-x32.diff29
-rw-r--r--media-libs/gavl/gavl-1.4.0-r1.ebuild2
2 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/gavl/files/1.4.0-x32.diff b/media-libs/gavl/files/1.4.0-x32.diff
new file mode 100644
index 00000000000..4b510a55069
--- /dev/null
+++ b/media-libs/gavl/files/1.4.0-x32.diff
@@ -0,0 +1,29 @@
+------------------------------------------------------------------------
+r4209 | gmerlin | 2014-06-02 16:38:33 +0200 (Mon, 02 Jun 2014) | 2 lines
+
+* Compilation fix
+
+
+Index: gavl/cputest.c
+===================================================================
+--- gavl/cputest.c (revision 4208)
++++ gavl/cputest.c (revision 4209)
+@@ -69,6 +69,8 @@
+ int rval = 0;
+ int eax, ebx, ecx, edx;
+ int max_std_level, max_ext_level, std_caps=0, ext_caps=0;
++
++#ifndef ARCH_X86_64
+ long a, c;
+
+ __asm__ __volatile__ (
+@@ -94,6 +96,7 @@
+
+ if (a == c)
+ return 0; /* CPUID not supported */
++#endif // !ARCH_X86_64
+
+ cpuid(0, max_std_level, ebx, ecx, edx);
+
+
+------------------------------------------------------------------------
diff --git a/media-libs/gavl/gavl-1.4.0-r1.ebuild b/media-libs/gavl/gavl-1.4.0-r1.ebuild
index a6674fa770b..ba891587213 100644
--- a/media-libs/gavl/gavl-1.4.0-r1.ebuild
+++ b/media-libs/gavl/gavl-1.4.0-r1.ebuild
@@ -23,6 +23,8 @@ DEPEND="doc? ( app-doc/doxygen )
DOCS=( AUTHORS README TODO )
src_prepare() {
+ epatch "${FILESDIR}/${PV}-x32.diff"
+
# AC_CONFIG_HEADERS, bug #467736
sed -i \
-e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \