summaryrefslogtreecommitdiff
path: root/media-plugins/alsaequal
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/alsaequal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/alsaequal')
-rw-r--r--media-plugins/alsaequal/Manifest1
-rw-r--r--media-plugins/alsaequal/alsaequal-0.6-r2.ebuild46
-rw-r--r--media-plugins/alsaequal/files/alsaequal-0.6-asneeded.patch16
-rw-r--r--media-plugins/alsaequal/files/alsaequal-0.6-eq-name.patch63
-rw-r--r--media-plugins/alsaequal/metadata.xml5
5 files changed, 131 insertions, 0 deletions
diff --git a/media-plugins/alsaequal/Manifest b/media-plugins/alsaequal/Manifest
new file mode 100644
index 00000000000..d61f8f1f40b
--- /dev/null
+++ b/media-plugins/alsaequal/Manifest
@@ -0,0 +1 @@
+DIST alsaequal-0.6.tar.bz2 23562 SHA256 916e7d152added24617efc350142438a46099efe062bd8781d36dbf10b4e6ff0 SHA512 53a73469682eb7b641849151d4e91a3ac031daa5f11f7ad328bdd0bcf5251112814c75d27dceb8baf8582c749bf80f055414397259d24b749e7edbc03472bc6a WHIRLPOOL 991467670e6913829b402d6ba46b019317bcc49f98c45620ee2501c950d7b655c72a5dd65a76e68c59b4f2bbedc9c2c4a78d00a6b80bbfd34a37d8845eb43d85
diff --git a/media-plugins/alsaequal/alsaequal-0.6-r2.ebuild b/media-plugins/alsaequal/alsaequal-0.6-r2.ebuild
new file mode 100644
index 00000000000..f8a8c5c8b86
--- /dev/null
+++ b/media-plugins/alsaequal/alsaequal-0.6-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="a real-time adjustable equalizer plugin for ALSA"
+HOMEPAGE="http://www.thedigitalmachine.net/alsaequal.html"
+SRC_URI="http://www.thedigitalmachine.net/tools/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}]
+ >=media-plugins/caps-plugins-0.9.15[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r3
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+DOCS=( README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-eq-name.patch
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall -fPIC -DPIC" \
+ LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS} -shared" \
+ Q= \
+ SND_PCM_LIBS="-lasound" \
+ SND_CTL_LIBS="-lasound" || die
+}
+
+multilib_src_install() {
+ exeinto /usr/$(get_libdir)/alsa-lib
+ doexe *.so || die
+}
diff --git a/media-plugins/alsaequal/files/alsaequal-0.6-asneeded.patch b/media-plugins/alsaequal/files/alsaequal-0.6-asneeded.patch
new file mode 100644
index 00000000000..50a95e6a5c9
--- /dev/null
+++ b/media-plugins/alsaequal/files/alsaequal-0.6-asneeded.patch
@@ -0,0 +1,16 @@
+--- Makefile
++++ Makefile
+@@ -29,11 +29,11 @@
+
+ $(SND_PCM_BIN): $(SND_PCM_OBJECTS)
+ @echo LD $@
+- $(Q)$(LD) $(LDFLAGS) $(SND_PCM_LIBS) $(SND_PCM_OBJECTS) -o $(SND_PCM_BIN)
++ $(Q)$(LD) $(LDFLAGS) $(SND_PCM_OBJECTS) -o $(SND_PCM_BIN) $(SND_PCM_LIBS)
+
+ $(SND_CTL_BIN): $(SND_CTL_OBJECTS)
+ @echo LD $@
+- $(Q)$(LD) $(LDFLAGS) $(SND_CTL_LIBS) $(SND_CTL_OBJECTS) -o $(SND_CTL_BIN)
++ $(Q)$(LD) $(LDFLAGS) $(SND_CTL_OBJECTS) -o $(SND_CTL_BIN) $(SND_CTL_LIBS)
+
+ %.o: %.c
+ @echo GCC $<
diff --git a/media-plugins/alsaequal/files/alsaequal-0.6-eq-name.patch b/media-plugins/alsaequal/files/alsaequal-0.6-eq-name.patch
new file mode 100644
index 00000000000..7317214bf91
--- /dev/null
+++ b/media-plugins/alsaequal/files/alsaequal-0.6-eq-name.patch
@@ -0,0 +1,63 @@
+Description: Fix CAPS Eq plugin name
+Origin: vendor
+Bug-Debian: http://bugs.debian.org/721355
+Forwarded: no
+Author: Alessandro Ghedini <ghedo@debian.org>
+Last-Update: 2013-08-30
+
+--- a/ctl_equal.c
++++ b/ctl_equal.c
+@@ -167,7 +167,7 @@
+ snd_ctl_equal_t *equal;
+ const char *controls = ".alsaequal.bin";
+ const char *library = "/usr/lib/ladspa/caps.so";
+- const char *module = "Eq";
++ const char *module = "Eq10";
+ long channels = 2;
+ const char *sufix = " Playback Volume";
+ int err, i, index;
+--- a/pcm_equal.c
++++ b/pcm_equal.c
+@@ -151,7 +151,7 @@
+ snd_config_t *sconf = NULL;
+ const char *controls = ".alsaequal.bin";
+ const char *library = "/usr/lib/ladspa/caps.so";
+- const char *module = "Eq";
++ const char *module = "Eq10";
+ long channels = 2;
+ int err;
+
+--- a/README
++++ b/README
+@@ -1,11 +1,11 @@
+ Alsaequal is a real-time adjustable equalizer plugin for ALSA. It can
+ be adjusted using any ALSA compatible mixer, e.g. alsamixergui.
+
+-Alsaequal uses the Eq CAPS LADSPA Plugin for audio processing, actually
++Alsaequal uses the Eq10 CAPS LADSPA Plugin for audio processing, actually
+ alsaequal is a generic LADSPA plugin interface with real-time access to
+ the LADSPA controls (the LADSPA plugin included with alsa doesn't allow
+ for real-time controls) but it was developed for and only tested with
+-Eq CAPS LADSPA plugin. You are welcome to try it with other plugins, it
++Eq10 CAPS LADSPA plugin. You are welcome to try it with other plugins, it
+ may work. Let me know how it goes, you can reach me at
+ <charles@thedigitalmachine.net>.
+
+@@ -66,7 +66,7 @@
+ library -- location of the LADSPA library, the default is
+ "/usr/lib/ladspa/caps.so"
+ module -- module name within the LADSPA library, the deafault
+- is "Eq"
++ is "Eq10"
+ channels -- number of channels, the default is 2
+ }
+
+@@ -81,7 +81,7 @@
+ library -- location of the LADSPA library, the default is
+ "/usr/lib/ladspa/caps.so"
+ module -- module name within the LADSPA library, the deafault
+- is "Eq"
++ is "Eq10"
+ channels -- number of channels, the default is 2
+ }
+
diff --git a/media-plugins/alsaequal/metadata.xml b/media-plugins/alsaequal/metadata.xml
new file mode 100644
index 00000000000..af0275e2998
--- /dev/null
+++ b/media-plugins/alsaequal/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+</pkgmetadata>