summaryrefslogtreecommitdiff
path: root/media-plugins/emotion_generic_players
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/emotion_generic_players
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/emotion_generic_players')
-rw-r--r--media-plugins/emotion_generic_players/Manifest1
-rw-r--r--media-plugins/emotion_generic_players/emotion_generic_players-1.15.0.ebuild30
-rw-r--r--media-plugins/emotion_generic_players/emotion_generic_players-9999.ebuild28
-rw-r--r--media-plugins/emotion_generic_players/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/media-plugins/emotion_generic_players/Manifest b/media-plugins/emotion_generic_players/Manifest
new file mode 100644
index 00000000000..314fe20070a
--- /dev/null
+++ b/media-plugins/emotion_generic_players/Manifest
@@ -0,0 +1 @@
+DIST emotion_generic_players-1.15.0.tar.xz 100080 SHA256 9f6d5e9041ac7c014d663dac56d1b39ac42a45abe954d09d0edbf6e759e55f5f SHA512 e0dbebadf9fa3b8b6af4f6828e13a7445731508f219258d2c12c6c0a27e140571dc7abf657fe34fba4295a4c5f6a370950e29c9b3c5dad38ab746e20ccaa4ea3 WHIRLPOOL 1ad44ce27f975244420a4ccd376240d125a93f6894e785faf2ad6f620e35975dbba2d481273c81347dd5e1816c579c47a99d2291e5448964e949be9650bd077b
diff --git a/media-plugins/emotion_generic_players/emotion_generic_players-1.15.0.ebuild b/media-plugins/emotion_generic_players/emotion_generic_players-1.15.0.ebuild
new file mode 100644
index 00000000000..95a76648f42
--- /dev/null
+++ b/media-plugins/emotion_generic_players/emotion_generic_players-1.15.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P=${PN}-${PV/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="http://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Provides external applications as generic loaders for Evas"
+HOMEPAGE="http://www.enlightenment.org/"
+
+LICENSE="GPL-2"
+# The -arch need to keyword vlc first.
+KEYWORDS="~alpha ~amd64 ~arm -hppa -ia64 ~mips ~ppc ~ppc64 ~sh -sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-interix ~x86-solaris ~x64-solaris"
+
+RDEPEND=">=dev-libs/efl-${PV}
+ media-video/vlc"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
diff --git a/media-plugins/emotion_generic_players/emotion_generic_players-9999.ebuild b/media-plugins/emotion_generic_players/emotion_generic_players-9999.ebuild
new file mode 100644
index 00000000000..927cb92356e
--- /dev/null
+++ b/media-plugins/emotion_generic_players/emotion_generic_players-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P=${PN}-${PV/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="http://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Provides external applications as generic loaders for Evas"
+HOMEPAGE="http://www.enlightenment.org/"
+
+LICENSE="GPL-2"
+
+RDEPEND=">=dev-libs/efl-${PV}
+ media-video/vlc"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
diff --git a/media-plugins/emotion_generic_players/metadata.xml b/media-plugins/emotion_generic_players/metadata.xml
new file mode 100644
index 00000000000..99165add909
--- /dev/null
+++ b/media-plugins/emotion_generic_players/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+</pkgmetadata>