summaryrefslogtreecommitdiff
path: root/media-plugins/gmpc-libnotify
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/gmpc-libnotify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/gmpc-libnotify')
-rw-r--r--media-plugins/gmpc-libnotify/Manifest1
-rw-r--r--media-plugins/gmpc-libnotify/files/gmpc-libnotify-0.20.0-libnotify-0.7.patch37
-rw-r--r--media-plugins/gmpc-libnotify/gmpc-libnotify-11.8.16.ebuild31
-rw-r--r--media-plugins/gmpc-libnotify/metadata.xml12
4 files changed, 81 insertions, 0 deletions
diff --git a/media-plugins/gmpc-libnotify/Manifest b/media-plugins/gmpc-libnotify/Manifest
new file mode 100644
index 00000000000..164381df22a
--- /dev/null
+++ b/media-plugins/gmpc-libnotify/Manifest
@@ -0,0 +1 @@
+DIST gmpc-libnotify-11.8.16.tar.gz 303691 SHA256 379b25e9826672e6d4b187d3dcae19418c69103f6a187d90da149020f6267c76 SHA512 a9422e9f2c23c642967f81b75ca6915c54c364e11ff55321052e7db7dafb12bb832f4fc165a844f43c6db464b999f0cc28e7f8731a84afa643108b0633642967 WHIRLPOOL 974b951c47c9ad18fb01956a37ec4c7ab67bd6b8e91b1d7e3ddd9bfb12a12e40749d1edae64ceec7c9f6afa311018cfe13f04deb4342381529057de96aa49ca9
diff --git a/media-plugins/gmpc-libnotify/files/gmpc-libnotify-0.20.0-libnotify-0.7.patch b/media-plugins/gmpc-libnotify/files/gmpc-libnotify-0.20.0-libnotify-0.7.patch
new file mode 100644
index 00000000000..601b6f27c64
--- /dev/null
+++ b/media-plugins/gmpc-libnotify/files/gmpc-libnotify-0.20.0-libnotify-0.7.patch
@@ -0,0 +1,37 @@
+--- src/plugin.c
++++ src/plugin.c
+@@ -28,6 +28,10 @@
+ #include <gmpc/misc.h>
+ #include <config.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #define LOG_DOMAIN "LibNotifyPlugin"
+
+ extern GtkStatusIcon *tray_icon2_gsi;
+@@ -149,15 +153,23 @@
+ if(not == NULL)
+ {
+ // notify_notification_close(not, NULL);
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ not = notify_notification_new(summary, buffer,NULL);
++#else
+ not = notify_notification_new(summary, buffer,NULL, NULL);
++#endif
+ }
+ else{
+ notify_notification_update(not, summary, buffer, NULL);
+ }
+ notify_notification_set_urgency(not, NOTIFY_URGENCY_LOW);
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ /* notify_notification_attach_to_status_icon was removed */
++#else
+ if(cfg_get_single_value_as_int_with_default(config, "libnotify-plugin", "attach-to-tray", TRUE))
+ notify_notification_attach_to_status_icon(not, tray_icon2_gsi);
++#endif
+
+ g_free(summary);
+ /* Add the song to the widget */
diff --git a/media-plugins/gmpc-libnotify/gmpc-libnotify-11.8.16.ebuild b/media-plugins/gmpc-libnotify/gmpc-libnotify-11.8.16.ebuild
new file mode 100644
index 00000000000..1a39f999331
--- /dev/null
+++ b/media-plugins/gmpc-libnotify/gmpc-libnotify-11.8.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="This plugin sends an announcement to the notification daemon on song change"
+HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_LIBNOTIFY"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND=">=media-sound/gmpc-${PV}
+ dev-libs/libxml2
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -exec rm {} + || die
+}
diff --git a/media-plugins/gmpc-libnotify/metadata.xml b/media-plugins/gmpc-libnotify/metadata.xml
new file mode 100644
index 00000000000..974a58e8352
--- /dev/null
+++ b/media-plugins/gmpc-libnotify/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">musicpd</remote-id>
+ </upstream>
+</pkgmetadata>