summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-vaapi
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/gst-plugins-vaapi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/gst-plugins-vaapi')
-rw-r--r--media-plugins/gst-plugins-vaapi/Manifest1
-rw-r--r--media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-0.5.10.ebuild52
-rw-r--r--media-plugins/gst-plugins-vaapi/metadata.xml8
3 files changed, 61 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-vaapi/Manifest b/media-plugins/gst-plugins-vaapi/Manifest
new file mode 100644
index 00000000000..60140b1f479
--- /dev/null
+++ b/media-plugins/gst-plugins-vaapi/Manifest
@@ -0,0 +1 @@
+DIST gstreamer-vaapi-0.5.10.tar.bz2 1333822 SHA256 0dd236c7bf225322b8934fdba99a7a9e4542566a2acbe7564cdc3ec2c8b73c9d SHA512 bb0c2c29100f2edfdbf76d2de2a554b988779a9fc462788b537f08f6e62f0fdfaa7f12e4e4d49f1abf887533dcbd79bf0c734895bc73f5bc4b0bc3ba0ac07120 WHIRLPOOL 27350341e2899bd50aa8795bde505f4da78f23b9d1615e1a8706516ed482f7f2bae0db8f121b16a6163327cd2323f755b39b6605f16ea725dfabc766ee5ec74e
diff --git a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-0.5.10.ebuild b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-0.5.10.ebuild
new file mode 100644
index 00000000000..35cc2207cae
--- /dev/null
+++ b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-0.5.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils multilib-minimal
+
+MY_PN="gstreamer-vaapi"
+DESCRIPTION="Hardware accelerated video decoding through VA-API plugin"
+HOMEPAGE="http://gitorious.org/vaapi/gstreamer-vaapi"
+SRC_URI="http://www.freedesktop.org/software/vaapi/releases/${MY_PN}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0"
+KEYWORDS="~amd64"
+IUSE="+X opengl wayland"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ media-libs/libvpx[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-1.2.3:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-1.2.3:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-bad-1.2.3:1.0[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libva-1.4.0[X?,opengl?,wayland?,${MULTILIB_USEDEP}]
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/libudev-208:=[${MULTILIB_USEDEP}]
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-builtin-libvpx=no \
+ --disable-static \
+ --enable-drm \
+ $(use_enable opengl glx) \
+ $(use_enable wayland) \
+ $(use_enable X x11)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/media-plugins/gst-plugins-vaapi/metadata.xml b/media-plugins/gst-plugins-vaapi/metadata.xml
new file mode 100644
index 00000000000..ca8b22bc6ce
--- /dev/null
+++ b/media-plugins/gst-plugins-vaapi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gstreamer</herd>
+ <upstream>
+ <remote-id type="gitorious">vaapi/gstreamer-vaapi</remote-id>
+ </upstream>
+</pkgmetadata>