summaryrefslogtreecommitdiff
path: root/media-plugins/ir_lv2
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/ir_lv2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/ir_lv2')
-rw-r--r--media-plugins/ir_lv2/Manifest1
-rw-r--r--media-plugins/ir_lv2/ir_lv2-1.3.ebuild43
-rw-r--r--media-plugins/ir_lv2/metadata.xml5
3 files changed, 49 insertions, 0 deletions
diff --git a/media-plugins/ir_lv2/Manifest b/media-plugins/ir_lv2/Manifest
new file mode 100644
index 00000000000..153bc0819c3
--- /dev/null
+++ b/media-plugins/ir_lv2/Manifest
@@ -0,0 +1 @@
+DIST ir.lv2-1.3.tar.gz 47503 SHA256 1b728e74bc206f459a0fd9138c3122c6d418bebad68661d2d54ebcf33291ef7e SHA512 457e04b3080d9b497b90c737aa40584099222ff8c04aebb8be3d166758f513688cfd272e6fc91a0cdbee12f61b75effe99e63d03f46fea631ff3b24b43c9b667 WHIRLPOOL 5883cf1a2b61ad30ee5618f6636c6016615590428ebca17f546f32e368c63c6541887ef79c95dfdcb9a5268ce7d65e297187470f69ec0c0577cc84d3532ef63e
diff --git a/media-plugins/ir_lv2/ir_lv2-1.3.ebuild b/media-plugins/ir_lv2/ir_lv2-1.3.ebuild
new file mode 100644
index 00000000000..0e851fd7a03
--- /dev/null
+++ b/media-plugins/ir_lv2/ir_lv2-1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs flag-o-matic multilib
+
+MY_P="${P/_/.}"
+DESCRIPTION="LV2 convolver plugin especially for creating reverb effects"
+HOMEPAGE="http://factorial.hu/plugins/lv2/ir"
+SRC_URI="http://factorial.hu/system/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="media-libs/zita-convolver
+ >=x11-libs/gtk+-2.16:2
+ media-libs/lv2
+ media-libs/libsndfile
+ media-libs/libsamplerate"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN/_/.}
+
+src_prepare() {
+ sed -i -e 's/g++/$(CXX)/' -e 's/gcc/$(CC)/' Makefile || die #respect CC/CXX
+ sed -i -e 's/\(^C4CFLAGS =.*\) -O2.*/\1 $(CFLAGS)/' Makefile || die #respect CFLAGS
+ sed -i -e 's/\(^CPPFLAGS +=.*\) -O2.*/\1 $(CXXFLAGS)/' Makefile || die #respect CXXFLAGS
+}
+
+src_compile() {
+ tc-export CC CXX
+ emake || die
+}
+
+src_install() {
+ emake INSTDIR="${D}/usr/$(get_libdir)/lv2/ir.lv2" install || die
+ dodoc README ChangeLog || die
+}
diff --git a/media-plugins/ir_lv2/metadata.xml b/media-plugins/ir_lv2/metadata.xml
new file mode 100644
index 00000000000..0dc3775f83d
--- /dev/null
+++ b/media-plugins/ir_lv2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+</pkgmetadata>