summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-pvr-hts
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2016-04-25 13:51:18 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2016-04-25 13:51:18 +0200
commite7b569918d1dedffe881c6539f63ab6836502c4c (patch)
treed98f3a47677916d6c04f3434f0dd7d831cf2095f /media-plugins/kodi-pvr-hts
parent4108cf6e6c3c55351c8d0ba566f895893844a3c2 (diff)
downloadgentoo-e7b569918d1dedffe881c6539f63ab6836502c4c.tar.gz
gentoo-e7b569918d1dedffe881c6539f63ab6836502c4c.tar.xz
media-plugins/kodi-pvr-hts: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-plugins/kodi-pvr-hts')
-rw-r--r--media-plugins/kodi-pvr-hts/Manifest1
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-16_p20160419.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-hts/Manifest b/media-plugins/kodi-pvr-hts/Manifest
index b61844efc69..9764fd7bd45 100644
--- a/media-plugins/kodi-pvr-hts/Manifest
+++ b/media-plugins/kodi-pvr-hts/Manifest
@@ -1 +1,2 @@
DIST kodi-pvr-hts-16_p20160220.tar.gz 187707 SHA256 f8fc1f8c4ff92be6fdcb2e4d49c1e91c0e0638b859ca04cd6296d28d64551330 SHA512 6ae00e2c5e226be0fbe98aafd5495e0e962ae36187ff6cf2641c82ddec5b69dfc6fd7eaf4c91ce7ed28fe992f1e914b4cb1fd88d3502e7359f9bc867858a0322 WHIRLPOOL 3b1b9d6c03e65ceae934cc9bc4af6d539794034f00efcd048f68bcd599366751a8691423fbbc0f69db09b56d32fbfd0f28617d69e879e1b3a98c13f61ae04b27
+DIST kodi-pvr-hts-16_p20160419.tar.gz 187786 SHA256 4df61466a588e1cabde21e4f733b41f18df4d3989701ea70cc60241ac843f93a SHA512 02aba6242ef6b6d39480585bed9a82569b123c2272f25a9373e75ae65a64c107638f1dee42872a688378eb48d2a5bdd7db8f108dbf42bd2ea1664b6e99ed5d13 WHIRLPOOL 385eb10f920e243f41a84a39f451e14cae6435c90f08531ef8190cf92289a84cd37945e8daa78ca3cabba2355537577df37c221e2a4f0d0b7a3ed247e142c866
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-16_p20160419.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-16_p20160419.ebuild
new file mode 100644
index 00000000000..8da4de04ed7
--- /dev/null
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-16_p20160419.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+GIT_COMMIT="ada1e05"
+DESCRIPTION="Tvheadend Live TV and Radio PVR client addon for Kodi"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
+SRC_URI="https://github.com/kodi-pvr/pvr.hts/tarball/${GIT_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# libplatform changed in version 2 from platform to p8-platform which makes it incompatible
+DEPEND="=dev-libs/libplatform-1*
+ =media-libs/kodi-platform-16*
+ =media-tv/kodi-16*"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/kodi-pvr-pvr.hts-${GIT_COMMIT}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="${EPREFIX}"/usr/lib/kodi
+ )
+
+ cmake-utils_src_configure
+}