summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-autosort
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-autosort
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-autosort')
-rw-r--r--media-plugins/vdr-autosort/Manifest1
-rw-r--r--media-plugins/vdr-autosort/metadata.xml19
-rw-r--r--media-plugins/vdr-autosort/vdr-autosort-0.1.3.ebuild43
3 files changed, 63 insertions, 0 deletions
diff --git a/media-plugins/vdr-autosort/Manifest b/media-plugins/vdr-autosort/Manifest
new file mode 100644
index 00000000000..a6edb7da8e4
--- /dev/null
+++ b/media-plugins/vdr-autosort/Manifest
@@ -0,0 +1 @@
+DIST vdr-autosort-0.1.3.tgz 37190 SHA256 4add89651ea0affc91e4a46a45d8721dccca341765b800894d72dd59930592f8 SHA512 f9d154060ead285e4b775317c403372ecf3d80842d95bca31dd0ba220c3429b51f4be31bf7251222905d5485a0e6f5c1fc80927c386456cb500f1c58a5a9201a WHIRLPOOL e7c0ec6fe18e544555d576e9dbf0875a0bd65de40766ebacffeb0f6452c528076fa39daa5c46dc53a14c1e0f76994790cf4cc691edebab10c151f6b65348b19c
diff --git a/media-plugins/vdr-autosort/metadata.xml b/media-plugins/vdr-autosort/metadata.xml
new file mode 100644
index 00000000000..a993cc4be30
--- /dev/null
+++ b/media-plugins/vdr-autosort/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ AutoSort Plugin adds the capability to define rules for
+ automatically sorting your channels.conf with every
+ housekeeping thread.
+ </longdescription>
+ <longdescription lang="de">
+ Das AutoSort-Plugin erweitert den VDR um die Fähigkeit, die
+ Kanalliste automatisch nach benutzerspezifischen Kriterien
+ zu sortieren.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-plugins/vdr-autosort/vdr-autosort-0.1.3.ebuild b/media-plugins/vdr-autosort/vdr-autosort-0.1.3.ebuild
new file mode 100644
index 00000000000..5eabea0ebaf
--- /dev/null
+++ b/media-plugins/vdr-autosort/vdr-autosort-0.1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: Auto-sort channels.conf"
+HOMEPAGE="http://www.copypointburscheid.de/linux/autosort.htm"
+SRC_URI="http://www.copypointburscheid.de/linux/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.32"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ vdr-plugin-2_src_install
+ insinto /etc/vdr/plugins
+ doins examples/autosort.conf
+}
+
+pkg_preinst() {
+ if [[ ! -L ${ROOT}/etc/vdr/channels.conf ]]; then
+ cp "${ROOT}"/etc/vdr/channels.conf "${D}"/etc/vdr/channels.conf.autosort.bak
+ fowners vdr:vdr /etc/vdr/channels.conf.autosort.bak
+ fi
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+ echo
+ elog "You will find a backup of your channels.conf in /etc/vdr/channels.conf.autosort.bak"
+ elog "Edit /etc/vdr/plugins/autosort.conf to fit your needs"
+ ewarn "Important:"
+ ewarn "Backup your channels.conf together with autosort.conf"
+ ewarn "before making heavy changes to autosort.conf."
+ echo
+}