summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-cinebars
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-cinebars
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-cinebars')
-rw-r--r--media-plugins/vdr-cinebars/Manifest1
-rw-r--r--media-plugins/vdr-cinebars/files/vdr-cinebars-0.0.5_makefile.diff21
-rw-r--r--media-plugins/vdr-cinebars/metadata.xml12
-rw-r--r--media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild21
4 files changed, 55 insertions, 0 deletions
diff --git a/media-plugins/vdr-cinebars/Manifest b/media-plugins/vdr-cinebars/Manifest
new file mode 100644
index 00000000000..d743b9fe4ec
--- /dev/null
+++ b/media-plugins/vdr-cinebars/Manifest
@@ -0,0 +1 @@
+DIST vdr-cinebars-0.0.5.tgz 13253 RMD160 d49720c9ccfa8b42e243838257805f7f5cde8659 SHA1 49c9b17f3297d89125f7290b43f392f3dfb5af95 SHA256 d83f626cf7df916f5ea7193e022af2d7d82745a1a766fd132f21525cba912815
diff --git a/media-plugins/vdr-cinebars/files/vdr-cinebars-0.0.5_makefile.diff b/media-plugins/vdr-cinebars/files/vdr-cinebars-0.0.5_makefile.diff
new file mode 100644
index 00000000000..75e2870f814
--- /dev/null
+++ b/media-plugins/vdr-cinebars/files/vdr-cinebars-0.0.5_makefile.diff
@@ -0,0 +1,21 @@
+diff -Naur cinebars-0.0.5.orig/Makefile cinebars-0.0.5/Makefile
+--- cinebars-0.0.5.orig/Makefile 2012-06-30 18:27:52.000000000 +0200
++++ cinebars-0.0.5/Makefile 2012-06-30 18:29:25.000000000 +0200
+@@ -49,13 +49,13 @@
+
+ ### The object files (add further files here):
+ OBJS = $(PLUGIN).o
+-ifneq ($(VERS157),1)
+-OBJS += i18n.o
+-endif
++#ifneq ($(VERS157),1)
++#OBJS += i18n.o
++#endif
+
+ ### The main target:
+ all: libvdr-$(PLUGIN).so
+- if [ $(VERS157) = 1 ]; then make i18n; fi
++# if [ $(VERS157) = 1 ]; then make i18n; fi
+
+ ### Implicit rules:
+ %.o: %.c
diff --git a/media-plugins/vdr-cinebars/metadata.xml b/media-plugins/vdr-cinebars/metadata.xml
new file mode 100644
index 00000000000..d1b88e6872a
--- /dev/null
+++ b/media-plugins/vdr-cinebars/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild b/media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild
new file mode 100644
index 00000000000..66da06878b3
--- /dev/null
+++ b/media-plugins/vdr-cinebars/vdr-cinebars-0.0.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Show black bars to hide station logo"
+HOMEPAGE="http://www.egal-vdr.de/plugins/"
+SRC_URI="http://www.egal-vdr.de/plugins/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}/${P}_makefile.diff")