summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-pvrinput
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-pvrinput
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-pvrinput')
-rw-r--r--media-plugins/vdr-pvrinput/Manifest1
-rw-r--r--media-plugins/vdr-pvrinput/files/missing-include.diff12
-rw-r--r--media-plugins/vdr-pvrinput/metadata.xml13
-rw-r--r--media-plugins/vdr-pvrinput/vdr-pvrinput-2011.09.17.ebuild38
4 files changed, 64 insertions, 0 deletions
diff --git a/media-plugins/vdr-pvrinput/Manifest b/media-plugins/vdr-pvrinput/Manifest
new file mode 100644
index 00000000000..c77dba874f3
--- /dev/null
+++ b/media-plugins/vdr-pvrinput/Manifest
@@ -0,0 +1 @@
+DIST vdr-pvrinput-2011.09.17.tgz 70255 SHA256 cdad3eb2996df94ad342dd8461b4e9652c879f2eacd3971ce59e8c5bdf796273 SHA512 890ffbc1254b6c70f022dca6dbf0c09ba5689809fb95c1e40817f130f62f92383572dee61dcaaa44c515f05d9991a3031d4451e6be6fd1ae0640404f6a3a0e5e WHIRLPOOL 6c5fdcf7b454366b1cf4ee45f06c06d18d44158c6de0062537e10ba5bbcb87b07702f1c186662adba769e63f0745f71c2b37d9e19c4937adf59caa1b5052574e
diff --git a/media-plugins/vdr-pvrinput/files/missing-include.diff b/media-plugins/vdr-pvrinput/files/missing-include.diff
new file mode 100644
index 00000000000..18e9213de8b
--- /dev/null
+++ b/media-plugins/vdr-pvrinput/files/missing-include.diff
@@ -0,0 +1,12 @@
+diff -ur pvrinput-2011-08-18.orig/common.h pvrinput-2011-08-18/common.h
+--- pvrinput-2011-08-18.orig/common.h 2011-03-29 21:59:42.000000000 +0200
++++ pvrinput-2011-08-18/common.h 2012-04-11 23:05:24.870618177 +0200
+@@ -7,6 +7,7 @@
+ #include <sys/ioctl.h>
+ #include <stdarg.h>
+
++#include <vdr/device.h>
+ #include <vdr/plugin.h>
+ #if VDRVERSNUM > 10712
+ #include <vdr/sourceparams.h>
+
diff --git a/media-plugins/vdr-pvrinput/metadata.xml b/media-plugins/vdr-pvrinput/metadata.xml
new file mode 100644
index 00000000000..bb6229e6c20
--- /dev/null
+++ b/media-plugins/vdr-pvrinput/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Plugin to use a PVR* card as input device for VDR
+ </longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-pvrinput/vdr-pvrinput-2011.09.17.ebuild b/media-plugins/vdr-pvrinput/vdr-pvrinput-2011.09.17.ebuild
new file mode 100644
index 00000000000..78553b17a44
--- /dev/null
+++ b/media-plugins/vdr-pvrinput/vdr-pvrinput-2011.09.17.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Use a PVR* card as input device"
+HOMEPAGE="http://projects.vdr-developer.org/projects/show/plg-pvrinput"
+SRC_URI="mirror://gentoo/vdr-pvrinput-2011.09.17.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/vdr-plugin-pvrinput-3ee6b964382f38715f4a4fe57bd4760044f9a58a"
+
+src_prepare() {
+ # remove untranslated po files, i18n fix
+ rm "${S}"/po2i18n.pl "${S}"/po/{i18n-template.c,i18n.h} \
+ "${S}"/po/{ca_ES,cs_CZ,da_DK,el_GR,es_ES,et_EE,fi_FI,fr_FR,hr_HR,hu_HU,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI}.po
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include reader.c
+
+ epatch "${FILESDIR}/missing-include.diff"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ dodoc TODO FAQ example/channels.conf_*
+}