summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-sleeptimer
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-sleeptimer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-sleeptimer')
-rw-r--r--media-plugins/vdr-sleeptimer/Manifest1
-rw-r--r--media-plugins/vdr-sleeptimer/files/vdr-sleeptimer-0.6-includes.diff11
-rw-r--r--media-plugins/vdr-sleeptimer/metadata.xml12
-rw-r--r--media-plugins/vdr-sleeptimer/vdr-sleeptimer-0.6.ebuild26
4 files changed, 50 insertions, 0 deletions
diff --git a/media-plugins/vdr-sleeptimer/Manifest b/media-plugins/vdr-sleeptimer/Manifest
new file mode 100644
index 00000000000..675525b025b
--- /dev/null
+++ b/media-plugins/vdr-sleeptimer/Manifest
@@ -0,0 +1 @@
+DIST sleeptimer-0.6.tar.gz 11708 SHA256 8e024aa93a58be5c77e79ae494a891f2bdb94f3b9a0eeaee5f41459e5f87fdab SHA512 dbe0fef681c47190948532615f1108d06f61f6ffd1f2eea3c606a38b813c745686cab7115bc3336957936855e6e911c502273fdd0eef8a07ae5256ead734795e WHIRLPOOL e38af0f68094ed7248e95134e31c0b8efa2af0fbb2aa25ecde64649650397c11fe6f7b2148d9eb4ef436f4933bcfde1b024aad4c4b19f20e8d585703169f4b05
diff --git a/media-plugins/vdr-sleeptimer/files/vdr-sleeptimer-0.6-includes.diff b/media-plugins/vdr-sleeptimer/files/vdr-sleeptimer-0.6-includes.diff
new file mode 100644
index 00000000000..bd98e35da66
--- /dev/null
+++ b/media-plugins/vdr-sleeptimer/files/vdr-sleeptimer-0.6-includes.diff
@@ -0,0 +1,11 @@
+diff -ru sleeptimer-0.6-orig/sleeptimer.c sleeptimer-0.6/sleeptimer.c
+--- sleeptimer-0.6-orig/sleeptimer.c 2005-10-24 20:15:18.000000000 +0200
++++ sleeptimer-0.6/sleeptimer.c 2005-10-24 20:15:30.000000000 +0200
+@@ -8,6 +8,7 @@
+
+ #include <vdr/plugin.h>
+ #include <vdr/interface.h>
++#include <vdr/device.h>
+ #include "i18n.h"
+
+ static const char *VERSION = "0.6";
diff --git a/media-plugins/vdr-sleeptimer/metadata.xml b/media-plugins/vdr-sleeptimer/metadata.xml
new file mode 100644
index 00000000000..d1b88e6872a
--- /dev/null
+++ b/media-plugins/vdr-sleeptimer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-sleeptimer/vdr-sleeptimer-0.6.ebuild b/media-plugins/vdr-sleeptimer/vdr-sleeptimer-0.6.ebuild
new file mode 100644
index 00000000000..395efd6c6e9
--- /dev/null
+++ b/media-plugins/vdr-sleeptimer/vdr-sleeptimer-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Sleeptimer"
+HOMEPAGE="http://linvdr.org/download/vdr-sleeptimer"
+SRC_URI="http://linvdr.org/download/vdr-sleeptimer/${VDRPLUGIN}-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.2.6"
+
+PATCHES=( "${FILESDIR}/${P}-includes.diff" )
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -i sleeptimer.c -e "s:RegisterI18n://RegisterI18n:"
+}