summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-videosystem
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-videosystem
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-videosystem')
-rw-r--r--media-plugins/vdr-videosystem/Manifest1
-rw-r--r--media-plugins/vdr-videosystem/files/vdr-videosystem-0.0.1-uint64.diff12
-rw-r--r--media-plugins/vdr-videosystem/metadata.xml12
-rw-r--r--media-plugins/vdr-videosystem/vdr-videosystem-0.0.1.ebuild20
4 files changed, 45 insertions, 0 deletions
diff --git a/media-plugins/vdr-videosystem/Manifest b/media-plugins/vdr-videosystem/Manifest
new file mode 100644
index 00000000000..2bffa22f718
--- /dev/null
+++ b/media-plugins/vdr-videosystem/Manifest
@@ -0,0 +1 @@
+DIST vdr-videosystem-0.0.1.tgz 10578 RMD160 f0d49889607e7e463402441c7d158edf5e47f0b0 SHA1 84d49587dfa4a65b2e86032b4edfdbd681c5b8fe SHA256 7f2178a5e181a4c50a7dfed27a7421020b1ac6c83726d4168b531a0151f69e80
diff --git a/media-plugins/vdr-videosystem/files/vdr-videosystem-0.0.1-uint64.diff b/media-plugins/vdr-videosystem/files/vdr-videosystem-0.0.1-uint64.diff
new file mode 100644
index 00000000000..81ec8773c67
--- /dev/null
+++ b/media-plugins/vdr-videosystem/files/vdr-videosystem-0.0.1-uint64.diff
@@ -0,0 +1,12 @@
+diff -ru videosystem-0.0.1-orig/videosystem.c videosystem-0.0.1/videosystem.c
+--- videosystem-0.0.1-orig/videosystem.c 2006-12-03 16:03:23.386105568 +0100
++++ videosystem-0.0.1/videosystem.c 2006-12-03 16:03:31.716095700 +0100
+@@ -45,7 +45,7 @@
+ eVideoSystem GetVideoSystem(void);
+
+ bool doexit;
+- uint64 time;
++ uint64_t time;
+ eVideoSystem curVidSys;
+ bool initialized;
+ tOsdSettings pal;
diff --git a/media-plugins/vdr-videosystem/metadata.xml b/media-plugins/vdr-videosystem/metadata.xml
new file mode 100644
index 00000000000..d1b88e6872a
--- /dev/null
+++ b/media-plugins/vdr-videosystem/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-videosystem/vdr-videosystem-0.0.1.ebuild b/media-plugins/vdr-videosystem/vdr-videosystem-0.0.1.ebuild
new file mode 100644
index 00000000000..ff24121c815
--- /dev/null
+++ b/media-plugins/vdr-videosystem/vdr-videosystem-0.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: Switch OSD resolution depending on signal-videosystem (PAL/NTSC)"
+HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=43516"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.18"
+
+PATCHES=("${FILESDIR}/${P}-uint64.diff")