summaryrefslogtreecommitdiff
path: root/media-plugins
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 15:11:27 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 18:24:34 +0200
commitcc489f5d6b3d68c452aff9666b392c20f6aa3134 (patch)
treec220374ea62af75456e9ca878475a8963cda3d80 /media-plugins
parent3b558305ed5c677770f9638d071f8e3c0e43de6e (diff)
downloadgentoo-cc489f5d6b3d68c452aff9666b392c20f6aa3134.tar.gz
gentoo-cc489f5d6b3d68c452aff9666b392c20f6aa3134.tar.xz
media-plugins/grilo-plugins: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/grilo-plugins/Manifest1
-rw-r--r--media-plugins/grilo-plugins/grilo-plugins-0.3.2.ebuild118
-rw-r--r--media-plugins/grilo-plugins/metadata.xml1
3 files changed, 120 insertions, 0 deletions
diff --git a/media-plugins/grilo-plugins/Manifest b/media-plugins/grilo-plugins/Manifest
index 7dbccc0a77f..efa6aa51b24 100644
--- a/media-plugins/grilo-plugins/Manifest
+++ b/media-plugins/grilo-plugins/Manifest
@@ -1,2 +1,3 @@
DIST grilo-plugins-0.2.12.tar.xz 721592 SHA256 15bed8a633c81b251920ab677d455433e641388f605277ca88e549cc89012b48 SHA512 37865fea88b2927482490481f07d830e6cbd89c886e20b2986931215099bc9b6b46600ac45e0c72c6ff2d8f9e273ca5cd4ad42195436b540118c483d1cb5bd8e WHIRLPOOL 27006aa66002770c55be9c8f9d4302f1b60524096a11ad27731a3fcb57e4e4a55a0be6809808d14c441e4bdc005753fd55657fb9df83c149a420eacc29276c91
DIST grilo-plugins-0.2.17.tar.xz 1036308 SHA256 337669098cddf64a84fa9398aa1d7f994fea84bc5f7f1b348e1288f135713781 SHA512 f556ae6e72c82ce74cc8902f7b4ae27f51060c3b06230989b36ce4498f93894c723809c1f08fc8edfabd892fc303eb0523f21ea72649f644c7eb421b62773140 WHIRLPOOL f882ba3ef6ee4b7a1c115992dedd03778155d1ef4fa26077b7f482f5ab7bd5087e6d8485912bbd2563af3b0ef3e387169c1217b8f0427637aa1a9aa88e94df7c
+DIST grilo-plugins-0.3.2.tar.xz 1858408 SHA256 791b89289781272c001545931a8f58f499d14e46e038a9caa82dfe2494301afd SHA512 8c711631617a57dabaf8e509f5704bf9236e9e732b0707b7234fccfb8919d3c6724ae09ae89f8dd1f4f0d8d2713a1463dfb38e352f8756770fb6a1fadfa3f5b7 WHIRLPOOL 7dc1162a2aedcd0860c3f3bb7e1ef815313781386521c58eede1c629d882289f4de5e536a8191cdb77e3aadf1dc1bfa9dca0db9a9f4f6c0713d3ebb120ee02af
diff --git a/media-plugins/grilo-plugins/grilo-plugins-0.3.2.ebuild b/media-plugins/grilo-plugins/grilo-plugins-0.3.2.ebuild
new file mode 100644
index 00000000000..2b22de35d8f
--- /dev/null
+++ b/media-plugins/grilo-plugins/grilo-plugins-0.3.2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A framework for easy media discovery and browsing"
+HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="daap dvd examples chromaprint flickr freebox gnome-online-accounts lua subtitles thetvdb tracker upnp-av vimeo +youtube"
+
+# Bump gom requirement to avoid segfaults
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=media-libs/grilo-0.3.1:${SLOT}=[network,playlist]
+ media-libs/libmediaart:2.0
+ >=dev-libs/gom-0.3.2
+
+ dev-libs/gmime:2.6
+ dev-libs/json-glib
+ dev-libs/libxml2:2
+ dev-db/sqlite:3
+
+ chromaprint? ( media-libs/gstreamer:1.0 )
+ daap? ( >=net-libs/libdmapsharing-2.9.12:3.0 )
+ dvd? ( >=dev-libs/totem-pl-parser-3.4.1 )
+ flickr? ( net-libs/liboauth )
+ freebox? ( net-dns/avahi )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.91:= )
+ lua? (
+ >=dev-lang/lua-5.3
+ app-arch/libarchive
+ dev-libs/libxml2:2
+ >=dev-libs/totem-pl-parser-3.4.1 )
+ subtitles? ( net-libs/libsoup:2.4 )
+ thetvdb? (
+ app-arch/libarchive
+ dev-libs/libxml2 )
+ tracker? ( >=app-misc/tracker-0.10.5:= )
+ youtube? (
+ >=dev-libs/libgdata-0.9.1:=
+ >=dev-libs/totem-pl-parser-3.4.1 )
+ upnp-av? (
+ net-libs/libsoup:2.4
+ net-libs/dleyna-connector-dbus )
+ vimeo? (
+ >=dev-libs/totem-pl-parser-3.4.1 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+"
+
+src_prepare () {
+ gnome2_src_prepare
+ sed -e "s:GETTEXT_PACKAGE=grilo-plugins$:GETTEXT_PACKAGE=grilo-plugins-${SLOT}:" \
+ -i configure.ac configure || die "sed configure.ac configure failed"
+}
+
+# FIXME: some unittests required python-dbusmock
+src_configure() {
+ # --enable-debug only changes CFLAGS, useless for us
+ # Plugins
+ # shoutcast seems to be broken
+ gnome2_src_configure \
+ --disable-static \
+ --disable-debug \
+ --disable-uninstalled \
+ --enable-bookmarks \
+ --enable-filesystem \
+ --enable-gravatar \
+ --enable-jamendo \
+ --enable-localmetadata \
+ --enable-magnatune \
+ --enable-metadata-store \
+ --enable-podcasts \
+ --enable-raitv \
+ --disable-shoutcast \
+ --enable-tmdb \
+ $(use_enable chromaprint) \
+ $(use_enable daap dmap) \
+ $(use_enable dvd optical-media) \
+ $(use_enable flickr) \
+ $(use_enable freebox) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable lua lua-factory) \
+ $(use_enable subtitles opensubtitles) \
+ $(use_enable thetvdb) \
+ $(use_enable tracker) \
+ $(use_enable upnp-av dleyna) \
+ $(use_enable vimeo) \
+ $(use_enable youtube)
+}
+
+src_install() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins help/examples/*.c
+ fi
+
+ gnome2_src_install \
+ DOC_MODULE_VERSION=${SLOT%/*} \
+ HELP_ID="grilo-plugins-${SLOT%/*}" \
+ HELP_MEDIA=""
+
+ # The above doesn't work and collides with 0.2 slot
+ mv "${ED}"/usr/share/help/C/examples/example-tmdb{,-0.3}.c
+ mv "${ED}"/usr/share/help/C/grilo-plugins/legal{,-0.3}.xml
+ mv "${ED}"/usr/share/help/C/grilo-plugins/grilo-plugins{,-0.3}.xml
+}
diff --git a/media-plugins/grilo-plugins/metadata.xml b/media-plugins/grilo-plugins/metadata.xml
index a6af364af1d..900b1b4b335 100644
--- a/media-plugins/grilo-plugins/metadata.xml
+++ b/media-plugins/grilo-plugins/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo GNOME Desktop</name>
</maintainer>
<use>
+ <flag name="chromaprint">Enable Chromaprint support</flag>
<flag name="daap">Enable dmap support through <pkg>net-libs/libdmapsharing</pkg></flag>
<flag name="flickr">Enable Flickr support</flag>
<flag name="freebox">Build support for viewing TV channels using Freebox</flag>