summaryrefslogtreecommitdiff
path: root/media-radio/svxlink
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2017-12-27 18:40:46 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2017-12-27 18:46:15 +0100
commit0ca6aa99f6e02dc23c1b27269c681a67cada472e (patch)
treed5c9a274f2674d03e3598262c91602beef12fe25 /media-radio/svxlink
parent1f72bebd687d04304cc82503682b146452493436 (diff)
downloadgentoo-0ca6aa99f6e02dc23c1b27269c681a67cada472e.tar.gz
gentoo-0ca6aa99f6e02dc23c1b27269c681a67cada472e.tar.xz
media-radio/svxlink: Backport fix for newer gcc from github.
Thanks toralf. Closes: https://bugs.gentoo.org/639592 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-radio/svxlink')
-rw-r--r--media-radio/svxlink/files/svxlink-15.11-gcc72.patch12
-rw-r--r--media-radio/svxlink/svxlink-15.11.ebuild5
2 files changed, 16 insertions, 1 deletions
diff --git a/media-radio/svxlink/files/svxlink-15.11-gcc72.patch b/media-radio/svxlink/files/svxlink-15.11-gcc72.patch
new file mode 100644
index 00000000000..a55894c62f3
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink-15.11-gcc72.patch
@@ -0,0 +1,12 @@
+# backported fix for newer compilers
+--- src/async/audio/AsyncAudioDeviceAlsa.cpp.orig 2017-12-27 16:32:27.185098621 +0000
++++ src/async/audio/AsyncAudioDeviceAlsa.cpp 2017-12-27 16:33:33.468067578 +0000
+@@ -548,7 +548,7 @@
+ return false;
+ }
+
+- if (::abs(real_rate - sample_rate) > 100)
++ if (::abs(static_cast<int>(real_rate) - sample_rate) > 100)
+ {
+ cerr << "*** ERROR: The sample rate could not be set to "
+ << sample_rate << "Hz for ALSA device \"" << dev_name << "\". "
diff --git a/media-radio/svxlink/svxlink-15.11.ebuild b/media-radio/svxlink/svxlink-15.11.ebuild
index de0def111ea..0eac5fc40fe 100644
--- a/media-radio/svxlink/svxlink-15.11.ebuild
+++ b/media-radio/svxlink/svxlink-15.11.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit cmake-utils qt4-r2 user
+inherit cmake-utils eutils qt4-r2 user
CMAKE_USE_DIR="${S}/src"
@@ -34,6 +34,9 @@ pkg_setup() {
}
src_prepare() {
+ # fix compilation problem with newer gcc bug #639592
+ epatch "${FILESDIR}"/${P}-gcc72.patch
+
cmake-utils_src_prepare
# drop deprecated desktop category (bug #475730)
sed -i -e "s:Categories=Application;:Categories=:g" src/qtel/qtel.desktop || die