summaryrefslogtreecommitdiff
path: root/media-sound/bpmdetect
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/bpmdetect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/bpmdetect')
-rw-r--r--media-sound/bpmdetect/Manifest1
-rw-r--r--media-sound/bpmdetect/bpmdetect-0.6.1.ebuild45
-rw-r--r--media-sound/bpmdetect/files/bpmdetect-0.6.1-gcc44_and_fmodex_path.patch36
-rw-r--r--media-sound/bpmdetect/metadata.xml8
4 files changed, 90 insertions, 0 deletions
diff --git a/media-sound/bpmdetect/Manifest b/media-sound/bpmdetect/Manifest
new file mode 100644
index 00000000000..9cd33161d15
--- /dev/null
+++ b/media-sound/bpmdetect/Manifest
@@ -0,0 +1 @@
+DIST bpmdetect-0.6.1-src.tar.bz2 1433211 SHA256 2b7fb3e0595b5b9dd63381c079140656df196be1bee3365807f18ef4593c0b8f
diff --git a/media-sound/bpmdetect/bpmdetect-0.6.1.ebuild b/media-sound/bpmdetect/bpmdetect-0.6.1.ebuild
new file mode 100644
index 00000000000..8f35e919c79
--- /dev/null
+++ b/media-sound/bpmdetect/bpmdetect-0.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils multilib
+
+DESCRIPTION="Automatic BPM detection utility"
+HOMEPAGE="http://sourceforge.net/projects/bpmdetect"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/taglib
+ media-libs/id3lib
+ >=media-libs/fmod-4.25.07-r1:1
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ dev-util/scons
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44_and_fmodex_path.patch
+ sed -i -e "s:-O2:${CXXFLAGS}:" src/SConscript || die "sed failed"
+}
+
+src_configure() { :; }
+
+src_compile() {
+ export QTDIR="/usr/$(get_libdir)"
+ scons prefix=/usr || die "scons failed"
+}
+
+src_install() {
+ dobin build/${PN} || die "dobin failed"
+ doicon src/${PN}-icon.png
+ domenu src/${PN}.desktop
+ dodoc authors readme todo
+}
diff --git a/media-sound/bpmdetect/files/bpmdetect-0.6.1-gcc44_and_fmodex_path.patch b/media-sound/bpmdetect/files/bpmdetect-0.6.1-gcc44_and_fmodex_path.patch
new file mode 100644
index 00000000000..c2996164561
--- /dev/null
+++ b/media-sound/bpmdetect/files/bpmdetect-0.6.1-gcc44_and_fmodex_path.patch
@@ -0,0 +1,36 @@
+diff -ur bpmdetect.orig/src/main.cpp bpmdetect/src/main.cpp
+--- bpmdetect.orig/src/main.cpp 2008-05-01 12:50:18.000000000 +0300
++++ bpmdetect/src/main.cpp 2009-06-03 22:24:56.000000000 +0300
+@@ -20,6 +20,8 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <cstdio>
++
+ #ifndef NO_GUI
+ #ifdef USE_QT3
+ #include "dlgbpmdetect3.h"
+diff -ur bpmdetect.orig/src/SConscript bpmdetect/src/SConscript
+--- bpmdetect.orig/src/SConscript 2008-04-24 19:49:52.000000000 +0300
++++ bpmdetect/src/SConscript 2009-06-03 22:33:57.000000000 +0300
+@@ -234,7 +234,7 @@
+
+ env.Append(LIBS = ['id3', 'fmodex', 'z'])
+ env.Append(CPPPATH = ['.', '..', '../includes'])
+- env.Append(LIBPATH = ['.', '../libs'])
++ env.Append(LIBPATH = ['.', '../libs', '/opt/fmodex/api/lib'])
+ env['ISCONFIGURED']=1
+ # And finally save the options in the cache
+ opts.Save(cachefile, env)
+diff -ur bpmdetect.orig/src/track.cpp bpmdetect/src/track.cpp
+--- bpmdetect.orig/src/track.cpp 2008-04-25 22:33:18.000000000 +0300
++++ bpmdetect/src/track.cpp 2009-06-03 22:26:24.000000000 +0300
+@@ -20,6 +20,8 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <cstdio>
++
+ #include "track.h"
+ #include "trackfmod.h"
+ #include "BPMDetect.h"
diff --git a/media-sound/bpmdetect/metadata.xml b/media-sound/bpmdetect/metadata.xml
new file mode 100644
index 00000000000..605408c4b7f
--- /dev/null
+++ b/media-sound/bpmdetect/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">bpmdetect</remote-id>
+ </upstream>
+</pkgmetadata>