summaryrefslogtreecommitdiff
path: root/media-sound/cd-discid
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/cd-discid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/cd-discid')
-rw-r--r--media-sound/cd-discid/Manifest2
-rw-r--r--media-sound/cd-discid/cd-discid-1.3.ebuild31
-rw-r--r--media-sound/cd-discid/cd-discid-1.4.ebuild26
-rw-r--r--media-sound/cd-discid/metadata.xml8
4 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/cd-discid/Manifest b/media-sound/cd-discid/Manifest
new file mode 100644
index 00000000000..118150e0e84
--- /dev/null
+++ b/media-sound/cd-discid/Manifest
@@ -0,0 +1,2 @@
+DIST cd-discid-1.3.tar.gz 12324 SHA256 5396f862bf5fe81dee615de244f77c39b91612890c5c7ae42f93e8040cf6cae1 SHA512 947910ba2d8f8b3e82ea1ac155d38591ce6b574fb26e750c0462ad535dde546e627b5348e54094ddc6b1933cf928aadcccc79c81db72423c3e6f14b812c5e1b3 WHIRLPOOL 45eea1f33bf9a3a597a1c1e6f1c7a1e0d7e8204b4831bd7318c5535ee07fa08369c5a4da15a0c2ba2fd4cf1ce798aa06ab2d622401243bc84f1ff83add1bd5d9
+DIST cd-discid-1.4.tar.gz 12487 SHA256 b6b72db2934a6e2560c7aa26c52c88e27fba571e39a303ebf9cef022aa509d43 SHA512 f601ea8b7ad73e22ebafc22c392f120fe2e5ed2e275f8c53aab92b27ca1738b9f0c53dd5ed7a012915fe8f1f30fd2356f973895e2dbfe649937930e69faa0c29 WHIRLPOOL bfd8e1757699b15ed0dabe77dc24caaeeea24640ac4b5190a8df91a191f997c73d66026b50949ac290d36d36b6a20da9ba76b849d90af8994ecf3d24c17ca275
diff --git a/media-sound/cd-discid/cd-discid-1.3.ebuild b/media-sound/cd-discid/cd-discid-1.3.ebuild
new file mode 100644
index 00000000000..651a07bb638
--- /dev/null
+++ b/media-sound/cd-discid/cd-discid-1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="returns the disc id for the cd in the cd-rom drive"
+HOMEPAGE="https://github.com/taem/cd-discid"
+SRC_URI="https://github.com/taem/${PN}/tarball/upstream/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 x86"
+IUSE=""
+
+DOCS=( changelog README )
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}" || die
+}
+
+src_prepare() {
+ sed -i -e "/^\(C\|LD\)FLAGS/d" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
diff --git a/media-sound/cd-discid/cd-discid-1.4.ebuild b/media-sound/cd-discid/cd-discid-1.4.ebuild
new file mode 100644
index 00000000000..55445152792
--- /dev/null
+++ b/media-sound/cd-discid/cd-discid-1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="returns the disc id for the cd in the cd-rom drive"
+HOMEPAGE="https://github.com/taem/cd-discid"
+SRC_URI="https://github.com/taem/${PN}/archive/upstream/1.4.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 x86"
+
+S=${WORKDIR}/${PN}-upstream-${PV}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr STRIP=/bin/true install
+ dodoc changelog README
+}
diff --git a/media-sound/cd-discid/metadata.xml b/media-sound/cd-discid/metadata.xml
new file mode 100644
index 00000000000..0e440984353
--- /dev/null
+++ b/media-sound/cd-discid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="github">taem/cd-discid</remote-id>
+ </upstream>
+</pkgmetadata>