summaryrefslogtreecommitdiff
path: root/media-sound/dagrab
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/dagrab
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/dagrab')
-rw-r--r--media-sound/dagrab/Manifest1
-rw-r--r--media-sound/dagrab/dagrab-0.513.ebuild32
-rw-r--r--media-sound/dagrab/files/dagrab-0.513-build.patch50
-rw-r--r--media-sound/dagrab/files/dagrab-0.513-freedb.patch25
-rw-r--r--media-sound/dagrab/metadata.xml5
5 files changed, 113 insertions, 0 deletions
diff --git a/media-sound/dagrab/Manifest b/media-sound/dagrab/Manifest
new file mode 100644
index 00000000000..a40f8f7b99b
--- /dev/null
+++ b/media-sound/dagrab/Manifest
@@ -0,0 +1 @@
+DIST dagrab-S0.513.tgz 38747 RMD160 43ad50d7be07320ce6ce1bd5f5fd9e89fcb15e96 SHA1 d78c134c78b53cc27de48af0984c741b217ef0e8 SHA256 f8e4d30fc5943d1806a3320150256219bc63724f4cc7787e01d1f11fd3b3cf8a
diff --git a/media-sound/dagrab/dagrab-0.513.ebuild b/media-sound/dagrab/dagrab-0.513.ebuild
new file mode 100644
index 00000000000..9d9879d5314
--- /dev/null
+++ b/media-sound/dagrab/dagrab-0.513.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P="${PN}-S${PV}"
+DESCRIPTION="fixed point cd ripper"
+HOMEPAGE="http://vertigo.fme.vutbr.cz/~stibor/dagrab.html"
+SRC_URI="http://ashtray.jz.gts.cz/~smsti/archiv/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-freedb.patch
+}
+
+src_install() {
+ dobin dagrab || die
+ dodoc BUGS CHANGES FAQ grab TODO
+ doman dagrab.1
+}
diff --git a/media-sound/dagrab/files/dagrab-0.513-build.patch b/media-sound/dagrab/files/dagrab-0.513-build.patch
new file mode 100644
index 00000000000..43408d56b37
--- /dev/null
+++ b/media-sound/dagrab/files/dagrab-0.513-build.patch
@@ -0,0 +1,50 @@
+--- dagrab-S0.513/dagrab.c
++++ dagrab-S0.513/dagrab.c
+@@ -776,6 +776,7 @@
+ thread_save(NULL);
+ #endif
+ do_not_write_now:
++ ;
+ }
+ /****************************************************************
+ * Close output file *
+--- dagrab-S0.513/jit_in.c
++++ dagrab-S0.513/jit_in.c
+@@ -74,5 +74,6 @@
+ *p = (*(p + SSIZE) + *(p - SSIZE)) / 2;
+ view_status(ID_JITTER, NULL);
+ is_ok: /* means continue */
++ ;
+ }
+ }
+--- dagrab-S0.513/Makefile
++++ dagrab-S0.513/Makefile
+@@ -3,14 +3,12 @@
+ # Note: PTHREAD support is optional, you can comment it out
+ ################################################################################
+
+-CC= gcc
+-CFLAGS= -O ${UCD} -W -Wall -DPTHREAD #-g # #-DDEBUG
+-LDFLAGS=-O -s -lpthread # -static
+ PREFIX=/usr/local
+-
+-ifneq ($(wildcard /usr/include/linux/ucdrom.h),)
+- CFLAGS +=-DUSE_UCDROM
+-endif
++CC ?= gcc
++CFLAGS ?= -O
++CFLAGS += -W -Wall -DPTHREAD
++LDFLAGS ?= -O
++LIBS = -lpthread
+
+ all: dagrab
+
+@@ -28,7 +26,7 @@
+ err.o: dagrab.h main.h
+
+ dagrab: $(OBJ) Makefile
+- $(CC) $(LDFLAGS) $(OBJ) $(LIBS) -o dagrab
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJ) $(LIBS) -o dagrab
+
+ clean:
+ rm -f dagrab *.o *.wav *.mp[23] *.ogg .*swp *~ gmon.out tags
diff --git a/media-sound/dagrab/files/dagrab-0.513-freedb.patch b/media-sound/dagrab/files/dagrab-0.513-freedb.patch
new file mode 100644
index 00000000000..6a65576497d
--- /dev/null
+++ b/media-sound/dagrab/files/dagrab-0.513-freedb.patch
@@ -0,0 +1,25 @@
+--- dagrab.1
++++ dagrab.1
+@@ -209,7 +209,7 @@
+ .B -H
+ .I [host][:port]
+ .RS 3
+-sets the remote cddb server and/or port, defaults to de.freedb.org:888.
++sets the remote cddb server and/or port, defaults to freedb.org:8880.
+ .RE
+
+ .B -D
+--- const.h
++++ const.h
+@@ -18,9 +18,9 @@
+ #define BLEN 1024 /* length in chars of command/trackname */
+ #define OVERLAP 1 /* minimum number of sectors for overlapping */
+
+-#define CDDB_PORT 888
++#define CDDB_PORT 8880
+ #define CDDB_PATH "/usr/lib/X11/xmcd/cddb"
+-#define CDDB_HOST "de.freedb.org"
++#define CDDB_HOST "freedb.org"
+ #define CDDB_MAX 65535
+
+ #define KEYLEN 16 /* number of samples for overlap checking */
diff --git a/media-sound/dagrab/metadata.xml b/media-sound/dagrab/metadata.xml
new file mode 100644
index 00000000000..e1774e3d9ad
--- /dev/null
+++ b/media-sound/dagrab/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>