summaryrefslogtreecommitdiff
path: root/media-sound/daudio
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/daudio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/daudio')
-rw-r--r--media-sound/daudio/Manifest1
-rw-r--r--media-sound/daudio/daudio-0.3.ebuild37
-rw-r--r--media-sound/daudio/files/daudio-0.3-makefile.patch50
-rw-r--r--media-sound/daudio/files/daudio.rc20
-rw-r--r--media-sound/daudio/metadata.xml8
5 files changed, 116 insertions, 0 deletions
diff --git a/media-sound/daudio/Manifest b/media-sound/daudio/Manifest
new file mode 100644
index 00000000000..f56caa9e2c2
--- /dev/null
+++ b/media-sound/daudio/Manifest
@@ -0,0 +1 @@
+DIST daudio-0.3.tar.gz 76683 SHA256 f2abf767b6be1ff9ed0c2d2f983484bd7a41dbdc3fa7e0839729aa857d4a60f8
diff --git a/media-sound/daudio/daudio-0.3.ebuild b/media-sound/daudio/daudio-0.3.ebuild
new file mode 100644
index 00000000000..80f2168bbff
--- /dev/null
+++ b/media-sound/daudio/daudio-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Distributed audio on the local network"
+HOMEPAGE="http://daudio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+#-sparc: 0.3: static audio on local daemon. No audio when client connects to amd64 daemon
+KEYWORDS="amd64 ~ppc -sparc x86"
+
+IUSE=""
+DEPEND=">=media-libs/libmad-0.15.0b-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC
+ emake -C client || die "emake failed"
+ emake -C server || die "emake failed"
+ emake -C streamer || die "emake failed"
+}
+
+src_install() {
+ dobin client/daudioc server/daudiod streamer/dstreamer
+ newinitd "${FILESDIR}"/daudio.rc daudio
+ dodoc doc/*
+}
diff --git a/media-sound/daudio/files/daudio-0.3-makefile.patch b/media-sound/daudio/files/daudio-0.3-makefile.patch
new file mode 100644
index 00000000000..28f1215f7c9
--- /dev/null
+++ b/media-sound/daudio/files/daudio-0.3-makefile.patch
@@ -0,0 +1,50 @@
+Index: daudio-0.3/client/Makefile
+===================================================================
+--- daudio-0.3.orig/client/Makefile
++++ daudio-0.3/client/Makefile
+@@ -13,10 +13,10 @@ install: $(PROG)
+ install -c -m755 --owner=0 --group=0 -b -D daudioc $(PREFIX)/bin/daudioc
+
+ debug: $(SRCS)
+- gcc $(DEFINES) -DDEBUG $(INCLUDES) $(LIBS) -o $(PROG) $^
++ $(CC) $(CFLAGS) $(LDFLAGS) $(DEFINES) -DDEBUG $(INCLUDES) -o $(PROG) $^ $(LIBS)
+
+ $(PROG): $(SRCS)
+- gcc $(DEFINES) $(INCLUDES) $(LIBS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) -o $@ $^ $(LIBS)
+
+ clean:
+ rm -f $(PROG)
+Index: daudio-0.3/server/Makefile
+===================================================================
+--- daudio-0.3.orig/server/Makefile
++++ daudio-0.3/server/Makefile
+@@ -10,13 +10,13 @@ PREFIX = /usr/local
+ all: $(SBINS)
+
+ debug: $(SRCS)
+- gcc -g $(DEFINES) $(INCLUDES) $(LIBS) -o daudiod $^
++ $(CC) $(CFLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) -o daudiod $^ $(LIBS)
+
+ install: $(SBINS)
+ install -c -m755 --owner=0 --group=0 -b -D daudiod $(PREFIX)/bin/daudiod
+
+ $(SBINS): $(SRCS)
+- gcc $(DEFINES) $(INCLUDES) $(LIBS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) -o $@ $^ $(LIBS)
+
+ clean:
+ rm -f $(SBINS)
+Index: daudio-0.3/streamer/Makefile
+===================================================================
+--- daudio-0.3.orig/streamer/Makefile
++++ daudio-0.3/streamer/Makefile
+@@ -12,7 +12,7 @@ install: $(SBINS)
+ install -c -m755 --owner=0 --group=0 -b -D dstreamer $(PREFIX)/bin/dstreamer
+
+ $(SBINS): $(SRCS)
+- gcc $(DEFINES) $(INCLUDES) $(LIBS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) -o $@ $^ $(LIBS)
+
+ clean:
+ rm -f $(SBINS)
diff --git a/media-sound/daudio/files/daudio.rc b/media-sound/daudio/files/daudio.rc
new file mode 100644
index 00000000000..00523194a9b
--- /dev/null
+++ b/media-sound/daudio/files/daudio.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting daudio"
+ start-stop-daemon --start --quiet --background --make-pidfile --pidfile /var/run/daudio.pid --exec /usr/bin/daudiod
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping daudio"
+ start-stop-daemon --stop --quiet --pidfile /var/run/daudio.pid
+ eend $?
+}
diff --git a/media-sound/daudio/metadata.xml b/media-sound/daudio/metadata.xml
new file mode 100644
index 00000000000..0840b254c78
--- /dev/null
+++ b/media-sound/daudio/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">daudio</remote-id>
+ </upstream>
+</pkgmetadata>