summaryrefslogtreecommitdiff
path: root/media-sound/fmdrv
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/fmdrv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/fmdrv')
-rw-r--r--media-sound/fmdrv/Manifest1
-rw-r--r--media-sound/fmdrv/files/fmdrv-1.0.7-ioperm.patch20
-rw-r--r--media-sound/fmdrv/fmdrv-1.0.7.ebuild38
-rw-r--r--media-sound/fmdrv/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/media-sound/fmdrv/Manifest b/media-sound/fmdrv/Manifest
new file mode 100644
index 00000000000..525fc14076d
--- /dev/null
+++ b/media-sound/fmdrv/Manifest
@@ -0,0 +1 @@
+DIST fmdrv-1.0.7.tar.bz2 61373 SHA256 85bbb651a531e86b7aa07fa9efcb2c62344484cb3999b36539af6002188cbaa1 SHA512 d5533aee5c4c4e6a08dd2ede07c2f657edf93cf89bdb43d3453badd8dde68ec39a94820f91098192202490d59e2abda49af03737db39d2bfdd6b009a65824f1d WHIRLPOOL 8486f8ba5f61c441cae76531bb3e16962b934e0db495db3e6afc8228d38336201f1f2f5ce712a0d29363a4e77373c619b49c9f3bf26104a97d8350e5f27e9477
diff --git a/media-sound/fmdrv/files/fmdrv-1.0.7-ioperm.patch b/media-sound/fmdrv/files/fmdrv-1.0.7-ioperm.patch
new file mode 100644
index 00000000000..ef719a4ac54
--- /dev/null
+++ b/media-sound/fmdrv/files/fmdrv-1.0.7-ioperm.patch
@@ -0,0 +1,20 @@
+--- a/sysdeps.c
++++ b/sysdeps.c
+@@ -1,17 +1,7 @@
+ #include "sysdeps.h"
+
+ #ifdef linux
+-/* A real real big bad hack. *
+- * Never try this at home! */
+-# define extern static
+-# if 0 /* This is required on older Linux versions, not anymore */
+-# include <asm/io.h>
+-# undef extern
+ # include <sys/io.h>
+-# else
+-# include <sys/io.h>
+-# undef extern
+-# endif
+ # define inportb(x) inb(x)
+ # define outportb(p,x) outb(x,p)
+ #endif
diff --git a/media-sound/fmdrv/fmdrv-1.0.7.ebuild b/media-sound/fmdrv/fmdrv-1.0.7.ebuild
new file mode 100644
index 00000000000..99a5a4512e4
--- /dev/null
+++ b/media-sound/fmdrv/fmdrv-1.0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Console mode MIDI player with builtin userland OPL2 driver"
+HOMEPAGE="http://bisqwit.iki.fi/source/fmdrv.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+LICENSE="fmdrv GPL-2" # GPL-2 only
+SLOT="0"
+KEYWORDS="x86 amd64"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ioperm.patch
+}
+
+src_configure() { :; } # it is a fake
+
+src_compile() {
+ emake fmdrv \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin fmdrv
+ dodoc README
+ dohtml README.html
+}
+
+pkg_postinst() {
+ elog "If you want to use AdLib (FM OPL2), you need to setuid /usr/bin/fmdv."
+ elog "chmod 4711 /usr/bin/fmdrv"
+}
diff --git a/media-sound/fmdrv/metadata.xml b/media-sound/fmdrv/metadata.xml
new file mode 100644
index 00000000000..e1774e3d9ad
--- /dev/null
+++ b/media-sound/fmdrv/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>