summaryrefslogtreecommitdiff
path: root/media-sound/giada
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/giada
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/giada')
-rw-r--r--media-sound/giada/Manifest1
-rw-r--r--media-sound/giada/files/giada-0.5.4-flags.patch10
-rw-r--r--media-sound/giada/files/giada-0.5.8-configure.patch50
-rw-r--r--media-sound/giada/giada-0.7.0.ebuild43
-rw-r--r--media-sound/giada/metadata.xml5
5 files changed, 109 insertions, 0 deletions
diff --git a/media-sound/giada/Manifest b/media-sound/giada/Manifest
new file mode 100644
index 00000000000..8c778981d6a
--- /dev/null
+++ b/media-sound/giada/Manifest
@@ -0,0 +1 @@
+DIST giada-0.7.0.tar.gz 200738 SHA256 493b9d7d8055ac617ef08816a44ba584c1dd429c3c01ca52877cc8163e9f3c15 SHA512 72bea7b2cced2a2ce7fe5705e0c3eea912fa58c561be8e3ae92dafb08ef7d4cedefea268ce4c71dfca1140c7e70a9bd6f5dd12b2991a8a8321d76e44bc9192d2 WHIRLPOOL 7d2aa21bb157eb9f8d1fc46b21fa02982ca6a0415b083cce2907c05fccc8e0a787ca401dcf1a3b3f3ab4624512eb622d15635566a62dbb4c62f4a444e61c58dc
diff --git a/media-sound/giada/files/giada-0.5.4-flags.patch b/media-sound/giada/files/giada-0.5.4-flags.patch
new file mode 100644
index 00000000000..17e013ccd2f
--- /dev/null
+++ b/media-sound/giada/files/giada-0.5.4-flags.patch
@@ -0,0 +1,10 @@
+--- giada-0.5.4/src/Makefile.am
++++ giada-0.5.4/src/Makefile.am
+@@ -1,6 +1,6 @@
+ AUTOMAKE_OPTIONS = foreign
+
+-AM_CXXFLAGS = -Wall -pedantic -Werror
++AM_CXXFLAGS = -Wall -pedantic
+
+ # aeffect.h (header from VST SDK) uses 'long long' which is not supported
+ # in ISO C++ 1998 and -Werror flag breaks the compilation.
diff --git a/media-sound/giada/files/giada-0.5.8-configure.patch b/media-sound/giada/files/giada-0.5.8-configure.patch
new file mode 100644
index 00000000000..c92ce0a1cc1
--- /dev/null
+++ b/media-sound/giada/files/giada-0.5.8-configure.patch
@@ -0,0 +1,50 @@
+--- giada-0.5.8/configure.ac
++++ giada-0.5.8/configure.ac
+@@ -52,6 +52,27 @@
+ [AC_DEFINE(WITH_VST)]
+ )
+
++AC_ARG_ENABLE(
++ alsa,
++ AS_HELP_STRING([--disable-alsa], [disable alsa support]),
++ [AC_DEFINE(WITH_ALSA)]
++)
++AM_CONDITIONAL(ALSA, test "x$enable_alsa" = "xtrue")
++
++AC_ARG_ENABLE(
++ jack,
++ AS_HELP_STRING([--enable-jack], [enable jack support]),
++ [AC_DEFINE(WITH_JACK)]
++)
++AM_CONDITIONAL(JACK, test "x$enable_jack" = "xtrue")
++
++AC_ARG_ENABLE(
++ pulse,
++ AS_HELP_STRING([--enable-pulse], [enable pulseaudio support]),
++ [AC_DEFINE(WITH_PULSE)]
++)
++AM_CONDITIONAL(PULSE, test "x$enable_pulse" = "xtrue")
++
+ # ----------------------------------------------------------------------
+
+ # Checks for programs.
+--- giada-0.5.8/src/Makefile.am
++++ giada-0.5.8/src/Makefile.am
+@@ -39,7 +39,16 @@
+ # inside configure.ac
+ if LINUX
+ giada_LDADD = -lsndfile -lfltk -lXext -lX11 -lXft -lXpm -lm -lrtaudio \
+- -ljack -lasound -lpthread -ldl -lpulse-simple -lsamplerate
++ -lpthread -ldl -lsamplerate
++if ALSA
++giada_LDADD += -lasound
++endif
++if JACK
++giada_LDADD += -ljack
++endif
++if PULSE
++giada_LDADD += -lpulse-simple
++endif
+ endif
+ if WINDOWS
+ giada_LDADD = -lole32 -lrtaudio -ldsound -lwinmm -lwsock32 -lm \
diff --git a/media-sound/giada/giada-0.7.0.ebuild b/media-sound/giada/giada-0.7.0.ebuild
new file mode 100644
index 00000000000..867557fb1a4
--- /dev/null
+++ b/media-sound/giada/giada-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="A free, minimal, hardcore audio tool for DJs and live performers"
+HOMEPAGE="http://www.giadamusic.com/"
+SRC_URI="http://www.giadamusic.com/download-action.php?os=source&version=${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack pulseaudio"
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+RDEPEND="media-libs/libsndfile
+ >=media-libs/libsamplerate-0.1.8
+ media-libs/rtaudio[alsa?,jack?,pulseaudio?]
+ x11-libs/fltk:1
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.4-flags.patch
+ epatch "${FILESDIR}"/${PN}-0.5.8-configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags $(fltk-config --cflags)
+ append-ldflags $(fltk-config --ldflags)
+
+ econf \
+ --target=linux \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable pulseaudio pulse)
+}
diff --git a/media-sound/giada/metadata.xml b/media-sound/giada/metadata.xml
new file mode 100644
index 00000000000..0dc3775f83d
--- /dev/null
+++ b/media-sound/giada/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+</pkgmetadata>