summaryrefslogtreecommitdiff
path: root/media-sound/grip
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/grip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/Manifest1
-rw-r--r--media-sound/grip/files/grip-3.3.1-implicit-declaration.patch32
-rw-r--r--media-sound/grip/files/grip-3.3.1-invalid-genre-size.patch30
-rw-r--r--media-sound/grip/grip-3.3.1-r3.ebuild53
-rw-r--r--media-sound/grip/metadata.xml8
5 files changed, 124 insertions, 0 deletions
diff --git a/media-sound/grip/Manifest b/media-sound/grip/Manifest
new file mode 100644
index 00000000000..fc3ac75924b
--- /dev/null
+++ b/media-sound/grip/Manifest
@@ -0,0 +1 @@
+DIST grip-3.3.1.tar.gz 812562 SHA256 d46394a1062ed066f9c633b010fd1059e63d9ed791bbb7a85bc6567cf0fd66fd
diff --git a/media-sound/grip/files/grip-3.3.1-implicit-declaration.patch b/media-sound/grip/files/grip-3.3.1-implicit-declaration.patch
new file mode 100644
index 00000000000..2319b772a9b
--- /dev/null
+++ b/media-sound/grip/files/grip-3.3.1-implicit-declaration.patch
@@ -0,0 +1,32 @@
+--- grip-3.3.1/src/status_window.c
++++ grip-3.3.1/src/status_window.c
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <unistd.h>
++#include <string.h>
+ #include <fcntl.h>
+ #include <vte/vte.h>
+ #include "status_window.h"
+--- grip-3.3.1/src/tray.c
++++ grip-3.3.1/src/tray.c
+@@ -20,6 +20,9 @@
+ * USA
+ */
+
++#include "cdplay.h"
++#include "common.h"
++#include "rip.h"
+ #include "tray.h"
+ #include "../pixmaps/rip1.xpm"
+ #include "../pixmaps/menuplay.xpm"
+--- grip-3.3.1/src/cdplay.c
++++ grip-3.3.1/src/cdplay.c
+@@ -28,6 +28,7 @@
+ #include "cddev.h"
+ #include "discedit.h"
+ #include "dialog.h"
++#include "tray.h"
+ #include "rip.h"
+ #include "grip_id3.h"
+
diff --git a/media-sound/grip/files/grip-3.3.1-invalid-genre-size.patch b/media-sound/grip/files/grip-3.3.1-invalid-genre-size.patch
new file mode 100644
index 00000000000..c826fc6e2e8
--- /dev/null
+++ b/media-sound/grip/files/grip-3.3.1-invalid-genre-size.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/285105
+
+--- grip-3.3.1/src/id3.c
++++ grip-3.3.1/src/id3.c
+@@ -252,8 +252,8 @@
+
+ if ( frames[ i ] ) {
+ char *c_data = NULL;
+- char gen[ 5 ] = "( )";
+- char trk[ 4 ] = " ";
++ char gen[ 6 ] = "( )"; /* max unsigned char: 255 */
++ char trk[ 3 ] = " "; /* max CDDA tracks: 99 */
+
+ switch( frameids[ i ] ) {
+ case ID3FID_TITLE:
+@@ -278,12 +278,12 @@
+
+ case ID3FID_CONTENTTYPE:
+ c_data = gen;
+- sprintf( gen, "(%d)", genre ); /* XXX */
++ snprintf( gen, 6, "(%d)", genre );
+ break;
+
+ case ID3FID_TRACKNUM:
+ c_data = trk;
+- sprintf( trk, "%d", tracknum ); /* XXX */
++ snprintf( trk, 3, "%d", tracknum );
+ break;
+
+ default:
diff --git a/media-sound/grip/grip-3.3.1-r3.ebuild b/media-sound/grip/grip-3.3.1-r3.ebuild
new file mode 100644
index 00000000000..e8fc95363bb
--- /dev/null
+++ b/media-sound/grip/grip-3.3.1-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils flag-o-matic toolchain-funcs libtool
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="http://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="nls vorbis"
+
+RDEPEND=">=x11-libs/gtk+-2.2:2
+ x11-libs/vte:0
+ media-sound/lame
+ media-sound/cdparanoia
+ >=media-libs/id3lib-3.8.3
+ >=gnome-base/libgnomeui-2.2.0
+ >=gnome-base/orbit-2
+ net-misc/curl
+ vorbis? ( media-sound/vorbis-tools )"
+# gnome-extra/yelp, see bug 416843
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-implicit-declaration.patch
+ epatch "${FILESDIR}"/${P}-invalid-genre-size.patch #285105
+ # fix include syntax for newer versions of bash
+ sed -i '/[.] conftest[.]id3/s: c: ./c:' configure || die
+ elibtoolize
+}
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nl pl_PL pt_BR ru zh_CN zh_HK zh_TW
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS CREDITS ChangeLog README TODO
+}
diff --git a/media-sound/grip/metadata.xml b/media-sound/grip/metadata.xml
new file mode 100644
index 00000000000..b9d0f75b516
--- /dev/null
+++ b/media-sound/grip/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">grip</remote-id>
+ </upstream>
+</pkgmetadata>