summaryrefslogtreecommitdiff
path: root/media-sound/jack-smf-utils
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2018-11-23 21:00:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-25 00:16:42 +0100
commitb30fa91ef71d9e6c41f22118b4cee1999b403357 (patch)
tree0fd5c918fe8249eecac2643c5c08d238071e7197 /media-sound/jack-smf-utils
parentcd1325eb7f1d815a5853b7de8ee6392974378f04 (diff)
downloadgentoo-b30fa91ef71d9e6c41f22118b4cee1999b403357.tar.gz
gentoo-b30fa91ef71d9e6c41f22118b4cee1999b403357.tar.xz
media-sound/jack-smf-utils: EAPI-7 bump, DEPEND on virtual/jack
- Drop version specifier from dev-libs/glib dependency. - Sort dependencies. - Update HOMEPAGE and SRC_URI. The old ones are no longer reachable, and it looks like the project is now hosted on SourceForge. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Karl Linden <karl.j.linden@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10440 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/jack-smf-utils')
-rw-r--r--media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild28
-rw-r--r--media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild31
2 files changed, 28 insertions, 31 deletions
diff --git a/media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild b/media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild
new file mode 100644
index 00000000000..edaef45d9e2
--- /dev/null
+++ b/media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utilities for MIDI streams and files using Jack MIDI"
+HOMEPAGE="https://sourceforge.net/projects/jack-smf-utils/"
+SRC_URI="https://sourceforge.net/projects/jack-smf-utils/files/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lash readline"
+
+RDEPEND="
+ dev-libs/glib
+ virtual/jack
+ lash? ( media-sound/lash )
+ readline? ( sys-libs/readline:0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with lash) \
+ $(use_with readline)
+}
diff --git a/media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild b/media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild
deleted file mode 100644
index c8fe7a6a7c9..00000000000
--- a/media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-DESCRIPTION="Utilities for MIDI streams and files using Jack MIDI"
-HOMEPAGE="http://pin.if.uz.zgora.pl/~trasz/jack-smf-utils/"
-SRC_URI="http://pin.if.uz.zgora.pl/~trasz/jack-smf-utils/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="lash readline"
-
-RDEPEND="readline? ( sys-libs/readline )
- >=dev-libs/glib-2.2
- >=media-sound/jack-audio-connection-kit-0.102
- lash? ( media-sound/lash )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_compile() {
- econf $(use_with readline) \
- $(use_with lash)
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS TODO
-}