summaryrefslogtreecommitdiff
path: root/media-sound/lilypond
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2015-10-31 14:04:47 +0100
committerKarl Linden <karl.j.linden@gmail.com>2015-11-04 17:16:35 +0100
commitb01a4bd24dff326307247ae5fa9d245b12904b46 (patch)
tree69e6b82b5bc68146b8957525d7be39b6a56f751e /media-sound/lilypond
parent0acbc50092d0f64835ba71ebf7f798d8e3f08f7a (diff)
downloadgentoo-b01a4bd24dff326307247ae5fa9d245b12904b46.tar.gz
gentoo-b01a4bd24dff326307247ae5fa9d245b12904b46.tar.xz
media-sound/lilypond: fix compilation with fontforge wrt #557160
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-sound/lilypond')
-rw-r--r--media-sound/lilypond/files/lilypond-2.18.2-fontforge.patch29
-rw-r--r--media-sound/lilypond/lilypond-2.18.2.ebuild3
2 files changed, 31 insertions, 1 deletions
diff --git a/media-sound/lilypond/files/lilypond-2.18.2-fontforge.patch b/media-sound/lilypond/files/lilypond-2.18.2-fontforge.patch
new file mode 100644
index 00000000000..cfd3295b394
--- /dev/null
+++ b/media-sound/lilypond/files/lilypond-2.18.2-fontforge.patch
@@ -0,0 +1,29 @@
+From a832764e7300d48468a6812077b899a4beed271b Mon Sep 17 00:00:00 2001
+From: Masamichi Hosoda <trueroad@trueroad.jp>
+Date: Sat, 22 Aug 2015 21:20:17 +0900
+Subject: [PATCH] Fix fontforge version detection
+
+Newer fontforge shows git hash in `fontforge --version`.
+In that case, configure script
+might recognize it as date (version).
+---
+ aclocal.m4 | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/aclocal.m4 b/aclocal.m4
+index 48d0b77..0037c58 100644
+--- a/aclocal.m4
++++ b/aclocal.m4
+@@ -42,7 +42,8 @@ AC_DEFUN(STEPMAKE_GET_VERSION, [
+
+ if test -z "$_ver"; then
+ ## If empty, try date [fontforge]
+- eval _ver=\"\`("$1" --version || "$1" -V) 2>&1 | grep '[0-9]\{6,8\}' \
++ eval _ver=\"\`("$1" --version || "$1" -V) 2>&1 \
++ | grep '\(^\|[^0-9a-f]\)[0-9]\{6,8\}\([^0-9a-f]\|$\)' \
+ | head -n 1 \
+ | sed -e 's/^[^.0-9]*//' -e 's/[^.0-9]*$//'\`\"
+ fi
+--
+2.6.2
+
diff --git a/media-sound/lilypond/lilypond-2.18.2.ebuild b/media-sound/lilypond/lilypond-2.18.2.ebuild
index 2604de192bb..02301ed46db 100644
--- a/media-sound/lilypond/lilypond-2.18.2.ebuild
+++ b/media-sound/lilypond/lilypond-2.18.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -58,6 +58,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.17.2-tex-docs.patch
+ epatch "${FILESDIR}"/${P}-fontforge.patch
if ! use vim-syntax ; then
sed -i 's/vim//' GNUmakefile.in || die